Showing questions tagged: اعرض كل الأسئلة
  • حُلّت

Can't import passwords from csv file

Hey all , i made backup via "export passwords" via password tab and i came back to my pc to and tried to import via csv file but when i pick my csv file nothing happens ,… (read more)

Hey all , i made backup via "export passwords" via password tab and i came back to my pc to and tried to import via csv file but when i pick my csv file nothing happens , any ideas ?

Asked by Aiakos 5 months ago

Answered by Aiakos 5 months ago

  • حُلّت

Slow Start Up on Ubuntu 22.04 wXFCE

Hello, I've spent several hours today trying to fix FireFox slow start up on my system. After start up (about 2 full minutes), everything works normally. The hardware is… (read more)

Hello,

I've spent several hours today trying to fix FireFox slow start up on my system. After start up (about 2 full minutes), everything works normally. The hardware is an ASUS A88xm-A MB, A10-6800K processor, 16G DDR3, runs OS and programs off an SSD. I worked through all the slow startup suggestions, ran memtest (0 Errors, 1 Pass), disabled all add ons, (even the OpenH264 video codec (I use the onboard HDMI, no graphics card)), turned off hardware acceleration, etc. When starting in troubleshoot mode, less than 30 seconds, (acceptable), but I really don't know where to begin with the "More Troubleshooting Information" when I look at the table generated by it. There have been no other problems to date with the system, and the long start-up time began with 20.04 Ubuntu (about a minute), then got worse when I upgraded to 22.04 to try to solve THAT problem. Currently running FF 104.0, and the update page says wait for a distro update if that is how it was installed. I believe 104.0 is the latest Linux 64b version though. All updates to the system are done as soon as I'm notified of them. there have been none since the upgrade a few days ago.

Any suggestions? Gotta get some sleep now... TIA, Dave

Asked by dkosewick 5 months ago

Answered by dkosewick 5 months ago

  • حُلّت

Firefox 104.0.2 arbitrarily freezes (Ubuntu 22.04)

I upgraded to Ubuntu 22.04 recently. Since then Firefox 104.0.2 (64-bit) has been arbitrarily freezing; sometimes i have to restart the computer while most of the times I… (read more)

I upgraded to Ubuntu 22.04 recently. Since then Firefox 104.0.2 (64-bit) has been arbitrarily freezing; sometimes i have to restart the computer while most of the times I am able to kill the Firefox main process and restart Firefox.

The freeze occurs when i try to save a Web page; i don't see any "logic" as to which Web pages cause Firefox to freeze. It seems totally arbitrary.

I clear my downloads list everyday (sometimes more frequently than that) and clear cookies & cache everyday.

I have selected "no proxy" by default, in 'Connection Settings'.

This never happened until after i upgraded to Ubuntu 22.04.

I've browsed the support pages and don't find anything relevant to my problem. If I'm overlooking something, I apologize in advance!

I have attached a 'screen capture' image of Firefox processes just before i killed the main process.

Thanks in advance for any suggestions. Ramki

Asked by moccsha 4 months ago

Answered by jonzn4SUSE 4 months ago

  • حُلّت

youtube thumbnails are grey

for the past several days, my youtube thumbnails have been grey boxes. they aren't the standard "no thumbnail :(" grey, instead just a block of grey. this is not the case… (read more)

for the past several days, my youtube thumbnails have been grey boxes. they aren't the standard "no thumbnail :(" grey, instead just a block of grey.

this is not the case for youtube on chrome or on the app. i've tried the following: - restarting firefox (multiple times) - clearing the cache for youtube - reinstalling firefox - restarting my computer - logging out and logging back into my youtube account - using firefox in a private browser

please help.

Asked by MARTIN 5 months ago

Answered by cor-el 5 months ago

  • حُلّت

How do I delete an autofill email address?

Running v104.0.2. (UK) Whenever I have an 'email box', I get an autofill email address appearing I wish to delete. When I highlight the address, and hit 'delete' it doesn… (read more)

Running v104.0.2. (UK) Whenever I have an 'email box', I get an autofill email address appearing I wish to delete. When I highlight the address, and hit 'delete' it doesn't work. On searching a method, I get the suggestion to go into settings and drill down in the 'Forms & Autofill' section in 'privacy' settings, but my FireFox has no such section.

I then tried to 'activate' the section by going into 'about:config' and changing 'extensions.formautofill.available' from, 'detect', to 'on', it made no difference, I still have no 'Forms & Autofill' section in settings.

How can something so simple be so complicated?

How do I delete an autofill email address?

Asked by Stephen5000 4 months ago

Answered by cor-el 4 months ago

  • حُلّت

OpenH264 fails to install with HTTPS-Only mode enabled

"OpenH264 Video Codec provided by Cisco Systems, Inc." plugin will sit in the "will be installed shortly" status forever if you have HTTPS-Only mode enabled. I have been … (read more)

"OpenH264 Video Codec provided by Cisco Systems, Inc." plugin will sit in the "will be installed shortly" status forever if you have HTTPS-Only mode enabled. I have been pulling my hair out for the last few days trying to figure out why I couldn't play YouTube or many other sites videos.

Turns out the site that the library is downloaded from has a bad certificate installed: https://ciscobinary.openh264.org/libopenh264-2.3.0-linux64.6.so.bz2

``` Websites prove their identity via certificates. Firefox does not trust this site because it uses a certificate that is not valid for ciscobinary.openh264.org. The certificate is only valid for the following names: a248.e.akamai.net, *.akamaihd-staging.net, *.akamaihd.net, *.akamaized-staging.net, *.akamaized.net

Error code: SSL_ERROR_BAD_CERT_DOMAIN ```

OS: Fedora 36 Firefox Version: 104.0 (64-bit)

Asked by Nickolas Gupton 5 months ago

Answered by Nickolas Gupton 5 months ago

  • حُلّت

Other Bookmarks in the Firefox Toolbar is missing

I had an arrow on the right side of my FF Toolbar for "Other Bookmarks". Recently it went missing. I have many bookmarks under that heading, and can get to them through… (read more)

I had an arrow on the right side of my FF Toolbar for "Other Bookmarks". Recently it went missing. I have many bookmarks under that heading, and can get to them through the Bookmarks Manager, but no arrow on the Toolbar. How can I get it back?

Asked by Barry_Merchant 5 months ago

Answered by jscher2000 - Support Volunteer 4 months ago

  • حُلّت

Firefox prefers IPv4 address in a dual-stack environment

Hi, I'm using IPv4 as well as IPv6 addresses in my home network. But Firefox uses always the IPv4 connection when I open a website. When I open the same website in MS Edg… (read more)

Hi,

I'm using IPv4 as well as IPv6 addresses in my home network. But Firefox uses always the IPv4 connection when I open a website. When I open the same website in MS Edge, the IPv6 connection is used.

I've captured the network traffic during opening a website in Firefox, which is reachable over IPv4 and IPv6. First I see two DNS queries (A and AAAA) for the domain name. Both responses containing the correct IP address, and they arrive nearly at the same time at the client. Next I can see the TCP handshake. But it's send between the IPv4 address only. No IPv6 connection was attempted.

When I run the IPv6 test at https://test-ipv6.com, the IPv6 resuls are nearly fine. Only the web browser test says "Your browser has real working IPv6 address - but is avoiding using it."

When I run the same test in MS Edge, all tests are fine.

So it seems that this is not a OS or network issue. It affects Firefox only.

What I've already tried:

  • Disabled all extensions
  • Created a new profile
  • Used the IPv6 address of the website instead of the FQDN -> Works fine.
  • Checked DNS cache of Firefox (about:networking). It contains the IPv4 and IPv6 addresses of the requested websites

I guess that Firefox prefers the A record for some reason. But I've no idea why. Has anybody an idea what could causing this?

Thanks.

Jas Man

Asked by JasMan 5 months ago

Answered by JasMan 5 months ago

  • حُلّت

Expired cookie breaks Azure AD B2C auth (with Blazor and MSAL)

Hi all, is expired cookies management changed lately? Authentication doesn't work anymore in following use case. Question is all about FF for windows, while usually I'm o… (read more)

Hi all, is expired cookies management changed lately? Authentication doesn't work anymore in following use case. Question is all about FF for windows, while usually I'm on FF Android, Edge and Chrome for Windows and all these browsers are working correctly.

My working web app (static blazor wasm standalone) is interactively authenticating in Azure AD B2C using Microsoft.Authentication.WebAssembly.Msal library (like MSAL.js), API is an Azure Function protected through AAD B2C.

Login request successfully invokes Signin/Signup B2C flow with popup to myb2ctenant.b2clogin.com but breaks navigating to auth protected pages or backend apis.

From DevTools I see that every request to following b2c endpoints sets an expired cookie (expired 10 years before, year is now 2012):

When user clicks login: GET /myb2ctenant.onmicrosoft.com/b2c_1_sinsup/v2.0/.well-known/openid-configuration

Returning from login confirmation: GET /myb2ctenant.onmicrosoft.com/B2C_1_SInSUp/api/CombinedSigninAndSignup/confirmed?rememberMe=false&csrf_token=xxx

for example: Set-Cookie: x-ms-cpim-trans=; domain=myb2ctenant.b2clogin.com; expires=Fri, 14-Sep-2012 12:46:46 GMT; path=/; SameSite=None; secure; HttpOnly

FF registers this warning in console:

Cookie “x-ms-cpim-trans” has been rejected because it is already expired

Following when MSAL execute a request to /myb2ctenant.onmicrosoft.com/b2c_1_sinsup/oauth2/v2.0/authorize?xxxx

Response always contains:

Location: https://blazorapp.xx.web.core.windows.net/authentication/login-callback#error= interaction_required&error_description=AADB2C90077%3a+User+does+not+have+an+existing+session+and+request+prompt+parameter+has+a+value+of+%27None%27.%0d%0a

All other browsers are working... Thanks in advance for any help

Asked by croma 4 months ago

Answered by jscher2000 - Support Volunteer 4 months ago

  • حُلّت

PDFs are opening in browser AND downloading

In my Firefox settings, I have PDF files set to "Open in Firefox". When I click on a PDF file, Firefox DOES open the PDF in a new browser tab, but the PDF ALSO downloads … (read more)

In my Firefox settings, I have PDF files set to "Open in Firefox".

When I click on a PDF file, Firefox DOES open the PDF in a new browser tab, but the PDF ALSO downloads to my desktop (both!). How can I stop it from downloading?

Asked by gtg254k 5 months ago

Answered by jscher2000 - Support Volunteer 5 months ago

  • حُلّت

Dynamic text selection doesn't work

Selecting text on any page, there's no visual feedback of what is selected until mouse is released. There's no feedback that selection starts when mouse button is pressed… (read more)

Selecting text on any page, there's no visual feedback of what is selected until mouse is released.

There's no feedback that selection starts when mouse button is pressed down, no visual feedback while moving the mouse with the button pressed and only upon releasing the button do I get to see the selection.

Selecting works fine in other browsers (chromium) and was working the other day before I did a fresh install of Ubuntu 22.04 (was using 20.04 before) wiping my previous Firefox. So this issue is on an almost vanilla Firefox version 104.0.2.

(Incidentally I can highlight that version number and only that version number in the about-box and I get continuous dynamic feedback of what part of the version number I highlight, but nowhere else in Firefox.)

Asked by Local_Minimum 4 months ago

Answered by Local_Minimum 4 months ago

  • حُلّت

What is better to use in Ubuntu, a snap installation or a regular deb package?

Ubuntu is pushing snaps. However, I am not sure whether snap affects performance and other things. What is the advantage of snap for Firefox? Better security? Avoiding … (read more)

Ubuntu is pushing snaps. However, I am not sure whether snap affects performance and other things. What is the advantage of snap for Firefox? Better security? Avoiding potential library conflicts? I don't think there is any conflict with the regular Firefox deb package. Moreover, the current snap Firefox gives me errors on Ubuntu 22.04. Gtk-Message: 15:49:48.484: Failed to load module "xapp-gtk3-module" Gtk-Message: 15:49:48.486: Failed to load module "appmenu-gtk-module" Gtk-Message: 15:49:49.153: Failed to load module "canberra-gtk-module"

Gtk-Message: 15:49:49.250: Failed to load module "canberra-gtk-module"

Asked by YDUBINSKY 4 months ago

Answered by James 4 months ago

  • حُلّت

Did Not Connect: Potential Security Issue (Error Code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT)

I can't connect to my router using this same link I've always used: https://router.asus.com:8443/ I also tried: http://router.asus.com and: http://192.168.1.1/ Nothing ha… (read more)

I can't connect to my router using this same link I've always used: https://router.asus.com:8443/ I also tried: http://router.asus.com and: http://192.168.1.1/ Nothing has changed! I get a security error. See attachment. There is no "Proceed at your own risk" option. I've spent hours searching for a work around or fix. Nothing works! How in blue blazes am I supposed to connect to my ASUS Router's GUI. This is Windows 10, Firefox 104.0.2 (64-bit)

Asked by acct3 4 months ago

Answered by acct3 4 months ago

  • Locked

Unable to type a "space"

When typing comments on a web blog, after the spacebar is used, the first letter of the next word eliminates the previously typed space. So what I end up with is all word… (read more)

When typing comments on a web blog, after the spacebar is used, the first letter of the next word eliminates the previously typed space. So what I end up with is all words in a sentence running together. Tried other browsers and they work fine. Changed keyboard as well no joy. Typing is normal in applications like adobe, word, etc..... Only happens during Firefox use......... Uninstalled and reinstalled Firefox, also no help..... How do I fix ?

Asked by doej79779 5 months ago

Last reply by cor-el 4 months ago

  • حُلّت

Login not possible anymore on Letterboxd.com and other websites since update to FF 104

Hello, This issue might or might not be related to [other issue] I have since I updated Ubuntu 20.04 to 22.04 and therefore updated my Firefox to 104. I can't login anym… (read more)

Hello, This issue might or might not be related to [other issue] I have since I updated Ubuntu 20.04 to 22.04 and therefore updated my Firefox to 104. I can't login anymore on Letterboxd since the update. It's not a problem of username or password. When I click "Sign in", nothing happens except a page refresh, but I'm still not logged in. Other strange behaviour on that site since the update: most of the images don't appear. For example on this page : https://letterboxd.com/films/# all the movie covers are just blank.

The website does work properly when using Firefox in private mode though (both login and images work fine), so this makes me think it's related to my other issue mentioned above.

OS: Ubuntu 22.04 Firefox 104.0.2

EDIT after posting this question: I just found out that I can't login on Google either. I enter my username, password, then it asks me to validate on another apparel that it's really me, which I do, and nothing happens so I can't login. It works normally in private mode.

Asked by vanecx 4 months ago

Answered by jonzn4SUSE 4 months ago

  • حُلّت

All tabs are crashing and show the message 'Gah. Your tab just crashed'

I am using firefox v104 on linux mint. This problem happened this evening. Every tab i open shows the same error. I tried the solutions suggested in other similar forum … (read more)

I am using firefox v104 on linux mint. This problem happened this evening. Every tab i open shows the same error.

I tried the solutions suggested in other similar forum posts like >safemode (tabs still crashed) >driver update (my drivers are up to date as far i can tell) >deleting cache and reinstalling firefox (tabs crash). I took a backup of my bookmarks and extensions as suggeated in another forum post. > one youtube video (https://youtu.be/F9VaXwSB_po) suggested toggling media.cubeb.sandbox in the config section. The tabs started loading after that but it wasnt that useful as i wasnt able to get any videos to play in the browser.

Also, i don't really know if the issue is related, but chrome tabs were also not loading or responding ('Page unresponsive' error).

Please help. Thank you :)

Asked by Vaghar 5 months ago

Answered by Vaghar 5 months ago

  • حُلّت

PRIVACY: The Big Lie

You will tell me why Mozilla Firefox, a browser that claim to protect our privacy, is PERMANENTLY connected to Amazon servers. Even If I try to block the connections with… (read more)

You will tell me why Mozilla Firefox, a browser that claim to protect our privacy, is PERMANENTLY connected to Amazon servers.

Even If I try to block the connections with a Firewall, it's useless, because the next time I start it, it still connects to Amazon using diffferent IP address, even if the starting page is totally blank.

It is not about keeping firefox up-to-date, because when I manually start the search for an update, Firefox establish a new connection: Mozilla REALLY want my browser to SEND datas to Amazon, which is one of the worst company when we talk about collecting personnal informations, just like Google, which Firefox also use, but it's less dramatic since I can decide to not use that feature.

So, like I wrote, I try to block Amazon IP addresses: The result is that I can't access extensions store, but that's still not the use of these servers, since even If It's blocked, Amazon still appears in Established connections, and it's not about Search: Indeed, Amazon appears in a list of engines we can use ( if we want it ), but it's un-checked, and I use a different search engine, so what's left now, since there's apparently no reason at all for these connections to happen.

Here's my theory: Mozilla need money to survive, so it sell informations about its users to Amazon, and that's why it's so important to keep these connections alive.

The fact that we're forced to connect to Amazon servers shows that it's not necessary and that whatever the reason you ive me (update, protection...), it's probably (obviously) not the truth.

Waiting for a real answer !



I

Asked by SmilieX 5 months ago

Answered by jscher2000 - Support Volunteer 5 months ago

  • حُلّت

How do I lock bookmarks on the bookmark tool bar?

I'm a gamer and alt+tab considerably often. Most of the time I end up on FireFox because I need to look at a map or browse reddit while I'm in queue. However, whenever I … (read more)

I'm a gamer and alt+tab considerably often. Most of the time I end up on FireFox because I need to look at a map or browse reddit while I'm in queue. However, whenever I alt+tab frequently a bookmark will get selected as if I am clicking and dragging. The bookmarks on the bookmark tool bar always end up in different places. Is there a way to lock these links in place so I can't move them or do I have to resign myself to fixing it every day?

Asked by Vileynye 5 months ago

Answered by Vileynye 5 months ago