Showing questions tagged: اعرض كل الأسئلة
  • حُلّت
  • المُؤرشفة

OpenH264 fails to install with HTTPS-Only mode enabled

"OpenH264 Video Codec provided by Cisco Systems, Inc." plugin will sit in the "will be installed shortly" status forever if you have HTTPS-Only mode enabled. I have been … (read more)

"OpenH264 Video Codec provided by Cisco Systems, Inc." plugin will sit in the "will be installed shortly" status forever if you have HTTPS-Only mode enabled. I have been pulling my hair out for the last few days trying to figure out why I couldn't play YouTube or many other sites videos.

Turns out the site that the library is downloaded from has a bad certificate installed: https://ciscobinary.openh264.org/libopenh264-2.3.0-linux64.6.so.bz2

``` Websites prove their identity via certificates. Firefox does not trust this site because it uses a certificate that is not valid for ciscobinary.openh264.org. The certificate is only valid for the following names: a248.e.akamai.net, *.akamaihd-staging.net, *.akamaihd.net, *.akamaized-staging.net, *.akamaized.net

Error code: SSL_ERROR_BAD_CERT_DOMAIN ```

OS: Fedora 36 Firefox Version: 104.0 (64-bit)

Asked by Nickolas Gupton 1 year ago

Answered by Nickolas Gupton 1 year ago

  • حُلّت
  • المُؤرشفة

Export all the bookmarks from a loads of profiles from a script

Hello everyone :) From a folder, I have loads of Firefox profiles from different eras. I am looking for a way to export all the bookmarks of each of the profiles to… (read more)

Hello everyone :)

From a folder, I have loads of Firefox profiles from different eras. I am looking for a way to export all the bookmarks of each of the profiles to an HTML file like the manual method (Library > Import and backup > Export bookmarks to formal HTML), but all in an automatic way by script. I like the HTML export from Firefox because it allows you to quickly navigate using keywords, either in links or in the folder names I gave.

Is there a simple solution that would reuse, for example, the same export code as Firefox ?

Thanks in advance With adelphity estebann

Asked by estebann 1 year ago

Answered by cor-el 1 year ago

  • حُلّت
  • المُؤرشفة

Google docs add-ons not working on Firefox

I am using Firefox 95.0.1 on Ubuntu 20.04. When I want to use an add-on in google docs, I see this error screen in Firefox. Opening the add-on in a separate window does n… (read more)

I am using Firefox 95.0.1 on Ubuntu 20.04. When I want to use an add-on in google docs, I see this error screen in Firefox. Opening the add-on in a separate window does not work either and even if it did, it would be off the purpose of a google doc add-on. How can I solve this problem?

Asked by Arman 1 year ago

Answered by Arman 1 year ago

  • حُلّت
  • المُؤرشفة

Import Certificates button not functioning

I am attempting to import server certificates into Firefox. But the "Import" button does nothing when viewing certificates. Any work around? I need to import our serv… (read more)

I am attempting to import server certificates into Firefox. But the "Import" button does nothing when viewing certificates. Any work around? I need to import our server certificates into the Authorities section.

Ubuntu 22.04 Firefox installed through snap. Version 104.0 just upgraded this afternoon.

Thank you, James

Asked by James Finnall 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • حُلّت
  • المُؤرشفة

An extension installed globally for all users (in /usr/share/mozilla/extensions) does not load for an unobvious reason

I need to automate the deployment of Firefox along with the extensions. I put three extensions (uBlock, Translate Web Pages, and Auto Tab Discard) in the /usr/share/mozil… (read more)

I need to automate the deployment of Firefox along with the extensions. I put three extensions (uBlock, Translate Web Pages, and Auto Tab Discard) in the /usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/. All extensions load normally, except Auto Tab Discard. When running firefox with the -jsconsole option, I see what the screenshot shows (the message "Invalid addon ID"). But the installation to user profile is successful. I add the extension ID to manifest.json, and get the following output in the console: addons.xpi-utils WARN addMetadata: Add-on {c2c003ee-bd69-42a2-b0e9-6f34222cb046} is invalid: Error: File /usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{c2c003ee-bd69-42a2-b0e9-6f34222cb046} does not contain a valid manifest(resource://gre/modules/addons/XPIInstall.jsm:669:11) What can go wrong?

System: Debian 11 (bullseye) Firefox version: 91.4.1esr (amd64)

If you need any other information, please ask, I will write it down.

Asked by zostajekni 1 year ago

Answered by zostajekni 1 year ago

  • حُلّت
  • المُؤرشفة

Low fps on multiple iwndows hen one is playing audio or video

OS: Ubuntu 21.04 x86_64 CPU: AMD Ryzen 7 3700X (16) @ 3.600GHz GPU: NVIDIA GeForce RTX 2060 SUPER When I have two windows running and one of them is playing either audio… (read more)

OS: Ubuntu 21.04 x86_64 CPU: AMD Ryzen 7 3700X (16) @ 3.600GHz GPU: NVIDIA GeForce RTX 2060 SUPER

When I have two windows running and one of them is playing either audio or video on its active tab, the other window runs at a very low FPS. This is noticeable when scrolling, as CPU usage appears to increase dramatically while monitored.

The problem does not appear when running firefox in safe mode, but I cannot determine what might be causing the problem when firefox runs normally: the problem persists when I disable all extensions, as well as when I use the browser's default appearance as opposed to the theme of my choice. As far as I can tell, I have not modified any about:config settings either, although some cursory searching online suggests webrender may be a cause.

Asked by dmitry7 1 year ago

Answered by cor-el 1 year ago

  • حُلّت
  • المُؤرشفة

Code: 4 | Message: Something went wrong during native playback

Hi all. Did a search but found nothing that helped. Just updated my Fedora 36 workstation and tried to play videos in CNN and MSNBC web sites and get the error message: "… (read more)

Hi all. Did a search but found nothing that helped. Just updated my Fedora 36 workstation and tried to play videos in CNN and MSNBC web sites and get the error message: "Code: 4 | Message: Something went wrong during native playback." I am using the latest Firefox WEB browser. UTube videos are playing fine. Someone has stated on the Fedora forum that they have the same problem but has no problem in Chrome on the same machine. Any ideas? Thanks in advance. Bob BTW, this happened in two machines running Fedora 36 and Firefox 101.0.

Asked by 1bbrazie 1 year ago

Answered by jonzn4SUSE 1 year ago

  • المُؤرشفة

Google

Why are there so many Google tools embedded in Firefox? Many of us don't trust Google at all, and in the current environment of increasing surveillance, it seems very str… (read more)

Why are there so many Google tools embedded in Firefox? Many of us don't trust Google at all, and in the current environment of increasing surveillance, it seems very strange to find many Google processes in Firefox.

Asked by john820 12 months ago

Last reply by Dropa 12 months ago

  • حُلّت
  • المُؤرشفة

2FA login on web sites does not work with Firefox (Linux)

2FA login on sites works with Chromium but NOT WITH Firefox (Linux) Present setup: Does NOT work firefox 102.7.0esr on debian 11.6 bullseye 5.10.162-1 (x86-64) firefox … (read more)

2FA login on sites works with Chromium but NOT WITH Firefox (Linux)

Present setup:

Does NOT work firefox 102.7.0esr on debian 11.6 bullseye 5.10.162-1 (x86-64) firefox 110.0 on Ubuntu MATE 22.04 LTS 5.15.0-58 (x86-64)

Works chromium 109.0.5414.119 on debian 11.6 bullseye 5.10.162-1 (x86-64)

I am able to register and authenticate with security devices Yubikey NEO (without FIDO2) and Yubikey 5 NFC (FIDO2 compliant) on several sites (eg. pypi, google..) using Chrome or Chromium but now not with Firefox at all. It has not worked for at least the last few updates. Changing settings in about:config or plugging/unplugging keys, stopping every Firefox plugin etc. don't help. Neither does a fresh Firefox install without any super-security-settings.

Testing sites like Yubico's own or Okta's works fine using Chromium but not Firefox.

From what I can see this is not especially related to FIDO2 (Webauthn). pypi seems to use U2F which should work just fine with Firefox since way back.

I haven't tested Firefox for Windows but Chrome browser for Windows 10 works fine (which I tested first when Firefox didn't cut the mustard), I therefore expect it to work also on Chrome browser for Linux. Just to check if this was related to a debian bullseye package, I tested it on Ubuntu MATE too, which didn't do the trick. Haven't done any more testing than that on MATE.

This seems like a strictly firefox problem. -What to do?

Yours, Kaare

Asked by kaare 7 months ago

Answered by kaare 7 months ago

  • حُلّت
  • المُؤرشفة

Dynamic text selection doesn't work

Selecting text on any page, there's no visual feedback of what is selected until mouse is released. There's no feedback that selection starts when mouse button is presse… (read more)

Selecting text on any page, there's no visual feedback of what is selected until mouse is released.

There's no feedback that selection starts when mouse button is pressed down, no visual feedback while moving the mouse with the button pressed and only upon releasing the button do I get to see the selection.

Selecting works fine in other browsers (chromium) and was working the other day before I did a fresh install of Ubuntu 22.04 (was using 20.04 before) wiping my previous Firefox. So this issue is on an almost vanilla Firefox version 104.0.2.

(Incidentally I can highlight that version number and only that version number in the about-box and I get continuous dynamic feedback of what part of the version number I highlight, but nowhere else in Firefox.)

Asked by Local_Minimum 1 year ago

Answered by Local_Minimum 1 year ago

  • حُلّت
  • المُؤرشفة

How can I disable the display of the word "PLAYING" in the tab of a page that is playing media?

When I play HTML5 audio Firefox adds an extra line to the tab title with the word "PLAYING". This causes the main window to resize vertically. Any content that is sized b… (read more)

When I play HTML5 audio Firefox adds an extra line to the tab title with the word "PLAYING". This causes the main window to resize vertically. Any content that is sized based on the height of the window is also resized which causes a visible 'glitch' in the display. My specific use-case is a music rehearsal page that displays an SVG of the music score beside the HTML5 <audio> controls. The height of the is defined, in css, as 'height: 100vh;' so that the whole page is visible. I would like to be able to revert to Firefox's previous behaviour of displaying an icon _beside_ the tab title. Any other solution that does not increase the height of the tab could also be of use.

Thanks.

Asked by jlemcke1 1 year ago

Answered by cor-el 1 year ago

  • حُلّت
  • المُؤرشفة

Solved: No Aspect of File Interface works Ubuntu 22.04

I first realized an issue with downloading PDFs through the Firefox viewer - I cannot. The download button does nothing, there is no prompt, no popup, and no file downloa… (read more)

I first realized an issue with downloading PDFs through the Firefox viewer - I cannot. The download button does nothing, there is no prompt, no popup, and no file downloaded. I have also tried to print to pdf, that also seems to fail.

Today I realized I also cannot attach any files to an email through Gmail in Firefox, which is now leading me to believe that the software is unable to interface with my files at all.

Things I've tried include: - Turning off popup blocker - Refreshing Firefox in the ->Help->More Troubleshooting Information Menu - Starting Firefox in safe mode - Reinstalling through snap

The only way I can currently download files is through wget, and the only way I can send attachments is by installing Google Chrome, which is kind of a last resort for me.

I am running Ubuntu 22.04, this is on Firefox 106.0, though it didn't work last update either.

Thanks for any help


Edit: I have been googling for answers but after posting this question a similar thread popped up, the solution is to install the following packages:

xdg-desktop-portal xdg-desktop-portal-gtk

Asked by james228 11 months ago

Answered by cor-el 11 months ago

  • حُلّت
  • المُؤرشفة

As soon as a video is played in youtube firefox crashes

The main youtube page loads and displays ok. As soon as a video is played (even in preview), firefox crashes. I'm on Linux Manjaro. other websites with video work fine (f… (read more)

The main youtube page loads and displays ok. As soon as a video is played (even in preview), firefox crashes. I'm on Linux Manjaro. other websites with video work fine (for ex Vimeo) I tried disabling all my addons and plugins in the normal mode (not troubleshoot mode) and it still crashes. However, the troubleshoot mode works fine ! Refreshing firefox didn't fix the issue. I have another computer with Linux manjaro and firefox works just fine. I spent a lot of time trying to understand what's wrong but I really don't see why.

Thanks in advance for your help.

Asked by gdurrens 8 months ago

Answered by TyDraniu 8 months ago

  • حُلّت
  • المُؤرشفة

firefox two-step authentication always fail because of wrong recovery code

I am keeping trying to set up a two-step verify on my firefox account, but stuck on the last step of input the recovery code, even if I input the right recovery code, it … (read more)

I am keeping trying to set up a two-step verify on my firefox account, but stuck on the last step of input the recovery code, even if I input the right recovery code, it still tells me I entered wrong code.

Asked by locallearner 1 year ago

Answered by cor-el 1 year ago

  • حُلّت
  • المُؤرشفة

firefox input lag

When typing it comes behind al lot. It happens in input fieds, when typing in the adress bar. I also get lag when scrolling. I have tried all the thinks i can find. I hav… (read more)

When typing it comes behind al lot. It happens in input fieds, when typing in the adress bar. I also get lag when scrolling. I have tried all the thinks i can find. I have used troubleshooting mode, disables the addons i use (its just dark reader and uBlock orign). I also dont see a high CPU usage or RAM usage. I have disabled and enabled hardware acceleration, smooth scrolling and autoscrolling. Next to that i have also reinstall firefox. Today i also tried to make an new profile. Still got the same problem. It has not crashed yet so i couldn't find crash logs or something the kind. I have dual boot and on windows and don't have this problem there.

If you need some system information or other information, ill provide.

Asked by Jarne 1 year ago

Answered by jonzn4SUSE 1 year ago

  • حُلّت
  • المُؤرشفة

rumble video is not visible on a webpage

The rumble video interview of Jonathan Cahn by Greg Hunter is NOT visible in my linux version 91.12.0esr(64-bit) of Mozilla Firefox, straight from an openSuse software re… (read more)

The rumble video interview of Jonathan Cahn by Greg Hunter is NOT visible in my linux version 91.12.0esr(64-bit) of Mozilla Firefox, straight from an openSuse software repository and directly installable under yast, which is their administrator program over the linux software including the software manager

The web page in question is https://usawatchdog.com/only-way-to-save-america-is-turn-back-to-god-jonathan-cahn/ but the java script code is grayed out on this page

!function(r,u,m,b,l,e){r._Rumble=b,r[b]||(r[b]=function(){(r[b]._=r[b]._||[]).push(arguments);if(r[b]._.length==1){l=u.createElement(m),e=u.getElementsByTagName(m)[0],l.async=1,l.src="https://rumble.com/embedJS/ugdmvn"+(arguments[1].video?'.'+arguments[1].video:)+"/?url="+encodeURIComponent(location.href)+"&args="+encodeURIComponent(JSON.stringify([].slice.apply(arguments))),e.parentNode.insertBefore(l,e)}})}(window, document, "script", "Rumble");

I have used other browsers, such as Opera, Brave, Google Chrome and the rumble video is clearly visible and playable.

What do I have to change in Firefox so that this video becomes visible on the page?

Randall

p.s. Greg Hunter is interested in this reply too

Asked by website.reader3 1 year ago

Answered by jonzn4SUSE 1 year ago

  • حُلّت
  • المُؤرشفة

Unable to upload or download files

Hello all, For some reason, I can no longer upload or download files, with the pop-up window failing to appear entirely. I can upload folders through, for example, Dropb… (read more)

Hello all,

For some reason, I can no longer upload or download files, with the pop-up window failing to appear entirely. I can upload folders through, for example, Dropbox or Google Drive, but individual files don't work.

I've reset my browser, uninstalled and reinstalled it, opened it in troubleshooting mode, disabled enhanced tracking protection, but nothing seemed to work. I've tested another browser, and I was able to upload and download files just fine.

Is there anything I can do to fix this? I'm on Ubuntu 22.04 using Firefox 107.0.1.

Asked by Erika Campbell 9 months ago

Answered by jonzn4SUSE 9 months ago

  • حُلّت
  • المُؤرشفة

Some video content can not be displayed.

I use a laptop with Fedora 36 installed. Firefox is version 104.0.1 Until a few days ago, there were no problems with video display. But since a few days, video content … (read more)

I use a laptop with Fedora 36 installed. Firefox is version 104.0.1

Until a few days ago, there were no problems with video display. But since a few days, video content that is offered by the news site from NOS (Dutch television) is not displayed anymore. I only get this error: The media playback was aborted due to a corruption problem or because the media used features your browser did not support.

Also some content on Youtube aborts. For example loading https://www.youtube.com/watch?v=qq0BUiEs3JM results in this error: Er is een fout opgetreden. Probeer het later opnieuw. (Afspeel-ID: Ui0fzPxdSexgYcZ4).' (An error occured, try later again).

When using the Chrome Browser both websites can be used without giving errors implying that all the codecs are available.

How can I detect why video is blocked?

(Twitter also gives problems. After a fraction of a second, it stops displaying video)

Asked by Ben Engbers 1 year ago

Answered by Ben Engbers 1 year ago

  • حُلّت
  • المُؤرشفة

Is there a way to reset my Firefox password without losing my data?

I forgot my password to my Firefox account, and only just realized I haven't updated it in KeypassXC when I was trying to log in to a new machine. It seems that, even tho… (read more)

I forgot my password to my Firefox account, and only just realized I haven't updated it in KeypassXC when I was trying to log in to a new machine. It seems that, even though I am already logged in on my old computer and have full access to my account (including saved passwords, bookmarks, and browsing history) I can't find a way to reset my password without deleting all of my synced data. From the "Change Password" menu, it requires my old password if I want to change it without deleting everything. Also, I have 2FA enabled, so why isn't there the option to authenticate my identity in a password reset using 2FA instead of my old password? I know a similar thing already exists for recovery keys, but I only have 2FA. Is there any way for me to reset my password where I don't lose everything? Thank you.

Asked by Isaac Mellington 1 year ago

Answered by cor-el 1 year ago