Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't be able to open my bet9ja with Firefox and I don't know way?

  • 1 reply
  • 1 has this problem
  • 2 views
  • آخر ردّ كتبه jscher2000

more options

Please help me solve the problem

All Replies (1)

more options

What is a bet9ja ?

Your Firefox indicated it is version 53. The currently supported release version is Firefox 61.