Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe
  • Okugcinwe kunqolobane

Import Certificates button not functioning

I am attempting to import server certificates into Firefox. But the "Import" button does nothing when viewing certificates. Any work around? I need to import our serv… (funda kabanzi)

I am attempting to import server certificates into Firefox. But the "Import" button does nothing when viewing certificates. Any work around? I need to import our server certificates into the Authorities section.

Ubuntu 22.04 Firefox installed through snap. Version 104.0 just upgraded this afternoon.

Thank you, James

Asked by James Finnall 1 unyaka odlule

Answered by jscher2000 - Support Volunteer 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

2FA login on web sites does not work with Firefox (Linux)

2FA login on sites works with Chromium but NOT WITH Firefox (Linux) Present setup: Does NOT work firefox 102.7.0esr on debian 11.6 bullseye 5.10.162-1 (x86-64) firefox … (funda kabanzi)

2FA login on sites works with Chromium but NOT WITH Firefox (Linux)

Present setup:

Does NOT work firefox 102.7.0esr on debian 11.6 bullseye 5.10.162-1 (x86-64) firefox 110.0 on Ubuntu MATE 22.04 LTS 5.15.0-58 (x86-64)

Works chromium 109.0.5414.119 on debian 11.6 bullseye 5.10.162-1 (x86-64)

I am able to register and authenticate with security devices Yubikey NEO (without FIDO2) and Yubikey 5 NFC (FIDO2 compliant) on several sites (eg. pypi, google..) using Chrome or Chromium but now not with Firefox at all. It has not worked for at least the last few updates. Changing settings in about:config or plugging/unplugging keys, stopping every Firefox plugin etc. don't help. Neither does a fresh Firefox install without any super-security-settings.

Testing sites like Yubico's own or Okta's works fine using Chromium but not Firefox.

From what I can see this is not especially related to FIDO2 (Webauthn). pypi seems to use U2F which should work just fine with Firefox since way back.

I haven't tested Firefox for Windows but Chrome browser for Windows 10 works fine (which I tested first when Firefox didn't cut the mustard), I therefore expect it to work also on Chrome browser for Linux. Just to check if this was related to a debian bullseye package, I tested it on Ubuntu MATE too, which didn't do the trick. Haven't done any more testing than that on MATE.

This seems like a strictly firefox problem. -What to do?

Yours, Kaare

Asked by kaare 1 unyaka odlule

Answered by kaare 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

All tabs are crashing and show the message 'Gah. Your tab just crashed'

I am using firefox v104 on linux mint. This problem happened this evening. Every tab i open shows the same error. I tried the solutions suggested in other similar forum… (funda kabanzi)

I am using firefox v104 on linux mint. This problem happened this evening. Every tab i open shows the same error.

I tried the solutions suggested in other similar forum posts like >safemode (tabs still crashed) >driver update (my drivers are up to date as far i can tell) >deleting cache and reinstalling firefox (tabs crash). I took a backup of my bookmarks and extensions as suggeated in another forum post. > one youtube video (https://youtu.be/F9VaXwSB_po) suggested toggling media.cubeb.sandbox in the config section. The tabs started loading after that but it wasnt that useful as i wasnt able to get any videos to play in the browser.

Also, i don't really know if the issue is related, but chrome tabs were also not loading or responding ('Page unresponsive' error).

Please help. Thank you :)

Asked by Vaghar 1 unyaka odlule

Answered by Vaghar 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox flags MP4 file as malware

Hi, Is there any reason firefox would flag an mp4 file legitimately? The file extension and file type are absolutely mp4. There seem to be no mp4 related zero days… (funda kabanzi)

Hi,

Is there any reason firefox would flag an mp4 file legitimately?

  • The file extension and file type are absolutely mp4.
  • There seem to be no mp4 related zero days.

Does Firefox perhaps just treat all downloads from suspicious domains as malware? Is there a zero day I missed? Is this based on some missing metadata on the file or something?

Thanks for any advice you can give here, I'm scared.

Asked by jordanfilipovski 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox Automatically Redirecting from HTTP to HTTPS (RESOLUTION)

As per this issue I reported a while back, I was experiencing odd issue with automatic redirect to HTTPS for some private development sites. I finally found a fix for th… (funda kabanzi)

As per this issue I reported a while back, I was experiencing odd issue with automatic redirect to HTTPS for some private development sites.

I finally found a fix for the issue. The problem appears to be with DuckDuckGo Privacy Essentials Extension which apparently *may automatically redirect to the http site. In order to prevent this, I added my development sites to 'Unprotected Sites' and this prevented DuckDuckGo from doing the automatic redirect to https.

  • - Odd thing is that I had multiple domains pointing to the same web instance and only one of the domains was having this issue with the DDG extension. Both were going to the same IP through a HTTP proxy. The proxy and web server were not the issue. This symptom points to an maybe an issue in Firefox....

In summary, be wary of odd redirects and the DuckDuckGo Privacy Essentials extension if you are doing web development work.

Asked by Timothy C. Quinn 2 iminyaka edlule

Answered by Timothy C. Quinn 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox 109.0 on Linux Video Playback

The latest Firefox update appears to break video playback on Linux. I am having issues playing video on Twitter, Facebook, and Locals. YouTube video still plays. I have n… (funda kabanzi)

The latest Firefox update appears to break video playback on Linux. I am having issues playing video on Twitter, Facebook, and Locals. YouTube video still plays. I have not enabled any new ad blocking and have also not changed any settings. Looking at the Troubleshooting Information in Firefox reveals nothing that is suspect.

Asked by jdawgnoonan 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox using FIDO2 Security Keys

Firefox seems to have a problem on Linux using USB Security Keys. I have two Yubico Security Keys which I use for 2FA. The problem seems to be that Firefox cannot communi… (funda kabanzi)

Firefox seems to have a problem on Linux using USB Security Keys. I have two Yubico Security Keys which I use for 2FA. The problem seems to be that Firefox cannot communicate with the USB port, as it doesn't make any difference whether the USB Security Key is plugged in or not, the error returned is always the same and the Security Key does not light up.

I believe Firefox's WebAuth code must be fine, as it works on Windows, which is why I think it's some kind of permissions problem. Chrome works perfectly with the Security Keys on my computer.

I've used a number of sites (I've listed a couple below) where you can test your Security Key with Firefox on KDE Neon and the error is always "UnknownError: The operation failed for an unknown transient reason":

https://www.token2.com/tools/fido2-test/ https://demo.yubico.com/webauthn-technical/registration

I cannot log into Bugzilla with GitHub as my GitHub login uses a Security Key as the second factor.

Asked by dave353 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Some video content can not be displayed.

I use a laptop with Fedora 36 installed. Firefox is version 104.0.1 Until a few days ago, there were no problems with video display. But since a few days, video content … (funda kabanzi)

I use a laptop with Fedora 36 installed. Firefox is version 104.0.1

Until a few days ago, there were no problems with video display. But since a few days, video content that is offered by the news site from NOS (Dutch television) is not displayed anymore. I only get this error: The media playback was aborted due to a corruption problem or because the media used features your browser did not support.

Also some content on Youtube aborts. For example loading https://www.youtube.com/watch?v=qq0BUiEs3JM results in this error: Er is een fout opgetreden. Probeer het later opnieuw. (Afspeel-ID: Ui0fzPxdSexgYcZ4).' (An error occured, try later again).

When using the Chrome Browser both websites can be used without giving errors implying that all the codecs are available.

How can I detect why video is blocked?

(Twitter also gives problems. After a fraction of a second, it stops displaying video)

Asked by Ben Engbers 1 unyaka odlule

Answered by Ben Engbers 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Linux Dock Icon

I am using Pop OS, which is based off of Ubuntu. Somehow I did something, and it made the icon disappear for Firefox. I figured I could easily search the internet and fi… (funda kabanzi)

I am using Pop OS, which is based off of Ubuntu.

Somehow I did something, and it made the icon disappear for Firefox. I figured I could easily search the internet and find a simple solution.

I temporarily fixed it last night, but here it is missing again.

I could upload a picture, but I don't see what difference that would make. The dock at the bottom has a spot for firefox, but no icon, literally an empty spot, In the application menu it is a blank spot with Firefox worded underneath.

I have uninstalled, reinstalled, purged, deleted the application data in my user folder..

Just annoying. not a huge problem.

Asked by cadearmstrong 1 unyaka odlule

Answered by cadearmstrong 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

mysignins.microsoft.com

Hello I'm trying to sign into a Microsoft 365 email account but can't get beyond a screen saying "To use this site, you need to change your browser settings to enable DO… (funda kabanzi)

Hello

I'm trying to sign into a Microsoft 365 email account but can't get beyond a screen saying "To use this site, you need to change your browser settings to enable DOM storage or cookies."

I've enabled DOM storage and cookies but no difference. I've cleared cookies and no help. I'm running Firefox 115.0.2 and Linux Mint.

Is part of the problem that I hate Microsoft and they know it?

Thanks

Asked by arthurjackson 10 izinyanga ezidlule

Answered by jonzn4SUSE 10 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

File input is not working at all

In my firefox the file input is not functioning at all. EX: I go to https://www.w3schools.com/tags/tryit.asp?filename=tryhtml5_input_type_file and try and use any of the… (funda kabanzi)

In my firefox the file input is not functioning at all.

EX: I go to https://www.w3schools.com/tags/tryit.asp?filename=tryhtml5_input_type_file and try and use any of the file inputs there - they just do nothing.

Same with the file inputs on this support form page. None of them work for me.

System - ubuntu22.04, ff: 106.0.1 64bit

Asked by alan.kesselmann 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Cloudflare challenges only work in incognito (with all extensions)

I've been having an issue for a while now where the cloudflare challenges that ask you to click the check mark to "verify your connection is secure" would just endlessly … (funda kabanzi)

I've been having an issue for a while now where the cloudflare challenges that ask you to click the check mark to "verify your connection is secure" would just endlessly ask me to click the button and never continue. Sometimes it would say to unblock access to challenges.cloudflare.com.

But if I a launch an incognito window I can visit website with the challenge and it won't even ask! I've added all my extensions to run in incognito mode and everything still works, I can visit the websites in incognito just fine. So the one changing variable is incognito vs non-incognito.

I can have two windows open, one incognito and one not, and browse to the same website and the non-incog window will fail but the incog will just go to the site.

I thought incognito was supposed to only affect the session storage? Does it silently change other things to the running environment of the browser (about:config options, slightly different extension configs)?

Anyone know why this small change would suddenly allow cloudflare challenges to work?

Asked by txrxnet 8 izinyanga ezidlule

Answered by txrxnet 8 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Excessive apparmor log entries on Ubuntu platform

OS version: Ubuntu 22.04.1 LTS (jammy), 64-bit (amd64, x86_64). Firefox version: 110.0 (64-bit) (NOTE: the issue was noticed with version 109.0, too) Firefox package wa… (funda kabanzi)

OS version: Ubuntu 22.04.1 LTS (jammy), 64-bit (amd64, x86_64). Firefox version: 110.0 (64-bit) (NOTE: the issue was noticed with version 109.0, too)

Firefox package was installed on Ubuntu through 'APT', using the Mozilla Team repository (https://ppa.launchpadcontent.net/mozillateam/ppa/ubuntu/). It caught my attention that an excessive amount of Firefox related 'DENIED' AppArmor log messages is generated during the browser activity.

According to messages, Firefox is occasionally denied read access to '/sys/devices/' area and read/write access to 'oom_score_adj' target in '/proc/'. Could somebody clarify why would that access be required for regular browser operations? I'm a bit puzzled as I haven't noticed anything similar with the older Ubuntu and Firefox versions. A complete suppression of those messages is also an option as long as there's no negative impact on application's performance.

I already posted this question to Ubuntu forum but seems like nobody there could provide an explanation. I'd appreciate any input or hint.

Following is the sample of referred log messages:

---SNIP--- [Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.813:39): apparmor="DENIED" operation="capable" profile="firefox" pid=2231 comm="firefox" capability=21 capname="sys_admin"

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.877:40): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/revision" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.877:41): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/config" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.877:42): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/revision" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.877:43): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/config" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.885:44): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/revision" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.885:45): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/config" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.885:46): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/revision" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.885:47): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/config" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0 . . . . . . [Fri Feb 24 19:16:22 2023] audit: type=1400 audit(1674000983.040:56): apparmor="DENIED" operation="open" profile="firefox" name="/proc/2347/oom_score_adj" pid=2231 comm="firefox" requested_mask="w" denied_mask="w" fsuid=1000 ouid=1000

[Fri Feb 24 19:16:35 2023] audit: type=1400 audit(1674000995.296:57): apparmor="DENIED" operation="open" profile="firefox" name="/proc/2347/oom_score_adj" pid=2231 comm="firefox" requested_mask="w" denied_mask="w" fsuid=1000 ouid=1000

[Fri Feb 24 19:16:39 2023] audit: type=1400 audit(1674000999.280:58): apparmor="DENIED" operation="open" profile="firefox" name="/proc/2347/oom_score_adj" pid=2231 comm="firefox" requested_mask="w" denied_mask="w" fsuid=1000 ouid=1000

[Fri Feb 24 19:16:41 2023] audit: type=1400 audit(1674001001.768:59): apparmor="DENIED" operation="open" profile="firefox" name="/proc/2455/oom_score_adj" pid=2231 comm="firefox" requested_mask="w" denied_mask="w" fsuid=1000 ouid=1000

[Fri Feb 24 19:16:41 2023] audit: type=1400 audit(1674001001.768:60): apparmor="DENIED" operation="open" profile="firefox" name="/proc/2458/oom_score_adj" pid=2231 comm="firefox" requested_mask="w" denied_mask="w" fsuid=1000 ouid=1000 ---SNIP---

Asked by scoobienator 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Scroll bars not showing up on some sites since 112 update

I'm using Firefox in Ubuntu 22.04.2. I recently update to 112.0, then 112.0.1 With both versions, the scroll bar is not available on some sites which used to work in pre… (funda kabanzi)

I'm using Firefox in Ubuntu 22.04.2. I recently update to 112.0, then 112.0.1

With both versions, the scroll bar is not available on some sites which used to work in previous versions. Items which are outside the initial viewing area are not visible.

Is anyone else affected by this issue?

Asked by gomgomfirefox 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Videos freeze when scrubbing back

For a few months, I have encountered an issue with videos playback on my browser. On most websites (including Reddit, Dailymotion, and even some videos on YouTube), whene… (funda kabanzi)

For a few months, I have encountered an issue with videos playback on my browser. On most websites (including Reddit, Dailymotion, and even some videos on YouTube), whenever I scrub back a video, it will stop for about ten seconds, while the audio keeps playing.

My current extensions are: Metamask, Bionic Reader, uBlock Origin, Return Youtube Dislike, and TWP Translate Web Pages. I have tried using Troubleshooting mode, but the problem persisted, so I think it's not because of my extension.

My OS is Opensuse Tumbleweed, with Firefox version 155.0.3. I didn't have this issue with Firefox ESR on my previous Debian 11 installation. I hope someone can find a solution for this, as it is extremely troublesome switching to Chrome whenever I want to watch videos.

Asked by xuantung.trinh.63 9 izinyanga ezidlule

Answered by zeroknight 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox is popping up a small pop-up asking for a password.

Everything under Logins and Passwords, and Forms and Autofill is unchecked. A "Primary Password" has never been set in firefox. Can't get it to stop asking, which is ma… (funda kabanzi)

Everything under Logins and Passwords, and Forms and Autofill is unchecked. A "Primary Password" has never been set in firefox.

Can't get it to stop asking, which is made worse by the fact that nothing is selected to prompt it nor is anything stored for it to use.

Asked by Shawn.Janson 1 unyaka odlule

Answered by jscher2000 - Support Volunteer 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Scroll wheel click on links to open in new tab

Previous versions of Firefox allowed scroll wheel button clicking to open links. I noticed that the latest version doesn't allow this. Ctrl + left click works as normal… (funda kabanzi)

Previous versions of Firefox allowed scroll wheel button clicking to open links. I noticed that the latest version doesn't allow this. Ctrl + left click works as normal but not the scroll wheel clicking.

Asked by Andrew.Barge 1 unyaka odlule

Answered by Andrew.Barge 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Password generator does not appear on some sites firefox

Idk why but sometimes firefox just doesn't prompt to generate secure password, I even have to download some extensions to generate secure password (Secure Password Genera… (funda kabanzi)

Idk why but sometimes firefox just doesn't prompt to generate secure password, I even have to download some extensions to generate secure password (Secure Password Generator) meaning more secure issues.

My guess is that you guys probably hardcoded something like {if "type: password" then prompt}, but it's still partly fault at developers too for bringing these huge chunks of javascript.

In screenshot there's element examaple in which i input password but no prompt whatsoever.

Asked by astyd637 1 unyaka odlule

Answered by astyd637 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Very low volume on video playback

I am running Firefox on Mint Debian edition, I find the Youtube playback very low volume preset at about 1/4 of max, I try set it to the max but it returned the same afte… (funda kabanzi)

I am running Firefox on Mint Debian edition, I find the Youtube playback very low volume preset at about 1/4 of max, I try set it to the max but it returned the same after restart. I start FF in trouble shooting mode to disable theme and extension but didn't change thing, I remove and reinstall FF also did not help. I find something strange that, on the Help menu it said the updates disabled by system administrator but I did not do that, it is now on 116.0 64bits, any comment ?

Asked by Joe Lee 9 izinyanga ezidlule

Answered by jonzn4SUSE 9 izinyanga ezidlule