Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe
  • Okugcinwe kunqolobane

How to change the Tab color for inactive tabs?

How to change the Tab color for inactive tabs? I have a userChrome file and have been able to change the color of the active tab but cannot do so for the inactive tab. T… (funda kabanzi)

How to change the Tab color for inactive tabs?

I have a userChrome file and have been able to change the color of the active tab but cannot do so for the inactive tab. The inactive tab color blends into the toolbar color. If I move my mouse cursor over it changes to a slight darker gray color.

Active tab color. I made mine a off white color:

.tab-background[selected="true"] {

   background-color: #f9f7f1 !important;

}

Asked by davidhelp 1 unyaka odlule

Answered by davidhelp 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox breaks my desktop environment's scrollbar style and (gradient) color and in version 98+ refuses css to approximate it

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has t… (funda kabanzi)

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has to be an exception by itself! Not only that, but it changes my ability to customize its interface, from time to time and even changes access to such ability, on some updates.

My scrollbar customizations in userChrome.css and userContent.css do not work any more (other CSS changes still work, for menu/addressbar/tabbar/bookmarksbar orderint and tab styling). I had to resort to settings in user.js file, to get a 20px width scrollbar, suitable for my big screen, but... it gets very wide when I increase the focus, on some webpages and becomes very ugly! Furthermore, I cannot make sense of the proper use of "ui.themedScrollbar*" settings and the scrollbar and its slider result in the same color. These are my settings in user.js:

user_pref("widget.content.gtk-theme-override", "backwater"); user_pref("widget.non-native-theme.enabled", false); // Use GTK-3.0 gtk.css: set to false user_pref("toolkit.legacyUserProfileCustomizations.stylesheets", true); // Use userChrome.css & userContent.css: set to true user_pref("widget.gtk.alt-theme.scrollbar_active", true); user_pref("widget.non-native-theme.scrollbar.size.override", 20); // If nothing else works, fix scrollbar width to 20px user_pref("widget.non-native-theme.gtk.scrollbar.round-thumb", false); user_pref("widget.non-native-theme.gtk.scrollbar.thumb-size", 1.0); // originally 0.75 user_pref("widget.non-native-theme.gtk.scrollbar.allow-buttons", true); // it was true, anyway... user_pref("layout.css.cached-scrollbar-styles.enabled", false); user_pref("layout.css.color-mix.enabled", true); user_pref("widget.non-native-theme.scrollbar.style", 4); // wide scrollbar theme: set to 4 user_pref("ui.themedScrollbar", "#bad1f5"); user_pref("ui.themedScrollbarInactive", "#668cc4"); user_pref("ui.themedScrollbarThumb", "#e4e4e4"); user_pref("ui.themedScrollbarThumbHover", "#e4e4e4"); user_pref("ui.themedScrollbarThumbActive", "#668cc4"); user_pref("ui.themedScrollbarThumbInactive", "#bad1f5"); user_pref("browser.dom.window.dump.enabled", false); user_pref("extensions.ui.sitepermission.hidden", false); user_pref("fission.experiment.max-origins.qualified", true);

Either with the "ui.themedScrollbar*" settings or without them (and cleared from the prefs.js file), the scrollbar and its slider result in the same color, unless I (tryingly) click on some place on the scrollbar outside its slider; then I can see the slider, _only_ for the duration of the mouse-down event (which causes up or down page-hight scrolling).

The default, very thin scrollbar, as well as my modified wide scrollbar with invisible slider are both useless to me! I have even tried fx-autoconfig (https://github.com/MrOtherGuy/fx-autoconfig) to make the scrollbar CSS work, but no result. At this point, I am considering switching to another browser, despite the trust I have to mozilla, for my data and privacy.

Asked by kavadias 1 unyaka odlule

Answered by kavadias 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

How to get Content Types Back in Applications

Many file types are no longer listed under Settings > Applications>Content Type at about:preferences#general. I used to be able to click on a file in an email like … (funda kabanzi)

Many file types are no longer listed under Settings > Applications>Content Type at about:preferences#general. I used to be able to click on a file in an email like a Word or Excel document, and it would come up on my screen. Now Firefox asks me to Save them. I don't want to automatically save files without first looking at them. How can I get those file types in the Application list again?

I have attached a pic of the file types I have left to chose from. There used to be a lot more. How can I get back all the missing choices I have had there for years?

Asked by mishasarkpetsitting 1 unyaka odlule

Answered by jscher2000 - Support Volunteer 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Spell Check not working.

Dear Sir or Madam, I'm running 101.0.1 and spell check no longer works on any mail app like Gmail, Outlook, Yahoo, BT Mail. If I use Chrome or Edge then spell check work… (funda kabanzi)

Dear Sir or Madam,

I'm running 101.0.1 and spell check no longer works on any mail app like Gmail, Outlook, Yahoo, BT Mail. If I use Chrome or Edge then spell check works correctly. This is despite my Firefox Settings being as below.....

Language Choose the languages used to display menus, messages, and notifications from Firefox. ENGLISH GB Set Alternatives… ENGLISH GB Choose your preferred language for displaying pages. Choose… ENGLISH (United Kingdom) (en-gb) Check your spelling as you type = Tick (Yes)

Could you please advise a fix?

Kind regards,

Neil.

P.S. If I use Chrome or Edge then spell check works correctly.

Asked by Trinovantes 1 unyaka odlule

Answered by Trinovantes 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Compact mode: bookmark spacing/padding in Firefox 112.0 on Windows 10 - (since version 89?)

Firefox 112.0 running on Windows 10 64-bit laptop with a small (pixel geometry) display screen has unnecessarily large padding (white space) around each bookmark as I nav… (funda kabanzi)

Firefox 112.0 running on Windows 10 64-bit laptop with a small (pixel geometry) display screen has unnecessarily large padding (white space) around each bookmark as I navigate bookmarks on the bookmark bar.

I believe this was a change instituted around version 89 (in a nutshell, I could see more - twice as many? - bookmarks listed within a bookmark folder with version 88/before. The vertical whitespace between bookmarks within a folder is excessive and makes it much more necessary to scroll within a (long) list of bookmarks in a folder when looking for one.

There was a procedure posted in the discussion below on how to set and enable "compact density".

Bookmark Padding in New Firefox Versions 2 https://support.mozilla.org/en-US/questions/1369996

The procedure below was attempted - browser.compactmode.show enabled, browser restarted, however, I cannot fin "Customize Toolbar" and "compact".

"go to - about:config search - "browser.compactmode.show" - change to TRUE , then close that window go to - Customize Toolbar at the bottom of that page, there a box called Density. Click that, you'll see "compact (not supported)" Apparently, it IS supported because I chose that. (it looked like it ignored my choice) After I closed Customize Toolbar, the bookmarks were compact spaced again. Exactly how I need them."

Is this fixable/solvable?

Asked by wb0gaz 9 izinyanga ezidlule

Answered by cor-el 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox: Move Find bar to the top

I recently upgraded my system and, after installing and using Firefox, I notice the Find (Ctrl + F) bar is now at the bottom of the window. Whereas, it was previously at… (funda kabanzi)

I recently upgraded my system and, after installing and using Firefox, I notice the Find (Ctrl + F) bar is now at the bottom of the window. Whereas, it was previously at the top (which is more like every other application I use).

After some head scratching and web searches, I remembered I had to fix this issue previously (after a Firefox upgrade some time back). The method to fix it then could be found here: [there a way to put the Find Bar at top] That link is of course to the same question asked 4 years back.

I have once again followed the procedure there explained per: • Access my Firefox profile folder. In my case:

  C:\Users\<Me>\AppData\Roaming\Mozilla\Firefox\Profiles\5ym42ewi.default

• Create folder therein called ‘chrome’ • In that folder create a file called ‘userChrome.css’ • In that file add text:

  .browserContainer > findbar {
    -moz-box-ordinal-group: 0;
  }

However, after doing that (and restarting Firefox), the Find bar stubbornly remains glued to the bottom of the window.

Can anyone tell me how to solve this issue?

As a separate note to the developers: This issue is long-standing, that a web search reveals is still relevant to many users. Any chance of considering making it a standard option?

Asked by Spinner 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

how do I move bookmarks to the right side

as per my title: how do I move bookmarks to the right side? ps - migrated today from chrome... and amazed you haven't yet realised how MASSIVELY important customising … (funda kabanzi)

as per my title: how do I move bookmarks to the right side?

ps - migrated today from chrome... and amazed you haven't yet realised how MASSIVELY important customising options are. This place is our virtual home!

stay safe !

Asked by alexandre pruykemaker 1 unyaka odlule

Answered by alexandre pruykemaker 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

How do I disable the mute button on tabs? Setting "browser.tabs.showAudioPlayingIcon" to false does nothing

The mute icon only shows on hover and takes up 50% of the tab size so I'm constantly accidentally muting tabs without realizing it and silencing video calls and the like.… (funda kabanzi)

The mute icon only shows on hover and takes up 50% of the tab size so I'm constantly accidentally muting tabs without realizing it and silencing video calls and the like. The top Google result for this issue -- rightfully yelled in all caps because this is an absolutely horrid UX -- says to set browser.tabs.showAudioPlayingIcon to false, but that does absolutely nothing in FF 100.0

Asked by exasperated_plum 1 unyaka odlule

Answered by user104147805413306348376805769878442569366 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Close Tab button on left

Obviously people have asked this before, but those threads all seem to be closed now. The idea that a browser would not want to have a consistent UI with every other part… (funda kabanzi)

Obviously people have asked this before, but those threads all seem to be closed now. The idea that a browser would not want to have a consistent UI with every other part of the operating system is absolutely nuts, so why is it not easier (or even automatic?!) to place the 'close tab' button on the left when running on a Mac operating system?

I have tried the solutions recommended here – https://support.mozilla.org/en-US/questions/1253751 – but without any success. Maybe someone could help me understand what I am doing wrong? Better yet, maybe Mozilla could remove the need for such workarounds and implement what ought to be a standard feature?

Asked by Kit Marsden 2 iminyaka edlule

Answered by cor-el 2 iminyaka edlule

  • Kusonjululiwe

How do I disable the new built-in translator?

I need to disable this horrible translator that is now showing up on top of every page I visit, It keeps showing up even after choosing a translation or disabling transla… (funda kabanzi)

I need to disable this horrible translator that is now showing up on top of every page I visit, It keeps showing up even after choosing a translation or disabling translations for that language. That is probably a bug, but I don't want to wait for a fix, I need to be able to see the pages I visit completely, this thing prevents me from clicking buttons and and is really anoying.

This is the built-in translation feature since I do not use any translation plugins, and started showing up after an upgrade.

Asked by jose90 5 izinyanga ezidlule

Answered by jose90 5 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

How can I put the new tab button in the same position that chrome would have?

My muscle memory has me constantly clicking just slightly to the right of where the furthest right tab is. It feels weird stretching alllll the way right or alll the way … (funda kabanzi)

My muscle memory has me constantly clicking just slightly to the right of where the furthest right tab is. It feels weird stretching alllll the way right or alll the way left. I've tried both spots and it just feels unatural to me. Obvioulsy I'll get used to it after a while its just I'd like it to be back to where I'm used to it being.

Asked by xledgendsx 1 unyaka odlule

Answered by TyDraniu 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

What frame rate settings are available, and where are they documented?

I use layout.frame_rate 1 to block animation, and to replace painful partial scrolling with clean jumps. I can't use an intermediate frame rate, such as 3-30 fps, due to … (funda kabanzi)

I use layout.frame_rate 1 to block animation, and to replace painful partial scrolling with clean jumps. I can't use an intermediate frame rate, such as 3-30 fps, due to the seizure risks, or a high frame rate, such as 60 fps, due to migraines when hit by "smooth" animation, "ease in-out" animation, zooming animation, parallax animation, partial scrolling with one part of the window sliding alongside another, etc.

about:config involves some other frame-rate and frame_rate settings;

gfx.display.frame-rate-divisor starts at 1

layers.offmainthreadcomposition.frame-rate starts at -1

layout.expose_high_rate_mode_from_refreshdriver starts at true

layout.frame_rate starts at 0, which defaults to monitor settings; I've reset it to 1 (1 frame per second).

layout.throttled_frame_rate starts at 1

What are these and what do they do? I've tried looking them up, and see a bunch of posts about browser diagnostics, or *increasing* frame rates, or the like.

Asked by MarjaE 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

How do I disable the new download notification?

I save a lot of images from certain sites, and prior to me finally installing the latest update because your stupid system notifies me every few hours of an update and I … (funda kabanzi)

I save a lot of images from certain sites, and prior to me finally installing the latest update because your stupid system notifies me every few hours of an update and I dismiss 20 times a day for weeks on in.... I found that this latest update ruined firefox even further because now every single time I download an image, it pops the stupid download list on top of everything till I click somewhere instead of silently downloading like it used to do. I found no options at all for disabling this new terrible feature that you for some reason forced on us against our will yet again.

Asked by Vas 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Default font is replacing all fonts everywhere

The Firefox desktop browser default font is replacing all fonts on some websites, only title fonts on some others, and then leaving others unchanged. It seems random, and… (funda kabanzi)

The Firefox desktop browser default font is replacing all fonts on some websites, only title fonts on some others, and then leaving others unchanged. It seems random, and I can't stop the default font from taking over randomly on most websites no matter what I do. This was not happening until today, and no browsers or general MacBook Air preferences were changed between today and yesterday when I last used the browser on desktop.

Under Firefox Preferences » Fonts » Advanced, I've made sure to check the box to "Allow pages to choose their own fonts instead of your selections above", and I've unchecked it, and I've re-checked it, and the default is still overriding fonts on most websites.

I've quit and restarted Firefox 3 times.

Help!

Asked by Elan 1 unyaka odlule

Answered by jscher2000 - Support Volunteer 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Zoom change in firefox 103, how to undo it?

Firefox 103 screws with website zooming if you use the "Make text bigger" accessibility setting in Windows. 150% for example now zooms in a lot more with the accessibilit… (funda kabanzi)

Firefox 103 screws with website zooming if you use the "Make text bigger" accessibility setting in Windows. 150% for example now zooms in a lot more with the accessibility setting in Windows set to 120%.

How do I undo this change so that 150% is 150% and not bigger than 150%? I had all my frequented websites set up how I liked it and now this comes along and messes it all up >:V at the moment it seems like 120% Firefox + 120% Accessibility is similar to what 150% in Firefox was like but it's not exactly the same. I've now gotta go futz with zoom levels for each web page I frequent again to find what looks most comfortable for each one.

Also this change greatly modifies consistency when it comes to the granularity of zooming. For example, what is 100% zoom when Accessibility is set to 120% so that I can avoid filtered scaling being applied to pictures? Why is the in-browser percentage indication not accurate with the level of zooming actually being applied?

The zoom level I choose is no longer the zoom level applied, there is now a multiplier in effect. So 50% isn't 50% anymore, 60% isn't 60% anymore, 70% isn't 70% anymore, 80% isn't 80% anymore, 90% isn't 90% anymore, 100% isn't 100% anymore, 110% isn't 110% anymore, 120% isn't 120% anymore, 130% isn't 130% anymore, 140% isn't 140% anymore etc.

A website that looked good at 133% can no longer be viewed at 133% if the Accessibility setting isn't also 133%.

Not a fan of whoever decided to implement this seemingly without a way to turn it off.

Asked by Franpa 1 unyaka odlule

Answered by TyDraniu 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Can i disable ctrl + m shortcut?

Hi, Often the ctrl + m (mute tab) shortcut gets in my way while using the browser as i use this shortcut in something else. I would like to know if it is possible to dis… (funda kabanzi)

Hi,

Often the ctrl + m (mute tab) shortcut gets in my way while using the browser as i use this shortcut in something else. I would like to know if it is possible to disable that.

Thanks. (Message written using Google Translate)

Asked by josevneves 1 unyaka odlule

Answered by Terry 1 unyaka odlule