Kukhonjiswa imibuzo ethegiwe: Veza yonke imibuzo
  • Kusonjululiwe
  • Okugcinwe kunqolobane

Excessive GPU memory usage when visiting websites (especially watching live streams)

Firefox always uses excessive GPU memory when I watch video and livestream. about:memory shows that the explict GPU memory allocation is only about 200 MB but in the task… (funda kabanzi)

Firefox always uses excessive GPU memory when I watch video and livestream. about:memory shows that the explict GPU memory allocation is only about 200 MB but in the task manager the GPU memory usage is 1GB, and the latter doesn't decrease even if I close the tab. I suspect that this is a memory leak. I searched for Bugzilla and found a similar issue that has been existing for years: https://bugzilla.mozilla.org/show_bug.cgi?id=1386177

Asked by ZeroAurora 1 unyaka odlule

Answered by ZeroAurora 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

All tabs are crashing and show the message 'Gah. Your tab just crashed'

I am using firefox v104 on linux mint. This problem happened this evening. Every tab i open shows the same error. I tried the solutions suggested in other similar forum… (funda kabanzi)

I am using firefox v104 on linux mint. This problem happened this evening. Every tab i open shows the same error.

I tried the solutions suggested in other similar forum posts like >safemode (tabs still crashed) >driver update (my drivers are up to date as far i can tell) >deleting cache and reinstalling firefox (tabs crash). I took a backup of my bookmarks and extensions as suggeated in another forum post. > one youtube video (https://youtu.be/F9VaXwSB_po) suggested toggling media.cubeb.sandbox in the config section. The tabs started loading after that but it wasnt that useful as i wasnt able to get any videos to play in the browser.

Also, i don't really know if the issue is related, but chrome tabs were also not loading or responding ('Page unresponsive' error).

Please help. Thank you :)

Asked by Vaghar 1 unyaka odlule

Answered by Vaghar 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Facebook lagging

So for the last little while, Facebook has been making a complete nuisance of itself on firefox. This isn't a browser problem, because the other tabs I have open work pe… (funda kabanzi)

So for the last little while, Facebook has been making a complete nuisance of itself on firefox. This isn't a browser problem, because the other tabs I have open work perfectly fine, but FB takes forever to load, and any button I press to interact with it, (like the reload button,) also lags, (but, again, works fine on other tabs,). It doesn't even register links as being clickable for a good minute after loading. The page also seems to reset every time I switch from another tab to it, showing a blank page with a loading symbol. I have tried deleting the entire history, and restarting the browser, and deactivating the adblocker, (the only extension active) and nothing seems to help. Does anybody know why it's doing this, (other than because the company follows the 'if it isn't broke, break it' theory, which we all already knew,) and how to fix it?

Asked by Khat 9 izinyanga ezidlule

Answered by Khat 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Error 400 - Bad Request The request could not be understood by server due to malformed syntax.

For the past 8-10 days, every time I try to log-on to: https://selfservice.telkom.co.za/rococo/public/content/interstitial I click "Login" under the Mobile & Home hea… (funda kabanzi)

For the past 8-10 days, every time I try to log-on to: https://selfservice.telkom.co.za/rococo/public/content/interstitial I click "Login" under the Mobile & Home heading and I receive the following message returned.

Bad Request The request could not be understood by server due to malformed syntax.

I have used MS EDGE browser and do not get the same problem, it log's-on OK.

As such it seems that it is a Firefox problem.

Asked by Brian E 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Unable to show File Picker

This was going to be a question about Firefox being unable to display the file picker dialog, but I managed to find a solution that worked for me along the way. Since it … (funda kabanzi)

This was going to be a question about Firefox being unable to display the file picker dialog, but I managed to find a solution that worked for me along the way. Since it was nowhere near the top of Google's results, I thought I'll share my solution in the hopes that this would help someone facing this same issue.

The hardware:

  • Asus UM425IA Zenbook (AMD Ryzen 7 4700U CPU)

Worked in:

  • Ubuntu 20.04 LTS
  • Firefox provided by APT repository
  • Xorg display server

Not working in:

  • Ubuntu 22.04 LTS
  • Firefox 99.0.1 provided by snap
  • Wayland display server
  • File picker worked briefly on fresh install, but something (not sure what) quickly breaks file picker functionality

The symptoms:

  • Firefox stopped being able to open file picker dialogs
  • Right clicking an image and selecting "Save Image As..." does nothing
  • With forms that accept file upload (such as on this post question page "Add images (optional):"), clicking "Browse" does nothing
  • File downloads work correctly when set to "Save files to ..." under Settings, but nothing happens when set to "Always ask you where to save files"
  • No response to "Ctrl + O" open file shortcut

Similar questions and solutions:

Things I tried that did not work:

  • Disabling hardware acceleration
  • Starting with add-ons disabled
  • Troubleshoot mode
  • Clearing startup cache
  • Clearing cookies and site data
  • Clearing history
  • Refreshing Firefox
  • Creating and using a new profile
  • Deleting the `xulstore.json` file from the profile directory
  • Toggling all permissions under Ubuntu Settings > Applications > Firefox to off and then back to on
  • chmod 777 ~/Downloads
  • Disabling native file picker "ui.allow_platform_file_picker = false"

And finally, what fixed it for me was to go into "about:config" and change "widget.use-xdg-desktop-portal.file-picker" from "2" to "0". Credit to this post that clued me in.

I really hope this saves someone else 2 days of hair pulling and I would appreciate advice from someone more knowledgeable than me on:

  • Why this fixed the problem
  • Whether I should be opening a bug report either against Firefox, or Ubuntu
  • Whether I should also be changing "widget.use-xdg-desktop-portal.mime-handler" and "widget.use-xdg-desktop-portal.settings", both are currently set to "2"

Asked by James Fu 1 unyaka odlule

Answered by Kiki 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox can't play youtube streams

I cannot watch a video on youtube when it is in the process of being live streamed. I remember a time when I was able to, years ago, but I can't any longer. I'm not sure … (funda kabanzi)

I cannot watch a video on youtube when it is in the process of being live streamed. I remember a time when I was able to, years ago, but I can't any longer. I'm not sure what has changed. I found an article that says to install the optional update called "Windows Media Pack" in apps and features, but no app with that name exists. It was only a year old solution, so I'm unsure of what changed so significantly. I just installed another optional windows update, and also updated the browser, but still doesn't work.

Edition Windows 10 Home Version 21H2 Installed on ‎09-‎Jun-‎20 OS build 19044.1466 Experience Windows Feature Experience Pack 120.2212.3920.0

Firefox: 97.0 (64-bit)

Asked by tomi.fodor 2 iminyaka edlule

Answered by tomi.fodor 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Issue with most Google sites on Firefox v100 64bit

I can log into GMail via our SSO just fine, however after a few minutes I see the "error connecting for X-minutes" bar. I try to force refresh the site and every time I … (funda kabanzi)

I can log into GMail via our SSO just fine, however after a few minutes I see the "error connecting for X-minutes" bar. I try to force refresh the site and every time I get the bellow error. This is also happening when I am using Firefox Troubleshooting mode, to see if maybe it's a plugin/extension causing this issue, but it's not.

Secure Connection Failed

An error occurred during a connection to mail.google.com. SSL peer reports incorrect Message Authentication Code.

Error code: SSL_ERROR_BAD_MAC_ALERT

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

Asked by scriptguru1701 1 unyaka odlule

Answered by jscher2000 - Support Volunteer 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

"NetworkError when attempting to fetch resource." on many websites

in the last day firefox has all but stopped working on most websites. i can go to them and they start to load, but then they eventually break halfway through and either e… (funda kabanzi)

in the last day firefox has all but stopped working on most websites. i can go to them and they start to load, but then they eventually break halfway through and either end up loading forever or produce an error. if i look at the console i see "Source map error: Error: NetworkError when attempting to fetch resource." this happens on twitter.com and raidbots.com to name two off the top of my head.

i did a complete refresh and even completely uninstalled and reinstalled the browser - it started working for a bit and then broke again. i have no plugins or extensions enabled currently (i have dashlane but this happens with it enabled or disabled). it's making the browser unusable. ive scanned my computer for malware and cant find anything either. i don't have this problem in any other browsers so not sure what else to try.

Asked by fnnmyr 10 izinyanga ezidlule

Answered by cor-el 10 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

YouTube blacks out entire screen while watching video.

Hi, so yesterday, I updated to the latest version of FireFox (version 105.0). Nothing seemed to be out of the ordinary until I decided to watch a few YouTube videos. The … (funda kabanzi)

Hi, so yesterday, I updated to the latest version of FireFox (version 105.0). Nothing seemed to be out of the ordinary until I decided to watch a few YouTube videos. The best way I can describe this problem is that every time I decide to scroll down to see the description or read a few comments, the entire screen on my laptop goes black regardless if it's on default view or full screen.

Even though that does sound like a crash, the audio still plays, and if I power the computer to sleep mode and log back in, the window of the video automatically scrolls up and everything is back to the way it was (but I did had to restart the laptop once because it also visually broke my mouse pointer). The only way I can get around this problem is to pause whatever video I watch and then scroll down, and no black screen occurs.

I don't know if I'm the only one who has this problem, but I've never had this issue happen in past versions of FireFox. If there is another way to fix this problem, I'll be glad to take anyone's possible suggestions/solutions.

Asked by dashoobi 1 unyaka odlule

Answered by techguy150 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

google not loading after connecting to VPN network

google.com and google related websites doesn't load at all. For example, gmail slowly loads, but loading icon never disappears, loading icon is always shown and then ofte… (funda kabanzi)

google.com and google related websites doesn't load at all. For example, gmail slowly loads, but loading icon never disappears, loading icon is always shown and then often it shows 'reconnecting' message. This works OK in Chrome.

Steps to reproduce: 1. Open Firefox without VPN - all loads well. 2. Enable VPN - stops loading. If I then disable VPN - it starts loading again.

If I restart Firefox it starts working OK, but after a while stops working again.

Asked by kantix 2 iminyaka edlule

Answered by kantix 2 iminyaka edlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox takes a long time to be responsive on first start

I'm having the exact same problem that https://support.mozilla.org/en-US/questions/1157490 firefox itself opens and loads within seconds perfectly fine,[...] But when… (funda kabanzi)

I'm having the exact same problem that

https://support.mozilla.org/en-US/questions/1157490

firefox itself opens and loads within seconds perfectly fine,[...] But when I try to go to any website, it takes ages to load and function normally. [...]

Once it has loaded the website(s) it functions completely normally

As the solution in that thread was a full format I'm reopening this to find a more precise solution.

I tried everything on that thread without success. Deactivated every plug-in and the problem persist. Running in safe-mode corrects the problem.

I attach an image of the profiler (I can send the full profile if needed)

Asked by joseluismx33 1 unyaka odlule

Answered by joseluismx33 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Scrolling lagging on every website

I get so choppy scrolling that my eyes hurt after few minutes. Doesn't happen on Chrome or Edge. It is most noticable on YouTube. It feels like it's running at 15fps … (funda kabanzi)

I get so choppy scrolling that my eyes hurt after few minutes. Doesn't happen on Chrome or Edge. It is most noticable on YouTube. It feels like it's running at 15fps

Asked by SpookieGames 1 unyaka odlule

Answered by SpookieGames 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

DUO: "Access Not Allowed With Firefox Due To Security Concerns

I've been utilizing the security protocol app DUO for work purposes for the last year with Firefox, no issues. I just recently updated to 105.0.1 and received the follow… (funda kabanzi)

I've been utilizing the security protocol app DUO for work purposes for the last year with Firefox, no issues. I just recently updated to 105.0.1 and received the following error message when my DUO was prompted:

  • "We're sorry, access is not allowed with Firefox due to security concerns." - with a sad face.

It then shows me a list of compatible browsers and FF being the only one not allowed to use the DUO authentication. I've attempted to clear my browsers cache, fire up FF once more only to arrive at the same messaging. I've uploaded a screenshot of what I ran into.

This has to be some sort of error as I've been utilizing FF and DUO together successfully with no issues over the last year.

Any help is greatly appreciated.

Asked by Eddie 1 unyaka odlule

Answered by Eddie 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Copy-pasting of files not working in Ubuntu 22.04

Hey there, Intro: I recently switched to Linux and (because Brave is so broken) also to Firefox and I am liking it so far. Problem: Unfortunately I can't copy-paste fil… (funda kabanzi)

Hey there,

Intro: I recently switched to Linux and (because Brave is so broken) also to Firefox and I am liking it so far.

Problem: Unfortunately I can't copy-paste files from Ubuntu Files (Nautilus) to Firefox (I tested image files and also sounds files, neither is working).

Test with Firefox: 1. Download a random photo (e.g. from Unsplash) 2. Select the file and hit ctrl + c in Files/Nautilus 3. I go to the clipboard inspector 4. I hit ctrl + v 5. The image does not show up in the output (see screenshot)

Test with Brave: 1. Do the same as above 2. The image does show up in the output (see screenshot)

Notes: - I am using Linux Ubuntu 22.04 with Wayland - Firefox Version 107.0 (64-bit) for Ubuntu Canonical - 1.0 - I have no extensions installed - I am not using the snap version (so I can scroll smoothly) ... I think I used apt-get install but not 100% sure

Asked by Stephan 1 unyaka odlule

Answered by Stephan 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Code erreur PR_END_OF_FILE_ERROR

Bonjour, Depuis une semaine, j'ai ce message à l'ouverture de ma page d'accueil Orange, avec Firefox !! PR_END_OF_FILE_ERROR il n'y a qu'avec mon navigateur et pas … (funda kabanzi)

Bonjour, Depuis une semaine, j'ai ce message à l'ouverture de ma page d'accueil Orange, avec Firefox !! PR_END_OF_FILE_ERROR il n'y a qu'avec mon navigateur et pas sur Chrome ni Edge. Avant, j'étais le seul impacté par ce problème et maintenant les trois P.C de la maison le sont. Deux W11 et un W10. En déconnectant le VPN le souci n'existe plus. Merci d'avance pour votre aide.

Asked by YAGO 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Excessive apparmor log entries on Ubuntu platform

OS version: Ubuntu 22.04.1 LTS (jammy), 64-bit (amd64, x86_64). Firefox version: 110.0 (64-bit) (NOTE: the issue was noticed with version 109.0, too) Firefox package wa… (funda kabanzi)

OS version: Ubuntu 22.04.1 LTS (jammy), 64-bit (amd64, x86_64). Firefox version: 110.0 (64-bit) (NOTE: the issue was noticed with version 109.0, too)

Firefox package was installed on Ubuntu through 'APT', using the Mozilla Team repository (https://ppa.launchpadcontent.net/mozillateam/ppa/ubuntu/). It caught my attention that an excessive amount of Firefox related 'DENIED' AppArmor log messages is generated during the browser activity.

According to messages, Firefox is occasionally denied read access to '/sys/devices/' area and read/write access to 'oom_score_adj' target in '/proc/'. Could somebody clarify why would that access be required for regular browser operations? I'm a bit puzzled as I haven't noticed anything similar with the older Ubuntu and Firefox versions. A complete suppression of those messages is also an option as long as there's no negative impact on application's performance.

I already posted this question to Ubuntu forum but seems like nobody there could provide an explanation. I'd appreciate any input or hint.

Following is the sample of referred log messages:

---SNIP--- [Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.813:39): apparmor="DENIED" operation="capable" profile="firefox" pid=2231 comm="firefox" capability=21 capname="sys_admin"

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.877:40): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/revision" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.877:41): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/config" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.877:42): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/revision" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.877:43): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/config" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.885:44): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/revision" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.885:45): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/config" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.885:46): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/revision" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0

[Fri Feb 24 19:14:50 2023] audit: type=1400 audit(1674000890.885:47): apparmor="DENIED" operation="open" profile="firefox" name="/sys/devices/pci0000:00/0000:00:02.0/config" pid=2235 comm="firefox" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0 . . . . . . [Fri Feb 24 19:16:22 2023] audit: type=1400 audit(1674000983.040:56): apparmor="DENIED" operation="open" profile="firefox" name="/proc/2347/oom_score_adj" pid=2231 comm="firefox" requested_mask="w" denied_mask="w" fsuid=1000 ouid=1000

[Fri Feb 24 19:16:35 2023] audit: type=1400 audit(1674000995.296:57): apparmor="DENIED" operation="open" profile="firefox" name="/proc/2347/oom_score_adj" pid=2231 comm="firefox" requested_mask="w" denied_mask="w" fsuid=1000 ouid=1000

[Fri Feb 24 19:16:39 2023] audit: type=1400 audit(1674000999.280:58): apparmor="DENIED" operation="open" profile="firefox" name="/proc/2347/oom_score_adj" pid=2231 comm="firefox" requested_mask="w" denied_mask="w" fsuid=1000 ouid=1000

[Fri Feb 24 19:16:41 2023] audit: type=1400 audit(1674001001.768:59): apparmor="DENIED" operation="open" profile="firefox" name="/proc/2455/oom_score_adj" pid=2231 comm="firefox" requested_mask="w" denied_mask="w" fsuid=1000 ouid=1000

[Fri Feb 24 19:16:41 2023] audit: type=1400 audit(1674001001.768:60): apparmor="DENIED" operation="open" profile="firefox" name="/proc/2458/oom_score_adj" pid=2231 comm="firefox" requested_mask="w" denied_mask="w" fsuid=1000 ouid=1000 ---SNIP---

Asked by scoobienator 1 unyaka odlule

Answered by cor-el 1 unyaka odlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox Memory Leak Microsoft

Hi. When opening the Microsoft Website (answers.microsoft.com) i experience some memory leaks. See photo for details. Someone knows why? … (funda kabanzi)

Hi. When opening the Microsoft Website (answers.microsoft.com) i experience some memory leaks. See photo for details.

Someone knows why?

Asked by SuperFurias 9 izinyanga ezidlule

Answered by SuperFurias 9 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Error message "You need to enable JavaScript to run this app." continues

Hi all I'm a happy user of FF but have started to see issues with JavaScript (error message: You need to enable JavaScript to run this app.). I do the about:config corre… (funda kabanzi)

Hi all

I'm a happy user of FF but have started to see issues with JavaScript (error message: You need to enable JavaScript to run this app.). I do the about:config correction and it sometimes works, but now the error is spreading to involve other pages - a page worked yesterday doesn't work today.

Is it just me?

//Allan, Sweden

Asked by Allan Andersen 1 unyaka odlule

Answered by Paul 1 unyaka odlule

  • Kusonjululiwe

Can't open Firefox - error re "platform version '120.0.1'

Hello, Clicking to open Firefox gives me the following error message: Error. Platform version '120.0.1' is not compatible with miniVersion >= 120.0 maxVersion <= … (funda kabanzi)

Hello,

Clicking to open Firefox gives me the following error message:

Error. Platform version '120.0.1' is not compatible with miniVersion >= 120.0 maxVersion <= 120.0

Can't open firefox! I'm running Windows 11 version 10.0.22631 Build 22631

Thanks! Julie

Asked by Julie 3 izinyanga ezidlule

Answered by Terry 3 izinyanga ezidlule

  • Kusonjululiwe
  • Okugcinwe kunqolobane

Firefox crash after ubuntu 22 update.

After an update of ubuntu 22 on my computer, Firefox does not render properly (see the screenshot of my desktop). I have tried to reinstall it but it continues to happen.… (funda kabanzi)

After an update of ubuntu 22 on my computer, Firefox does not render properly (see the screenshot of my desktop). I have tried to reinstall it but it continues to happen. All the other programs works fine, it is only firefox.

My system is: Ubuntu 22.04.2 LTS Processor: AMD Rysen 5 3600 6 core procesor x 12 Graphics: AMD Radeon rx 5500 tx

Thanks.

Asked by holadanielam 7 izinyanga ezidlule

Answered by zeroknight 7 izinyanga ezidlule