顯示問題標籤 顯示所有問題

20 GB RAM usage, pagefile takes up all space on C: - 300 tabs in Tree Tabs

First, this post is basically Congratulations for Firefox upon working almost flowlessly under this extreme heavy load without crashing. Saving/loading sessions works wel… (閱讀更多)

First, this post is basically Congratulations for Firefox upon working almost flowlessly under this extreme heavy load without crashing. Saving/loading sessions works well. (which is unexpected but makes me _very_ happy :-)) Firefox exits properly without any exceptions, no matter how long it runs, or how many times the PC is sent to STR mode meanwhile.

Second, everything is fine, except RAM usage. No matter how many RAM is installed, Firefox takes up all of it after a few days of normal operation. I have recently upgraded my PC from 16 to 24 GB of RAM only for this sole reason to see if anything changes, but it did not produce any noticable change, except that it takes 5-7 days for Firefox to fill up all the RAM instead of the 3-4 days before. Disk space on C: drive was nullified by Firefox as the paging file went up to 50 GB.

I want to hunt down this thing. I have approx. 300 tabs, 2 addons, and Hardware Acceleration is disabled since otherwise Fox hangs several times a day (have to be killed from outside). Pics are attached. https://addons.mozilla.org/hu/firefox/addon/tree-tabs/ https://gitlab.com/kroppy/TreeTabs

I'd like to get suggestions where to start.

  1. Disabling or replacing the adblocker ?
  2. Inspecting memory usage on Process Manager (about:processes) and Task Manager (about:performance) pages ?
  3. Installing some external tools like Firemin ?

Please don't suggest neither safe mode nor disabling all addons, since that makes it impossible to reproduce this amount of load, which is the primary reason behind the symptom.

I PrtScr'ed Process Manager and Task Manager, see that RAM sizes per page are normal in Task Manager, but not in Process Manager (10 times more).

CPU usage is totally normal for this load, even when memory is in the heaven. See the TaskMan pic. (I suppose that's because of ad blocking)

Thanks for any ideas,

Peter B. (I'm PC enthusiast)

-- Windows 7 Ultimate SP1 64 bit Firefox 106.0.5 (latest autoupdated) no firewall nor any antivirus - since 20 years with no infection ... AMD FX-6350 Six-core ASUS M5A99FX PRO R2.0 24 GB DDR3 1600 MHz Sapphire Radeon HD 5750 1GB (AMD Catalyst 15.11.1, Nov 18, 2015)

Peter B. 於 2 週前 詢問

Peter B. 最近回覆 於 1 天前

Picture-in-picture not showing

When on youtube or any video website, when I click the PiP button on the side of the video, instead of having the video popup on the screen I have a new windows (only vis… (閱讀更多)

When on youtube or any video website, when I click the PiP button on the side of the video, instead of having the video popup on the screen I have a new windows (only visible in the windows taskbar) which is invisible.

If I try to hover the (empty) preview in windows, it should hide everything else and show the window, but nothing happens as if the popup create a window but stops in the middle.

I tried with Firefox (v107.0 64-bit) and Firefox dev edition (v108.0b6 64-bit), same problem. I tried disabling every addon/theme, same problem. I tried disabling hardware acceleration, same problem. I tried Troubleshoot mode, works correctly.

Before re-installing Windows it worked normally. What could be the problem ?

EdgelordMcTeabag 於 1 天前 詢問

EdgelordMcTeabag 最近回覆 於 3 小時前

Back button doesn't work, only changes the URL

Hello there! I have a strange issue where only the URL changes when I press the back button, it seems to happen randomly, but it isn't only happening to me, I was in a di… (閱讀更多)

Hello there! I have a strange issue where only the URL changes when I press the back button, it seems to happen randomly, but it isn't only happening to me, I was in a discord call yesterday when I saw it happen for my friend too. See attached gif for an example. Any idea what could cause this, or how to fix it? I haven't found any other threads about this, but I haven't looked very hard.

Jani 於 3 天前 詢問

Jani 最近回覆 於 3 天前

Twitter Video Streaming in Firefox is Terrible

Twitter Video Streaming in Firefox on an older computer (Windows 7) does not work. The videos don't play (just audio). I logged into my same Twitter account on Chrome on … (閱讀更多)

Twitter Video Streaming in Firefox on an older computer (Windows 7) does not work. The videos don't play (just audio). I logged into my same Twitter account on Chrome on the same computer and Twitter video streaming worked perfectly. Please fix the disparity.

brookse321 於 3 天前 詢問

brookse321 最近回覆 於 2 天前

Titlebar and tabs missing in full screen mode (literally missing)

From time to time when maximising the Firefox window, the top 20-80 pixels or so are replaced with a white bar. It is usually possible to grab the window by clicking som… (閱讀更多)

From time to time when maximising the Firefox window, the top 20-80 pixels or so are replaced with a white bar.

It is usually possible to grab the window by clicking somewhere next to the address field, and thereby move the window downwards, alt double clicking there which set the window to "not full screen".


Right-click in any of the "white" areas - which is located inside the FF window - opens the Windows desktop menu.

screenshot 1 - "not full screen" (all is fine) screenshot 2 - FF in full screen mode (title bar vanished - replaced by white space) screenshot 6 - right-click in white space opens Windows desktop menu

Found a few reports that seem similar but not identical to this one. Rebooting the computer usually helps but after a while the problem returns. It is a rather old machine, and quite possible that this is not caused by FF, however, only FF suffers from this behaviour - any other application works "normally" (i.e. you see the title bar and buttons when the window is maximised).

branpet 於 2 天前 詢問

branpet 最近回覆 於 1 天前

Unable to upload attachments in outlook/OneDrive from Firefox

Hi, I'm using Firefox 107.0 (64-bit) version and I'm unable to upload attachments in outlook online, One drive using Firefox browser. Tried with chrome, edge etc.. and th… (閱讀更多)

Hi,

I'm using Firefox 107.0 (64-bit) version and I'm unable to upload attachments in outlook online, One drive using Firefox browser. Tried with chrome, edge etc.. and the files are uploading without any errors.. Kindly advise to solve this issue.

joemon.thomas 於 1 週前 詢問

joemon.thomas 最近回覆 於 3 天前

Picture-in-picture is not working

I am using firefox on a Macbook pro M1 using Ventura. The picture-in-picture feature is not working. When I click on the popup button for p-i-p, it only pauses the video,… (閱讀更多)

I am using firefox on a Macbook pro M1 using Ventura. The picture-in-picture feature is not working. When I click on the popup button for p-i-p, it only pauses the video, it does not start the picture-in-picture.

I've uploaded a .gif of me clicking on the button in YouTube.

cmm225 於 3 天前 詢問

cmm225 最近回覆 於 23 小時前

some pages dont load proprely

Hi Firefox, my https://castbox.fm and https://linkedin.com/ aren't loading properly in my Firefox. Please see the images in attach. Can you please explain why this is ha… (閱讀更多)

Hi Firefox, my https://castbox.fm and https://linkedin.com/ aren't loading properly in my Firefox. Please see the images in attach. Can you please explain why this is happening ?

Thanks Gonçalo

Gonçalo 於 2 天前 詢問

Gonçalo 最近回覆 於 2 天前

Resolving link issue

for example: navigation to firefox.com works instantly trying to get there from a search result https://www.google.com/search?client=firefox-b-1-d&q=firefox+forums ha… (閱讀更多)

for example: navigation to firefox.com works instantly

trying to get there from a search result https://www.google.com/search?client=firefox-b-1-d&q=firefox+forums

hangs the browser.

new tabs wont work correctly. I have to close the browser and start over. It will always hang again.

This is a new windows 10 and browser installation (about 10 days old). I had to replace my boot drive due to hw failure.

axw 於 4 天前 詢問

Warum startet Firefox nicht mehr?

Guten Tag! Seit einiger Zeit startet Firefox nicht mehr. Wenn ich ihn als Admin starte, startet er zwar, friert aber sofort wieder ein und rührt sich nicht mehr. Ich habe… (閱讀更多)

Guten Tag! Seit einiger Zeit startet Firefox nicht mehr. Wenn ich ihn als Admin starte, startet er zwar, friert aber sofort wieder ein und rührt sich nicht mehr. Ich habe ihn mehrfach deinstalliert und wieder sauber installiert und aktualisiert. Nichts hilt. Was läuft da falsch? Danke! klaus1003

klaus1003 於 2 天前 詢問

YouTube Wont Play In Private Window

Firefox 103.0.2 (64 bit) doesn't play YouTube videso in Private Window. The same videso play in s statdrad new window. Try: https://www.youtube.com/watch?v=0fiVciCs8zU wh… (閱讀更多)

Firefox 103.0.2 (64 bit) doesn't play YouTube videso in Private Window. The same videso play in s statdrad new window. Try: https://www.youtube.com/watch?v=0fiVciCs8zU which ironically won't play in private! Every time you press the play button you get about half a second of play before pausing. In standard mode it plays just fine.

Les 於 4 天前 詢問

Loading Firefox is slow and lagging, crashing often

it is taking over 30 seconds, sometimes several minutes to load firefox, especially first thing in the day. Rebooting computer only makes it worse. Any thought's on how… (閱讀更多)

it is taking over 30 seconds, sometimes several minutes to load firefox, especially first thing in the day. Rebooting computer only makes it worse. Any thought's on how to speed up responsiveness?

chris-nancy 於 4 天前 詢問

Firefox opens websites and follow links only after retry

I'm on macOS's Firefox Developer Edition 108.0b3 right now (arm64/M1 CPU). Though my current version is a bit outdated, this problem appeared several months ago and still… (閱讀更多)

I'm on macOS's Firefox Developer Edition 108.0b3 right now (arm64/M1 CPU). Though my current version is a bit outdated, this problem appeared several months ago and still bothers me to this day.

When I, or any another application, opens a new link in Firefox, the browser _doesn't initiate the request_. So the address bar changes, new tab opens, but absolutely nothing happens afterwards, I'm just getting blank page. In order to get site opened, I have to click the address bar and press enter. Rarely, even that does not help and I have to press enter one more time again. The same applies to the basic links too - on this support website I practically had to click every link twice to get it opened. The click even is clearly registered: I see the :active state for a second. But afterwards, nothing happens, just like event got canceled in browser (clearly not JS error since it not only happens with links). It doesn't matter which site I'm using, where I am (even start page has this bug), and don't really seem to be connected to the extensions I'm using (recently I had high RAM usage by extension, and being unable to determine which extension uses RAM I disabled most of the untrusted extensions, which do not have cup icon given by Mozilla or not very popular), so I practically use _mostly_ clean Firefox now.

Before going full reset, I wonder if anyone happen to have the same issue?

dantaeusb 於 1 天前 詢問

Firefox (v107.0 64 bits) fails to connect to an IIS website that has Extended Protection configured

Dear team I'm trying to use firefox to connect OWA on an Exchange server where Extended Protection (EP) is configured. OWA website is configured to use basic and windows… (閱讀更多)

Dear team I'm trying to use firefox to connect OWA on an Exchange server where Extended Protection (EP) is configured. OWA website is configured to use basic and windows authentication. When EP is off, it works fine, meaning it connects automatically. When EP is set to require, then I get a credential prompt, that loops prompting me for the credentials Strange thing is if the 1st time I get prompted I press Escape key, and at the 2nd prompt I enter my credentials, then I connect the webmail.

These settings were configured in the about:config with the webmail URL "network.automatic-ntlm-auth.trusted-uris" "network.negotiate-auth.delegation-uris" "network.negotiate-auth.trusted-uris" and this one "signon.autologin.proxy" has been set to true

If I use Chrome or Edge, I do not face this issue I found this website https://www.synacktiv.com/en/publications/dissecting-ntlm-epa-with-love-building-a-mitm-proxy.html which seems to explain the issue I'm facing but it talks about Firefox v93.

Anyone knows how to fix this issue?

Regards

Seb 於 1 天前 詢問

Having trouble signing into firefox

For last few weeks I am have trouble opening my browser after clicking on it several times. Some times I have to right click and select open from the drop down menu. I do… (閱讀更多)

For last few weeks I am have trouble opening my browser after clicking on it several times. Some times I have to right click and select open from the drop down menu. I done the restore to the previous version, but did not help but did loose all my bookmarks and other personal setting, which has taken me a long time to fine tune to my personal likes, I am not happy about this. I do not have any trouble opening Microsoft Edge. If I can not get this fixed soon, I will switch to Google chrome. This has cost me a lot of frustration over the last several weeks and properly add to that once I get it fix, as I have lost all my personal setting. I am a 75 year old frustrated man. Thanks Gary

garyflossie 於 6 天前 詢問

Delayed browser start after version 107 update

I've noticed that for the last few days, Firefox takes several seconds to start. I happened to look in settings while I have the spinning ball and waiting for it to star… (閱讀更多)

I've noticed that for the last few days, Firefox takes several seconds to start. I happened to look in settings while I have the spinning ball and waiting for it to start, and noticed that the "Checking for updates" is running. The moment that it verifies Firefox is up to date, my initial browser page opens with my default page. It looks like version 107 was installed on Nov 15th, which is just about the time I noticed this problem occurring.

Is there any fix for this or is that something I have to live with until enough people notice it as a problem and a new update is released? Using Windows 10 if that makes any difference.

Thanks for any help from any of you.

jdcarpenter1 於 6 天前 詢問

firefox hangs whenever i open tumblr

afternoon, my keyboard is missing several keys so please bear with me. I have been having issues opening Tumblr in firefox for about a month now. I have been clearing my … (閱讀更多)

afternoon, my keyboard is missing several keys so please bear with me. I have been having issues opening Tumblr in firefox for about a month now. I have been clearing my cache, i deleted all of my browser history and cookies to the beginning of time, and tumblr still hangs whenever i open it, going unresponsive until I forcequit from the task manager. sometimes, if I grab the scrollbar and get it away from the top of the page before it hangs, itll let me browse no issue, but most of the time it takes about 2 seconds to become hanging/unresponsive. I have not experienced this issue on any other site with the frequency that Tumblr experiences, and I cannot find any help desk information about a problem like this. I would really like to avoid moving to a different browser but its getting kind of insane how hard it is to live around it. if I have music/video going in the background, it will continue to play while Im forced to hang on tumblr, until I forcequit.

littlebluecolor 於 3 天前 詢問