顯示下列標籤的問題: 顯示所有問題

Unblocking websites

All of a sudden I can't open a certain website. I opened the website a few days ago with no problem and have been using the site for years. (I checked to see if the site … (閱讀更多)

All of a sudden I can't open a certain website. I opened the website a few days ago with no problem and have been using the site for years. (I checked to see if the site is down but it's not.) I googled how to unblock websites in Firefox and nothing I've tried works. I disabled Trackers for the website and I cleared my Cookies. I added the Firefox uBlock extension a few weeks ago to stop constant website popups (after I tried resetting Firefox) and I turned uBlock off for this certain website but I still can't access the website. I also installed Mozilla VPN last week. I'm using Firefox 122.0.1. What could be the problem?

grov10 於 2 個月前 詢問

zeroknight 最近回覆於 2 個月前

error message www.bbc.com. PR_END_OF_FILE_ERROR Error code: PR_END_OF_FILE_ERROR

For the past couple of months I have been getting the message www.bbc.com. PR_END_OF_FILE_ERROR Error code: PR_END_OF_FILE_ERROR when loading pages on www.bbc.com websi… (閱讀更多)

For the past couple of months I have been getting the message www.bbc.com. PR_END_OF_FILE_ERROR

Error code: PR_END_OF_FILE_ERROR when loading pages on www.bbc.com website. I have done a search on the internet and it seems this is a common problem with Firefox and does not affect othere browesers. I have done what was advice given online but it does not solve the problem. It is getting so bad I may have to start using one of the other browsers even though I prefare Firefox.

Brian Beesley 於 2 個月前 詢問

cor-el 最近回覆於 2 個月前

Why can't Firefox copy text anymore?

Why can't Firefox copy text to the clipboard anymore? It won't copy text from a web page, from a URL, or even from about:support "Copy text to clipboard"!!! I'm using ver… (閱讀更多)

Why can't Firefox copy text to the clipboard anymore? It won't copy text from a web page, from a URL, or even from about:support "Copy text to clipboard"!!! I'm using version 1.22 64 bit on windows 11. I've reinstalled Firefox but it doesn't make a difference. I've tried "Troubleshoot Mode" and it's still broken!!!

I can paste into Firefox but something has broken copy!

FirefoxUser73 於 2 個月前 詢問

zeroknight 最近回覆於 5 天前

Firefox opening two windows at startup

Firefox is now opening two windows at startup: one that has my previous session (which I always prefer) and one window with one blank tab. It used to open only the saved… (閱讀更多)

Firefox is now opening two windows at startup: one that has my previous session (which I always prefer) and one window with one blank tab. It used to open only the saved session. What can I do do change this. Thank you. (I have Firefox 122 version)

VegRunner66 於 2 個月前 詢問

cor-el 最近回覆於 2 個月前

Norton Safe Search

My default search engine was Norton Safe Search but now it does not appear as one of the options to choose. I cannot remember all of them. Bing and Google are two of them… (閱讀更多)

My default search engine was Norton Safe Search but now it does not appear as one of the options to choose. I cannot remember all of them. Bing and Google are two of them but not Norton Safe Search although I have been able to add it to the toolbar. Why is it no longer one of the options?

ju.col 於 3 週前 詢問

jscher2000 - Support Volunteer 最近回覆於 3 週前

Is AdBlock scamming all Firefox users, or do you not want their partnership?

AdBlock has not made any updates for Firefox for eleven months. Do they just not care, or has Mozilla rejected them? The internet is terrible enough as it loves to scam a… (閱讀更多)

AdBlock has not made any updates for Firefox for eleven months. Do they just not care, or has Mozilla rejected them? The internet is terrible enough as it loves to scam all users on all sites.

Benjamin_Minney 於 3 個月前 詢問

cor-el 最近回覆於 3 個月前

"Your browser is being managed by your organization"

"Your browser is being managed by your organization" is on the top of my settings page and it preventing me from using some of my streaming services. I am at my home, don… (閱讀更多)

"Your browser is being managed by your organization" is on the top of my settings page and it preventing me from using some of my streaming services. I am at my home, don't work at a job where I would ever be on a network, what the heck? It is some name I don't even know. Did I get hacked? Is it a virus? Nothing I have seen on here so far has worked, and I AM NOT A LINUX USER. (After looking at other answers, seems to be a problem with Linux.) I am on Windows 11. Thanks!

jbunds 於 2 個月前 詢問

cor-el 最近回覆於 2 個月前

Cursor won't show when writing a letter or note. So I don't know where i stop typing? It works here but not when I open my browser to write letter?

Cursor won't show when writing a letter or note. So I don't know where i stop typing? It works here but not when I open my browser to write letter? … (閱讀更多)

Cursor won't show when writing a letter or note. So I don't know where i stop typing? It works here but not when I open my browser to write letter?

JSM 於 2 個月前 詢問

zeroknight 最近回覆於 2 個月前

Primary Password asked every time I open the browser

Dear community, since some recent update I am asked for a primary password every time I open the browser, which is higly annoying. I like my passwords protected by a pri… (閱讀更多)

Dear community,

since some recent update I am asked for a primary password every time I open the browser, which is higly annoying. I like my passwords protected by a primary password and in former times it was only asked for when trying to reveal a saved password. I know this has probably to do with me using Firefox sync, because I use the browser on my Android too but I would like to keep my devices synced. Besides: On my phone I am only asked for a fingerprint when accessing passwords, not every single time I open the app. There must be a way to reconfigure this on a desktop, right?

Jonah 於 2 個月前 詢問

cor-el 最近回覆於 2 個月前

Developer Edition switched to dark background and I cannot undo this setting

I change nothing in my settings and I am now on Dark background everywhere despite having: - forced the system settings (OS) to stay in light background - in about:prefer… (閱讀更多)

I change nothing in my settings and I am now on Dark background everywhere despite having: - forced the system settings (OS) to stay in light background - in about:preferences appearance I've manually selected (forced) the light background - in about:config I've tried to switch the browser.theme.content-theme to "1" (instead of "0")

this is really frustrating, I would like to get a better "reading" of what happens, as an Engineer I am happy to also squint at logs if needed, please consider adding a preference / settings change log file

looeegee 於 3 個月前 詢問

cor-el 最近回覆於 3 個月前

Firefox v122 --profile option is not working properly

Hi, I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap) and when using the --profile option to specify the startup pr… (閱讀更多)

Hi,

  I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap)

and when using the --profile option to specify the startup profile it fails to start even on a NEW system that never ran Firefox if I give it a directory that resides on a mounted ext3 filesystem.

  All the permissions are OK and yet running strace I see an error and after a few second will get the

generic pop-up with the error message: (after a few seconds)

Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile.

 Running the SAME from /tmp works fine, but I need the profile to reside on a persistent storage area

so if the LIVE distro restarts then it can restore the previous session, bookmarks, options, etc...


============================================================
 The 2 directories were created identically and have the exact same permissions:

xubuntu@xubuntu:~$ mkdir /tmp/firefox3

xubuntu@xubuntu:~$ mkdir /media/xubuntu/sys_n01_home/mozilla/firefox3

xubuntu@xubuntu:~$ ls -ald /tmp/firefox3 drwxrwxr-x 17 xubuntu xubuntu 1080 Jan 21 22:05 /tmp/firefox3

xubuntu@xubuntu:~$ ls -ald /media/xubuntu/sys_n01_home/mozilla/firefox3 drwxrwxr-x 17 xubuntu xubuntu 4096 Jan 21 21:13 /media/xubuntu/sys_n01_home/mozilla/firefox3

============================================================

The only difference is that one is mounted on tmpfs and the other is on /dev/nvme0n1p2:

xubuntu@xubuntu:~$ df -k /tmp/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on tmpfs 32560016 351528 32208488 2% /tmp

xubuntu@xubuntu:~$ df -k /media/xubuntu/sys_n01_home/mozilla/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on /dev/nvme0n1p2 195751828 51056068 142695768 27% /media/xubuntu/sys_n01_home


============================================================

When starting firefox with the /tmp/firefox3 profile directory it works fine and starts up:

xubuntu@xubuntu:~$ firefox --profile /tmp/firefox3

newfstatat(AT_FDCWD, "/tmp/firefox3", {st_mode=S_IFDIR|0775, st_size=1040, ...}, 0) = 0 newfstatat(AT_FDCWD, "/tmp/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/tmp/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=-487933736}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = 0 uname({sysname="Linux", nodename="xubuntu", ...}) = 0


BUT when using the persistent storage on the real filesystem (but SAME exact permissions) it fails:

newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3", {st_mode=S_IFDIR|0775, st_size=4096, ...}, 0) = 0 newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=1519466008}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = -1 EACCES (Permission denied) close(11) = 0

Am I doing anything wrong or is this some weird startup issue / race condition in the parentlock management?

Thank you for looking into this.

  -Sanjiyan

PS: I can upload the full strace file for both scenarios if needed. Thanks again.

     running on an xubuntu distribution "22.04.2 LTS (Jammy Jellyfish)"

Sanjiyan 於 2 個月前 詢問

zeroknight 最近回覆於 2 個月前