搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Firefox 11 do not display properly some websites

  • 5 个回答
  • 7 人有此问题
  • 1 次查看
  • 最后回复者为 cor-el

more options

Hello. I wold like to ask your help in setting the Firefox 11 browser for a correct dispay of my website. This is how the site looks in Firefox 11: http://transport-in-comun.ro/firefox/site-Firefox.jpg and this is how it looks in IE8: http://transport-in-comun.ro/firefox/site-IE.jpg . About the site: the page is written in FrontPage (I do not have many knowledge of web-design), and the photo thumbnail and text near it is put into a 796px wide tabel. For some reason, Firefox 11 "narrows" the table. I didn't have this kind of problems when I was using Firefox 3.6, even if I was using it under Windows 7, that had the ClearType turned on by default. After the upgrade to Firefox 11, I start having problems in the viewing the above mentioned website and other sites with similar structure. I tried to adjust the ClearType settings, but it didn't help. With ClearType disabled, the text in the site is displayed how it should be, but it's fade. Thank you.

被采纳的解决方案

It seems a bit random. When I try to document similarities and difference, there are changes between refreshes. Are you editing the page now?


Graphics hardware acceleration is not new in Firefox 11, but it is being tweaked in each release. Do you want to try disabling it?

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

在上下文中阅读这个答案 👍 0

所有回复 (5)

more options

选择的解决方案

It seems a bit random. When I try to document similarities and difference, there are changes between refreshes. Are you editing the page now?


Graphics hardware acceleration is not new in Firefox 11, but it is being tweaked in each release. Do you want to try disabling it?

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

由jscher2000于修改

more options

Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl+0 (zero); Cmd+0 on Mac)
more options

By the way, a better way to position text to the right on a line is as follows:


<p><a href="link-url-goes-here"><img src="image-url-goes-here">Left-aligned text.<span style="float:right">Right-aligned text.</span></a></p>

If you use Frontpage's HTML view, you can insert the starting and editing span tags and clear out all those hard spaces. Worth a try?

(Edit: I left out a lot of the extra attributes in the tags in that simplified example. You don't need to change any of that.)

由jscher2000于修改

more options

Thank you all for your fast asnwers. The "Use hardware acceleration when available" was the problem, I disabled it and I will post a message on my site about this. The site is on-line in the same aspect since 2005, modifiyng the whole site to fit with Firefox11's default setting is not a good option. At that moment, placing a tabel (alligned to the center of the page) and puting in it the thumbnails with links generated by ExpressThumbnailCreator, than manually adding the description in the HTML view of FrontPage was the simplyest way possible to make the site appear properly on my 800*600 px resolution I used then. Of course, I upgraded my hardware and software since then, but the site remained mostly unchanged (except the index and a few files). I know it's time for a new version of the site but... my web-design knowledges are limited to basic HTML.

more options

That can be a problem with using Direct2D for rendering text.

You can try to disable D2D by setting the gfx.direct2d.disabled pref to true on the about:config page.