切换到 Thunderbird

从 Apple 邮件迁移到 Thunderbird

Thunderbird 能导入您的消息和 OS X 通讯录,但是无法导入您的账户设置。(目前,邮件和通讯录导入功能只支持 Apple 邮件 5.0 及 5.0 之前版本。)

导入 Apple 邮件中的消息

  1. 打开菜单栏中的工具 菜单,单击导入。导入向导随后会打开。

    mac-toolsimport

  2. 选择邮件然后单击下一步

    mac-importwizard

  3. 选择Apple 邮件然后单击下一步

    mac-importmail

  4. 导入成功后,您会看到成功导入文件夹的日志,然后单击完成关闭导入向导。

    mac-mailimportedsuccess

您导入的消息会出现在本地文件夹下的“Apple Mail 导入”文件夹中。
mac-whereimportedmail

导入 OS X 通讯录

Thunderbird 能读取您的 OS X 通讯录并显示在 Thunderbird 通讯录中。 在菜单栏中打开窗口菜单并单击通讯录。您的 OS X 通讯录就会出现在左侧面板中。
mac-OSXaddressbook

如果您想将 OS X 通讯录导入 Thunderbird 通讯录,只需将 Mac OS X 通讯录拖放到个人通讯录中。

注意: 您可以通过先按住command键再按下A来一次性选中所有通讯录。

从 Windows Mail 或 Windows Live Mail 迁移到 Thunderbird

Windows Mail 是 Windows Vista 系统的默认邮件客户端。 Windows Live Mail 是 Windows Live 软件包中的邮件客户端。 这两个客户端都使用 .eml 格式储存邮件。要将邮件从 Windows Mail 或 Windows Live Mail 导入 Thunderbird, 您必须先将邮件从 Windows 应用程序中导出,然后再导入 Thunderbird。将 Windows Mail 或 Windows Live Mail 联系人导入 Thunderbird 也是采用类似的方法。

要查看 Windows Mail 或 Windows Live Mail 的存放路径,打开工具 > 选项 > 高级 > 维护 > 存储文件夹

如果你看不到 工具,可以试一试 文件 > 选项 > 邮件... > 高级 > 维护...

导入 Windows Mail 邮件

您可以通过 下载 并安装第三方附加组件 ImportExport Tools 将 Windows Mail 或Windows Live Mail 的 .eml 文件导入 Thunderbird。

  1. 从 Windows Mail 中导出 .eml 格式的邮件。
  2. 在 Thunderbird 中,在“本地文件夹”下创建一个新文件夹还存放导入的邮件。选中该文件夹。
  3. 右击该文件夹并选择 工具 > 以mbox/eml格式导入/导出 > 从一个目录中导入所有的eml文件 > 还包括子目录
  4. 选择 .eml 文件所在的文件夹。Windows Live mail 中默认路径为C:\Users\<username>\AppData\Local\Microsoft\Windows Live Mail (或 \Windows Mail)。
  5. 单击选择文件夹后,您的数据将会被导入。
注意:为了能查看 "App Data" 文件夹,您需要先将文件夹选项改为“显示隐藏的文件、文件夹和驱动器”。参看 Microsoft 支持文章 显示隐藏文件

导入 Windows Mail 联系人

要将 Windows 联系人导入 Thunderbird, 您必须先将联系人vCard(.vcf 格式)导出,然后导入 Thunderbird。

  1. 在 Windows Live Mail 里打开联系人并选择所有要导出的联系人。
  2. 点击 导出 > 名片 (.VCF)
  3. 选择一个空目录来保存它。

在 Thunderbird 上按照 该指导 安装附加组件 MoreFunctionsForAddressBook

  1. 点击 地址簿
  2. 点击你想要添加联系人的地址簿。
  3. 点击 工具 > MoreFunctionsForAddressBook > 联系人操作 > 导入 vCard / VCF
  4. 找到刚才保存联系人的目录。
  5. 选择要导入的联系人。
  6. 点击 打开 来导入所有选中的联系人。

另外,如果上述方法不工作或无法满足你的要求,你可以

参看 Microsoft.com 的文章 从 Outlook 导出联系人 来学习如何从 Windows 导出联系人。

导出所需文件后,您就可以利用导入向导:

  1. 在 Thunderbird,打开菜单 工具 > 导入…
  2. 选择地址簿并点击 下一步
  3. 选择 文本文件(LDIF, .tab, .csv, .txt) 并点击 下一步
  4. 单击右下角的下拉列表,选择逗号分隔(或所有文件),然后找到您刚刚创建的 .csv 文件,选中后单击打开。
  5. 等待导入结束并点击 完成

在导入通讯录窗口中,使用上移下移按钮,将左侧的通讯录字段和要导入的记录数据配对,并取消选中您不想导入的字段。当完成以上设置后,单击确定。您的联系人就会被导入 Thunderbird 中。

注意,如果通讯录字段不能正常导入(例如在导入通讯录窗口中,所有要导入的记录数据都显示在第一行),这可能是因为导出的 .csv 文件不是用逗号而是用分号分隔,或者正相反。 这通常是由 Windows 区域设置中的分隔符设置与 Thunderbird 不一致引起的。例如,当您在英文版 Widnows 中导出 .csv 文件,而将 .csv 文件导入非英文版的 Thunderbird 中。在这种情况下,您可以在导出 .csv 文件前,在区域设置这种将分隔符列表设置成与 Thunderbird 一致,或者用文本编辑器编辑已导出的 .csv 文件,将所有的分号替换成逗号(反之亦然)。最后再尝试重新导入。

从 Outlook 和 Eudora 导入

常规的 Thunderbird 导入流程要求你在电脑上安装 Eudora 或 Outlook。如果没有安装,可以参考以下说明。

要使用 Thunderbird 的导入向导,你必须使用一个较老的 Thunderbird 版本,因为在 Thunderbird 38 及以上版本导入向对 Outlook 和 Eudora 已经禁用。请安装 31.8 版,导入数据,然后使用内置 升级机制 升级到 Thunderbird 最新版。

对 Eudora,如果你有数据问题或崩溃,可以尝试更 老版本的 Thunderbird 并使用根据清理数据。比如在 Mac OS 可以使用 Eudora 邮箱清理器 之类的数据清理工具。

替代 Thunderbird 的导入向导的方法是使用工具将数据转换成 mbox 格式(.mbx),然后再使用 导入导出工具 之类的附加组件在 Thunderbird 导入 mbox 文件。在 Eudora 下,可用的转换工具包括 Eudora Rescue

没有安装 Eudora

如果没有安装 Eudora,而且你还要使用 Thunderbird 的导入向导,你可以很容易地更改 Windows 的注册表,使之指向你的 Eudora 文件,然后再允许导入向导。

  • 创建一个名字是 eudora.reg 的 .reg 文件 ,它包含下列的内容,并将其中的 H:\\SCRATCH\\Eudoradata 用你的 Eudora 数据的路径替换。(注意双反斜线和空行)

=== Registry file, adjust file location as required ===
Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Qualcomm\Eudora\CommandLine]
"Current"="Anything H:\\SCRATCH\\Eudoradata Anything"
===

  • 在 Windows 命令行,运行 "regedit /s eudora.reg"。
  • 使用 Thunderbird 导入向导。

从 Evolution 迁移到 Thunderbird

以下内容介绍了如何从 Evolution 中导入消息和联系人。

导入 Evolution 消息

Thunderbird 和 Evolution 使用相同的文件格式(mbox)来储存邮件,因此,手动导入邮件并不难。

  1. 打开 Nautilus。
  2. 打开 Evolution 储存邮件的路径~/.local/share/evolution/mail/local
  3. 复制所有不带扩展名(如到InboxOutbox)文件到 Thunderbird 邮件的储存路径(如~/.thunderbird/uk41lql0.default/Mail/Local Folders,您需要将uk41lql0.default改为您电脑上 Thunderbird 安装路径)。
  4. 打开 Thunderbird 检查您的所有邮件是否都已正确导入。

导入 Evolution 联系人

  1. 打开您 Evolution 中的通讯录,右击并选择另存为 vcard... 导出 vCard 文件。
  2. 在Thunderbird里,打开工具 > 导入...菜单,选择通讯录,然后选择vCard 文件(.vcf),最后选择您的联系人文件即可。

从网页版的邮箱程序迁移到 Thunderbird

如果您目前使用互联网服务供应商(ISP)提供的网页版程序访问邮箱,您只需通过设置您的账号信息来迁移到 Thunderbird。参见手动帐号配置获取帮助。

一旦您在 Thunderbird 中完成了账号设置,您应该就能收取所有的消息了(包括收到的和已发送的消息)。然而,您的通讯录(联系人)、邮件过滤器和其他设置并不会自动导入到 Thunderbird 中。

一些网页版程序允许您以纯文本或逗号分隔符文本的形式导出联系人。 查阅供应商的帮助文档以获取更多信息。要将联系人导入 Thunderbird,选择工具 > 导入...,然后按照屏幕上出现的说明进行操作。

参见

这篇文章对您有帮助吗? 请稍候...

这些人帮助撰写了这篇文章:Mr.Ray, wxie。你也可以提供帮助,来看看该怎么做