附加组件阻挡列表

附加组件 如果违反 Mozilla 附加组件规范,会被放入“阻挡列表”(Blocklist)。

什么是阻挡列表?

禁用不安全的附加组件

Firefox 将在加载时阻挡附加组件并呈现给您以下消息:

Firefox 已经确定以下附加组件已知可能会带来安全性或稳定性问题。


Add-ons Blocklist Mac1

要阻止运行这些附加组件,请点击 重启 Firefox

在安装时阻挡不安全的附加组件

当您尝试安装一个在阻挡列表中的不安全附加组件时,Firefox 将阻止安装,并显示信息:

附加组件 名称 无法安装,因为其具有可引起安全性或稳定性的高风险问题。

阻止插件自动运行

Firefox 可以阻止插件自动运行(这可以避免许多问题)。Firefox 阻止一个插件时您将看到与以下类似的信息:

Click to play 1 new

然后,您可以选择运行该插件或更新它(如果有更新可用)。要了解更多信息,参看为什么我需要激活插件?

Mozilla 计划在2017年三月,当 Firefox 52版发布时,停止支持除 Flash 之外的所有 NPAPI 插件。请参看 此文此博客 了解详情。

实施步骤

如果安装的附加组件已被禁用

扩展或主题

  1. 点击菜单按钮 New Fx Menu ,选择 附加组件 打开附加组件管理器。

  2. 在附加组件管理器标签页中选择 Extensions 面板。
  3. 在"所有附加组件工具" Add-on Tools Icon 菜单,确保 自动更新附加组件 菜单已被选中。

插件

要检查您已安装的任何插件是否已过时,请访问 Mozilla 插件检查与更新页面

注:如果没有可用的更新,您可能需要联系被阻挡插件的开发者。

安装受阻

如果您想安装一个附加组件时被阻挡,请检查您试图安装的附加组件是否有更新的版本。

注:如果它没有一个更新的版本来安装,您可能需要联系被阻挡附加组件的开发者。

哪些不安全的附加组件在阻挡列表中?

请参阅 已被封锁附加组件的名单

这篇文章对您有帮助吗? 请稍候...

这些人帮助撰写了这篇文章:yfdyh000, wxie2016。你也可以提供帮助,来看看该怎么做