书签未保存

本文描述了当你不能添加新书签或者不能对书签进行更改时该怎么办。

注意:如果以前保存的书签不见了,参见 书签丢失了

不能添加新书签或者做其他更改

如果你不能添加新书签或者你对工具栏做出的更改在重新启动Firefox后没有保存,参见 无法保存工具栏设置和窗口大小

如果你不能添加新书签或者对书签进行更改,而且你安装了与书签相关的Firefox扩展(例如用来同步书签的扩展),请按照火狐扩展和主题的故障解决方法 的指示来确认是否是该扩展导致了这个问题。

当重新启动Firefox时,对书签的更改丢失了

如果你可以添加、删除、重新整理或者对你的书签做其他更改,但这些更改在你重新启动Firefox后就消失了,请尝试下列方案。

注意:在开始这些方案之前,我们建议你禁用书签相关的扩展,详见 此文

修复书签文件

如果你对书签的更改在重新启动Firefox后没有出现,问题可能是你的书签被写保护了。写保护的文件无法被更改,所以 Firefox 就禁止保存你的更改。

允许对书签文件的写操作:

  1. 要打开你的用户档案文件夹:

    点击 Firefox 窗口顶部的 Firefox 按钮,指向 帮助 菜单点击菜单栏中的 帮助 菜单点击 Firefox 窗口顶部的 帮助 菜单,选择 故障排除信息 菜单项以打开故障排除信息标签页。 点击菜单按钮 New Fx Menu ,点击帮助 Help-29 并选择 故障排除信息 菜单项以打开故障排除信息标签页。

  2. 应用程序概要 部分,点击 显示文件夹打开文件夹在 Finder 中显示打开目录 按钮,将打开一个窗口显示您的配置文件文件夹
  3. 注意:如果您无法打开或使用 Firefox,您也可尝试 在不打开 Firefox 的情况下找到您的用户配置文件 中的指导。

  4. 点击 Firefox 窗口顶部的 Firefox 按钮,然后选择 退出 菜单项。点击 Firefox 窗口顶部的 文件 菜单然后选择 退出 菜单项。点击菜单栏中的 Firefox 菜单,然后选择 退出 Firefox 菜单。点击 Firefox 窗口顶部的 文件 菜单然后选择 退出 菜单项

    点击菜单按钮 New Fx Menu ,然后点击退出退出 Close 29

  5. 右击文件 places.sqlite 并选择 属性 来打开属性窗口。
  6. 在属性窗口,选择常规标签页。在该窗口底部,确认 只读 没有被勾选。

    bookmarksnotsaved-readonly.png

允许对书签文件的写操作:

  1. 要打开你的用户档案文件夹:

    点击 Firefox 窗口顶部的 Firefox 按钮,指向 帮助 菜单点击菜单栏中的 帮助 菜单点击 Firefox 窗口顶部的 帮助 菜单,选择 故障排除信息 菜单项以打开故障排除信息标签页。 点击菜单按钮 New Fx Menu ,点击帮助 Help-29 并选择 故障排除信息 菜单项以打开故障排除信息标签页。

  2. 应用程序概要 部分,点击 显示文件夹打开文件夹在 Finder 中显示打开目录 按钮,将打开一个窗口显示您的配置文件文件夹
  3. 注意:如果您无法打开或使用 Firefox,您也可尝试 在不打开 Firefox 的情况下找到您的用户配置文件 中的指导。

  4. 点击 Firefox 窗口顶部的 Firefox 按钮,然后选择 退出 菜单项。点击 Firefox 窗口顶部的 文件 菜单然后选择 退出 菜单项。点击菜单栏中的 Firefox 菜单,然后选择 退出 Firefox 菜单。点击 Firefox 窗口顶部的 文件 菜单然后选择 退出 菜单项

    点击菜单按钮 New Fx Menu ,然后点击退出退出 Close 29

  5. 选择文件 places.sqlite
  6. 在菜单栏选择 文件 菜单并选择 获取信息。places.sqlite 文件的信息窗口会打开。
  7. 在该信息窗口,取消勾选 Locked

创建新书签文件

书签和浏览历史贮存在Firefox配置文件夹的 places.sqlite 文件中。如果这个文件有问题,你对书签的更改在Firefox重新启动后可能消失。通过删除(或重命名)现有的书签文件可以强制让 Firefox 创建另一个 places.sqlite 文件。

你也许需要把这些指导打印出来或复制到其他地方,因为你必须关闭 Firefox 才能删除或重命名书签文件。

警告:一旦删除了 places.sqlite 文件,所有浏览历史都不在了。Firefox 只有这一份历史记录的备份。
  1. 要打开你的用户档案文件夹:

    点击 Firefox 窗口顶部的 Firefox 按钮,指向 帮助 菜单点击菜单栏中的 帮助 菜单点击 Firefox 窗口顶部的 帮助 菜单,选择 故障排除信息 菜单项以打开故障排除信息标签页。 点击菜单按钮 New Fx Menu ,点击帮助 Help-29 并选择 故障排除信息 菜单项以打开故障排除信息标签页。

  2. 应用程序概要 部分,点击 显示文件夹打开文件夹在 Finder 中显示打开目录 按钮,将打开一个窗口显示您的配置文件文件夹
  3. 注意:如果您无法打开或使用 Firefox,您也可尝试 在不打开 Firefox 的情况下找到您的用户配置文件 中的指导。

  4. 点击 Firefox 窗口顶部的 Firefox 按钮,然后选择 退出 菜单项。点击 Firefox 窗口顶部的 文件 菜单然后选择 退出 菜单项。点击菜单栏中的 Firefox 菜单,然后选择 退出 Firefox 菜单。点击 Firefox 窗口顶部的 文件 菜单然后选择 退出 菜单项

    点击菜单按钮 New Fx Menu ,然后点击退出退出 Close 29

  5. 在你的配置文件夹中,删除文件 places.sqliteplaces.sqlite-journal(如果有),或者重命名,比如命名为 places.sqliteOLD
  • (可选项)把文件 localstore.rdf 也删除。这会重置 工具栏定制
  • (可选项)把文件 xulstore.json 也删除。这会重置 工具栏定制

Firefox将会创建一个新的places.sqlite文件,并自动导入最近的书签备份文件。书签会恢复,但浏览历史没有了。请注意浏览历史被用于 地址栏自动完成 功能。




信息基于 书签未保存 (mozillaZine KB)

这篇文章对您有帮助吗? 请稍候...

这些人帮助撰写了这篇文章:LittleBig, wxie2016。你也可以提供帮助,来看看该怎么做