Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Ця тема перенесена в архів. Якщо вам потрібна допомога, запитайте.

Images of personas and themes not showing on getpersonas etc.

  • 5 відповідей
  • 21 має цю проблему
  • 59 переглядів
  • Остання відповідь від cor-el

more options

When I try to view the personas.com site, the images of the personas do not show up on the web page. (This is not the same problem as not seeing my own persona change to the new one on mouse rollover - that form of previewing does work.) The same thing happens with themes on the themes page. Both sites are whitelisted for "install extensions or themes", and all adblock and ghostery etc turned off for these sites. I have also checked my hosts file - there is no mozilla or getpersonas entry. Sessional cookies allowed.

When I try to view the personas.com site, the images of the personas do not show up on the web page. (This is not the same problem as not seeing my own persona change to the new one on mouse rollover - that form of previewing does work.) The same thing happens with themes on the themes page. Both sites are whitelisted for "install extensions or themes", and all adblock and ghostery etc turned off for these sites. I have also checked my hosts file - there is no mozilla or getpersonas entry. Sessional cookies allowed.

Обране рішення

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.


Читати цю відповідь у контексті 👍 0

Усі відповіді (5)

more options

Вибране рішення

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.


more options

Thanks but everything was fine with those settings. Problem unresolved. Will check the link you sent.

[Later:] The link you listed helped me fix the problem, thanks! For the aid of others with this issue, what worked in my case was following this advice in the linked document: Use about:config to make sure that the preference permissions.default.image is set to "1", the default value (right-click and select "Reset" if any other value is shown).

Somehow my value for this had been set to 3.

Змінено DevonK

more options

You're welcome.

A setting of 3 for the pref permissions.default.image means that you only allow images from the originating domain and block images from other (third-party) domains.

more options

I must have made that change at some point in the past to avoid intrusive ads..... It did not occur to me that Mozilla would be using a 3rd party domain for providing images, it's typically a commercial practice.

FF crew should consider adding a caveat to the options -> content -> "load images automatically" indicating the setting can be overridden by settings in about:config.

Змінено DevonK

more options

That is quit common nowadays to allow for server balancing and make the main HTML available as quickly as possible.
The old Firefox 1.0 and 1.5 versions used to have that setting in the user interface, but that has been removed a long time ago to discourage using that setting because of that.