Шукати в статтях підтримки

Остерігайтеся нападів зловмисників. Mozilla ніколи не просить вас зателефонувати, надіслати номер телефону у повідомленні або поділитися з кимось особистими даними. Будь ласка, повідомте про підозрілі дії за допомогою меню “Повідомити про зловживання”

Learn More

Firefox keeps zooming in on web page

  • 3 відповіді
  • 0 мають цю проблему
  • 34 перегляди
  • Остання відповідь від cor-el

more options

I'm not sure how this happened, but one of my firefox web pages keeps zooming in only on one website and the zoom refuses to reset no matter what I do.

For reference this is wikipedia. Every time I load a wikipedia page it loads zoomed in to 210%, which I will then have to reset to 100% in order to read the page properly. If I for some reason click on a link on the wikipedia page that goes to another wikipedia page, the zoom will reset again to 210%, which I will then need to reset once again. This happens also whenever I switch from the wikipedia tab to another tab and then switch back again. I do have an addon that changes wikipedia slightly (the Wikipedia Vector Skin addon) but disabling this addon doesn't fix the issue.

I went into about:config several times already and changed different settings to try and make it stop, but nothing so far has worked. I've tried resetting layout.css.devPixelsPerPx to 1.0 and back again to -1.0 and it makes no difference. I also tried changing browser.zoom.full to false and it keeps happening. Changing browser.zoom.siteSpecific to false does fix the issue, however it also resets the zoom I have on other websites that I want to keep, so it's not an ideal fix. I also cleared all my cache and cookies and it changed nothing.

Does anyone have any idea on why this keeps happening only with wikipedia, and how I can get this to stop happening? I assume there must be some internal setting that would need to be reset in order to fix this, but I don't know how to do it or where I would even go.

I'm not sure how this happened, but one of my firefox web pages keeps zooming in only on one website and the zoom refuses to reset no matter what I do. For reference this is wikipedia. Every time I load a wikipedia page it loads zoomed in to 210%, which I will then have to reset to 100% in order to read the page properly. If I for some reason click on a link on the wikipedia page that goes to another wikipedia page, the zoom will reset again to 210%, which I will then need to reset once again. This happens also whenever I switch from the wikipedia tab to another tab and then switch back again. I do have an addon that changes wikipedia slightly (the Wikipedia Vector Skin addon) but disabling this addon doesn't fix the issue. I went into about:config several times already and changed different settings to try and make it stop, but nothing so far has worked. I've tried resetting layout.css.devPixelsPerPx to 1.0 and back again to -1.0 and it makes no difference. I also tried changing browser.zoom.full to false and it keeps happening. Changing browser.zoom.siteSpecific to false does fix the issue, however it also resets the zoom I have on other websites that I want to keep, so it's not an ideal fix. I also cleared all my cache and cookies and it changed nothing. Does anyone have any idea on why this keeps happening only with wikipedia, and how I can get this to stop happening? I assume there must be some internal setting that would need to be reset in order to fix this, but I don't know how to do it or where I would even go.

Обране рішення

Open the History sidebar (Ctrl+H), search for "wikipedia", right-click an entry > Forget About This Site.

Alternatively, if you don't want to lose history for that site but don't mind losing permissions for all sites, press Ctrl+Shift+Del, tick only "Site settings" with everything else unticked and then click "Clear now".

Читати цю відповідь у контексті 👍 1

Усі відповіді (3)

more options

Вибране рішення

Open the History sidebar (Ctrl+H), search for "wikipedia", right-click an entry > Forget About This Site.

Alternatively, if you don't want to lose history for that site but don't mind losing permissions for all sites, press Ctrl+Shift+Del, tick only "Site settings" with everything else unticked and then click "Clear now".

Корисно?

more options

Oh my god, you're a savior. The first fix didn't work but the second did! Finally I don't have to be plagued by this nonsense anymore, thank you Zeroknight!

Корисно?

more options

See also browser.zoom.siteSpecific in about:config and possibly set it to false.

Корисно?

Запитати

Щоб відповідати на повідомлення, ви повинні ввійти у свій обліковий запис. Поставте нове питання, якщо ви ще не маєте облікового запису.