Iskanje po podpori

Izogibajte se prevarantski tehnični podpori. Nikoli vam ne bomo naročili, da pokličete telefonsko številko ali nam pošljete osebne podatke. Sumljivo dejavnost prijavite z gumbom »Prijavi zlorabo«.

Learn More

Autoplay videos, some more...

  • 1 odgovor
  • 1 ima to težavo
  • 4 ogledi
  • Zadnji odgovor od cor-el

more options

On https://sanfrancisco.cbslocal.com/category/weather/, we have repeatedly set Firefox to block audio and video autoplay (in Privacy/ security/ permissions. It works that one time, then reverts and does autoplay. It's very annoying. Can this be fixed?

On https://sanfrancisco.cbslocal.com/category/weather/, we have repeatedly set Firefox to block audio and video autoplay (in Privacy/ security/ permissions. It works that one time, then reverts and does autoplay. It's very annoying. Can this be fixed?

Vsi odgovori (1)

more options

I can block auto-play via about:config, but hiding the floating media player requires blocking content, either via userContent.css or via an extension.

  • media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


The floating player on this page is about the #cbs_ott_widget-3 container and hiding this element prevents the player from showing when I scroll down. You can hide more by hiding #floating-column

You can add CSS code to the userContent.css file.


@-moz-document domain(sanfrancisco.cbslocal.com){
  #floating-column { display:none!important; }
}

More info about userContent.css and userChrome.css in case you are not familiar:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userContent.css and userChrome.css in the chrome folder.