Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

My spellcheck languages keep disappearing

  • 11 odpovedí
  • 0 má tento problém
  • 41 zobrazení
  • Posledná odpoveď od von Boomslang

more options

Every time I restart firefox, my spellchecker languages disappear, leaving me only with one - the addons are still installed, they're just not available to be selected. Even now I can't spellcheck in english. Please help.

Every time I restart firefox, my spellchecker languages disappear, leaving me only with one - the addons are still installed, they're just not available to be selected. Even now I can't spellcheck in english. Please help.

Všetky odpovede (11)

more options

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

You can try to reset extensions.databaseSchema in about:config (i.e. click the trashcan icon on this line).

Pomohla vám táto odpoveď?

more options

I have tried both approaches. No dice. The languages appear when I add them, disappear when I reload.

Pomohla vám táto odpoveď?

more options

Just to be sure, you are installing Dictionaries and not language packs. The language packs are for changing the language of the user interface like the menus.

Pomohla vám táto odpoveď?

more options

Yes, I have installed dictionaries. Installing them makes it appear, but it disappears when I restart.

Pomohla vám táto odpoveď?

more options

Do you still see them installed in the extension manager (about:addons -> Dictionaries) and in "Help -> More Troubleshooting Information" (about:support)?

Pomohla vám táto odpoveď?

more options

about:addons - the dictionaries are still installed, yes

about:support - they are also visible there, yes, and set to be 'on'

Pomohla vám táto odpoveď?

more options

Your System Details show that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and is normally not present.

You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

You also appear the be using userChrome.css and userContent.css.

Pomohla vám táto odpoveď?

more options

Well, crap. Thought that might be it - deleted the file, restarted firefox, removed and readded the discionary, checked it's working, restarted and it's gone.

.... hm. It doesn't work in ANY language now, actually. Maybe that's the problem?

Pomohla vám táto odpoveď?

more options

What was in the user.js file? Anything related to spell checking and dictionaries?

Do you see "Check Spelling" and Languages if you right-click in a text area like on this forum?

You can enable or disable spell checking globally:

You can check in about:config whether layout.spellcheckDefault is set to 1 (multi-line) or 2 (single-line).

Pomohla vám táto odpoveď?

more options

I'll be honest, I didn't check much in user.js before removing it to try

I do get the red squigglies for incorrect check spelling, but it happens regardless of what I type in, so it seems to be working.

Pomohla vám táto odpoveď?

more options

Man, fascinating further complications. I decided to , screw it, I'll just turn spell check off!

.... it.... won't stay off. Keeps turning itself back on. Not even when I reboot firefox. On its own.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete odpovedať na príspevky, musíte sa prihlásiť do svojho účtu. Ak ešte nemáte účet, položte novú otázku.