Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Weird symbols

  • 5 odpovedí
  • 1 má tento problém
  • 54 zobrazení
  • Posledná odpoveď od the.pelican.web

more options

I am using Windows 11 and Firefox 116.0.3. Some characters like ‘ ’ “ ” — become weird symbols in Firefox when I copy and paste text containing them to html source text file. This started happening earlier this month, never happened before. Why is this happening now?

I am using Windows 11 and Firefox 116.0.3. Some characters like ‘ ’ “ ” — become weird symbols in Firefox when I copy and paste text containing them to html source text file. This started happening earlier this month, never happened before. Why is this happening now?

Vybrané riešenie

Changed to UTF-8. Problem solved. Thank you for helping me! Visit my website:

http://www.pelicanweb.org/

Luis Gutierrez

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (5)

more options

That are Unicode quotes (2018:2019:201c:201d:2014) and should show fine if you paste them in a document that supports Unicode (utf-8).

What do you get if you paste them ? Do you paste then in Firefox or in a external editor ?

Can you attach a screenshot?

Upravil(a) cor-el dňa

more options

My HTML is rudimentary. I have a text file with a template that I use for all my web pages. When I insert text that contains letters with accents or characters like ‘ ’ “ ” — and save the filetype from.txt to .html, each of these words-symbols shows up as gibberish. For example, Gutiérrez shows up as Gutiérrez. This started happening earlier this month (8/8/24 to be exact) and had never happened before. Can you help me? This is my template: http://pelicanweb.org/web.page.template.txt

more options

You get the eight-bit character representation instead of the Unicode character because you have "charset=ISO-8859-1", "Tools -> Page Info -> General" (Ctrl+I) shows: windows-1252.

<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">

These days you should use Unicode (utf-8) like you can see on this forum page.

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

See also:

Upravil(a) cor-el dňa

more options

So, in my template, do I have to change this line

<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">

to this line

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

and do I have to do this for all my pages?

more options

Vybrané riešenie

Changed to UTF-8. Problem solved. Thank you for helping me! Visit my website:

http://www.pelicanweb.org/

Luis Gutierrez