Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

As of update 96.0, now have a white text on black background.

more options

I didn't ask for this change, and I don't want it. Black on white is hard on my eyes to read.

I've already checked around the forums and nothing that other posters have suggested works to change it back. Yes, I use a custom theme and I'm not going to change it to "white". I didn't make any changes , firefox did.

Všetky odpovede (8)

more options

Hi lightsenshi23, since you've already searched around, what I say is going to involve some duplication. Sorry about that, but it's very busy here recently(!).

Firefox 96 now harmonizes more parts of Firefox with your toolbar theme. When the text color on your background tabs is light/white, it triggers Firefox to use a dark background on menus, the sidebar, the Library window, and various built-in pages. It also signals sites that you have a dark theme preference.

What to do about this

(1) For people not attached to their toolbar theme

The fastest workaround for now is to change your theme to one that uses dark text. By dark text I mean, for example, the built-in Light theme, or an add-on theme with black or dark text on the tabs. That doesn't need to be blinding, it can have a pastel color. As examples:

I have attached a screenshot illustrating the difference between a theme with light text on the tabs and dark text on the tabs.

(2) For people who can't part with their toolbar theme

This is only a partial workaround for the built-in pages, and for websites that have light/dark responsive themes. (This is the middle panel of the attached screenshot.)

Currently, the only way to decouple your page (content) theme preference from your toolbar theme is through the back door:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.

What about other aspects of the UI?

For the sidebar, menus, and toolbar drop-down panels, there is an unofficial, community-supported option, which is to override the built-in styles using your own style rules in a userChrome.css file. I think people are still pondering how to do that efficiently, and perhaps you aren't that into hacking your browser anyway.

Pomohla vám táto odpoveď?

more options

Hey lightsenshi23! Try going into your settings, go down to Language and Appearance. Once you are there, click colors, and then change it back using Text and Background. Let me know in this thread if that does not work. NuggFrog

Pomohla vám táto odpoveď?

more options

At jscher2000: Yup, already tried all that. Not my solution.

At NuggFrog: See below.

Settings

Pomohla vám táto odpoveď?

more options

lightsenshi23 said

At jscher2000: Yup, already tried all that. Not my solution.

Changing the value of layout.css.prefers-color-scheme.content-override to 1 should have changed your Settings page to black-on-white. Are you saying that didn't work or you don't want to do it?

Pomohla vám táto odpoveď?

more options

jscher2000 said

lightsenshi23 said

At jscher2000: Yup, already tried all that. Not my solution.

Changing the value of layout.css.prefers-color-scheme.content-override to 1 should have changed your Settings page to black-on-white. Are you saying that didn't work or you don't want to do it?

The only thing it changed was the first browser screen. Didn't do anything with anything else: like settings, additional tabs/pages, etc.

Pomohla vám táto odpoveď?

more options

That change has worked in my testing with a few different themes add-on themes. I wonder whether some other setting might be conflicting. Stay tuned in case we learn of something additional to check.

Pomohla vám táto odpoveď?

more options

I just did a clean install of firefox and everything was fine until I added my custom theme. Then it went to hell.

So...I'm stuck with this ugly black background and white text. I'm seriously tired of people thinking that they "know what I want"....when they don't.

Pomohla vám táto odpoveď?

more options

Does the preference change work any better in the rebuilt profile?

And I understand there is a disconnect here.

Fictitious conversation:

Mozilla to Users: "Since you prefer light colored text on your toolbar theme, you probably want the rest of the browser to also use a dark theme."

Many Users to Mozilla: "No, just because I hung a painting of Starry Night does NOT mean I want the walls painted to match."

Me to No one in Particular: "We need a simple setting for this so everyone can be happy. But I know the odds of getting that quickly are low as all UI decisions seem to take a long time.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.