Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Firefox in dark mode prints black bars instead of readable text.

more options

My visual impairment means I have to run FireFox (and my computer) in dark mode. When I try to print, while it does not waste ink by printing the entire page black, where the text is the printed page only has black bars. An image of a print preview screen is attached. If there are settings to fix this there, I cannot see them because this does NOT use the dark mode and I can't see it.

Currently to print something, I take a screen shot and use another program to reverse the colors. I would like to not have to spend 30-40 min editing an image every time I want to print.

Priložené obrázky

Všetky odpovede (2)

more options

hello mgalip,

lets do a quick test on this issue with your FF.

lets see if a screen print before printing will prove better than first printing the webpage.

so open up your webpage in your browser again.

then at the right end of the url field, there should be 3 dots to click on

Then select screen print. Then select the area you want to capture. Then save your selection to a file.

Then open the file and see how the print feature of that file works out for you.

more options

mgailp said

My visual impairment means I have to run FireFox (and my computer) in dark mode.

Are you using a so-called "High Contrast" theme on your Windows? Firefox behaves specially with High Contrast themes, but I wasn't aware of printing problems.

If you wouldn't mind testing something for me:

Is this a fairly recent issue, possible related to the updated print interface in Firefox 85-86? If so, could you test whether the issue is resolved if you revert Firefox to the classic print experience with separate Preview, Page Setup, and Print. Here's how to test that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste tab_mo and pause while the list is filtered

(3) Double-click the print.tab_modal.enabled preference to switch between the new experience (true) and the classic experience (false)

(4) If there is another preference named app.normandy.startupRolloutPrefs.print.tab_modal.enabled you can double-click that one to switch it to false as well. If you do not have that one, no need to create it.

Since you are setting to false, it will look roughly like this:

Then to call up print preview, you can either:

  • menu button > Print...
  • (menu bar) File > Print Preview

Does it have the same strange presentation?