Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I COMPLETELY turn off search suggestions in address bar?

  • 8 odpovedí
  • 4 majú tento problém
  • 164 zobrazení
  • Posledná odpoveď od jscher2000

more options

I want to turn off search suggestions in the URL bar. Yes, they are turned off in Options. Please see the attached screenshot. I don't want anything to happen when I start typing an address in the bar. I've done this before on an older install, but I can't seem to figure out where in the about:config it is. Thanks.

Priložené obrázky

Vybrané riešenie

This issue has been gaining some popularity.

Please see: https://support.mozilla.org/en-US/questions/1277006#answer-1280820

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (8)

more options

Vybrané riešenie

This issue has been gaining some popularity.

Please see: https://support.mozilla.org/en-US/questions/1277006#answer-1280820

more options

In about:config see if toggling this pref to false helps you.

services.sync.prefs.sync.browser.urlbar.suggest.searches

more options

crankygoat said

This issue has been gaining some popularity. Please see: https://support.mozilla.org/en-US/questions/1277006#answer-1280820

Unfortunately it didn't work for me. I restarted FF twice, didn't go, then restarted the computer just to be sure. Still nothing.

Here's some shots of my config. I'm pretty sure I've got everything set to false that needs to be.

I do remember having to create a txt file like that way back on version 56-ish, and I've just been updating since. I finally replaced the machine the other day, and although I backed up everything else, I totally forgot my profile folder. Now that HDD has already been wiped.

more options

Success!!!

I did a bit more searching. I found some much older add-ons (version 45ish) and some configuration for them. One of them broke it down into creating the chrome folder and the text file. What I didn't check when I created it was that it didn't auto-rename with a ".txt". It sure did (thanks Windows......). I simply edited the .txt out and it worked perfectly.

Thanks!

more options

Oh, great! Glad that worked. I was hoping one line in a text file couldn't go wrong. :D

more options

I'm having the same issue but I'm not sure what you all are talking about "config" in the above messages. Is there a simpler solution?? I've attached my airbnb search... I only want my bookmarked sites to come up (which is the middle option,) but now it's making suggestions for popular sites. Please help me stop that. I name things very specific so I know it's only going to that address... Please help.

more options

Hi sasawatt22, it seems your second screenshot did not load, so I will comment on the first one only.

The second and third rows on the drop-down in your screenshot have blue stars indicating they are both bookmarked. Is there something broken there -- the third one is not really bookmarked? You can search in your bookmarks using either the Bookmarks Sidebar (Ctrl+b; Mac: Command+b) or Library window (Ctrl+Shift+b; Mac: Command+Shift+b).

The top row shows what will happen if you press Enter or click the Go button right now. The address that shows up inside the URL bar as you type is controlled by the following setting -- if you never want those in-URL-bar suggestions, this is how to turn them off. After this change, what you will see in the top bar instead is that your text will be sent to search if you press Enter or click the Go button.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.autoFill preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

more options

On the original topic of this thread:

For those who do not want to dive under the hood, setting the drop-down height to zero rows usually will suppress it entirely:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.maxRichResults preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change.

More info on about:config: Configuration Editor for Firefox.