Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New Firefox Quantum extremely slow &

  • 6 odpovedí
  • 22 má tento problém
  • 114 zobrazení
  • Posledná odpoveď od cor-el

more options

I upgraded to the new Firefox Quantum a few days ago and it is extremely slow. The previous version was brilliant and I never had any problems with slowness. It is slow opening a new Tab, slow going back to the previous page, slow just opening a page at all & sometimes doesn't load the page properly so I have to reload only to have the same problem with it not loading properly: I am talking like sometimes more than 10 minutes. Occasionally, it will work fine but most of the time, it is just painful! And with Quantum obviously trying to do "whatever it is" to load a page, it is slowing my system down to a crawl. I have had to use Google Chrome in the interim and it is fast and not having any problems. it is not our Internet speed as everything else is fine. I am using Windows 7 Professional. How do I roll back to the old Firefox in the interim until this issue can be sorted out. Thank you for your time.

Všetky odpovede (6)

more options

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

Reinstall with Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/

Please let us know if this solved your issue or if need further assistance.

more options

Thanks for your prompt reply - I really appreciate it :-) I'm in the process of doing everything that you suggested and will post here once I am done to let you know how it went.

more options

I have followed everything you suggested to the letter and so far, Mozilla seems much faster & not having all the problems that it had before. I will use Mozilla for a day or so and see how it goes and report back here. Can't thank you enough for your help :-)

more options

After assessing the browser after reinstalling, it is mostly OK, however it is extremely slow on some websites such as Candy Crush and EBay to the point where it slows my system to being unresponsive. It can take more than 15 minutes for websites to respond and even then, they don't load properly and pictures are missing. I can use those websites with ease on Google Chrome & they are fast and no lagging. I have noticed that Firefox is using an awful lot of CPU - more than 7 times as much as Google Chrome. Do you have any ideas as to why the CPU usage is so high or what I can do about the slowness? Thanks for your time :-)

more options

Well, I have had to completely give up on the new Mozilla Quantum unfortunately after trying in vain to keep trying to use it. It is just slowing my system down to a crawl & the browser often becomes unresponsive - which in turn makes my computer become unresponsive & the CPU usage is extremely high - 13 times higher than Google Chrome & my computer runs very hot. Sometimes it's reasonably OK and other times, it's just not usable necessitating me to use a different browser & it's not practical to keep swapping between the two. No hard feelings but thanks for your time in trying to fix the problem. I loved the old Mozilla & I found it a fantastic browser & so easy to use & I appreciated being able to have an alternative to Internet Explorer over the last 10 years. Best wishes everyone :-)

more options

Try to disable accessibility services in Firefox.


You can try to modify multi-process settings to see if this has effect.

  • set dom.ipc.processCount to 1 if it is currently set to a higher value (4)
  • disable multi-process windows in Firefox

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.