20 GB RAM usage, pagefile takes up all space on C: - 300 tabs in Tree Tabs

First, this post is basically Congratulations for Firefox upon working almost flowlessly under this extreme heavy load without crashing. Saving/loading sessions works wel… (читать ещё)

First, this post is basically Congratulations for Firefox upon working almost flowlessly under this extreme heavy load without crashing. Saving/loading sessions works well. (which is unexpected but makes me _very_ happy :-)) Firefox exits properly without any exceptions, no matter how long it runs, or how many times the PC is sent to STR mode meanwhile.

Second, everything is fine, except RAM usage. No matter how many RAM is installed, Firefox takes up all of it after a few days of normal operation. I have recently upgraded my PC from 16 to 24 GB of RAM only for this sole reason to see if anything changes, but it did not produce any noticable change, except that it takes 5-7 days for Firefox to fill up all the RAM instead of the 3-4 days before. Disk space on C: drive was nullified by Firefox as the paging file went up to 50 GB.

I want to hunt down this thing. I have approx. 300 tabs, 2 addons, and Hardware Acceleration is disabled since otherwise Fox hangs several times a day (have to be killed from outside). Pics are attached. https://addons.mozilla.org/hu/firefox/addon/tree-tabs/ https://gitlab.com/kroppy/TreeTabs

I'd like to get suggestions where to start.

  1. Disabling or replacing the adblocker ?
  2. Inspecting memory usage on Process Manager (about:processes) and Task Manager (about:performance) pages ?
  3. Installing some external tools like Firemin ?

Please don't suggest neither safe mode nor disabling all addons, since that makes it impossible to reproduce this amount of load, which is the primary reason behind the symptom.

I PrtScr'ed Process Manager and Task Manager, see that RAM sizes per page are normal in Task Manager, but not in Process Manager (10 times more).

CPU usage is totally normal for this load, even when memory is in the heaven. See the TaskMan pic. (I suppose that's because of ad blocking)

Thanks for any ideas,

Peter B. (I'm PC enthusiast)

-- Windows 7 Ultimate SP1 64 bit Firefox 106.0.5 (latest autoupdated) no firewall nor any antivirus - since 20 years with no infection ... AMD FX-6350 Six-core ASUS M5A99FX PRO R2.0 24 GB DDR3 1600 MHz Sapphire Radeon HD 5750 1GB (AMD Catalyst 15.11.1, Nov 18, 2015)

Задан Peter B. 3 недели назад

Последний ответ от Peter B. 3 часа назад

Firefox doesn't follow macOS forward/back localization convention

I have a Macbook with a Finnish keyboard layout. Safari, Chrome and Edge, by default, support command+ö and command+ä for going back and forward in history. This is becau… (читать ещё)

I have a Macbook with a Finnish keyboard layout.

Safari, Chrome and Edge, by default, support command+ö and command+ä for going back and forward in history. This is because Finnish/Swedish (they're the same) keyboard layout doesn't have [ or ] available.

While command + back arrow and command + forward arrow still work, those are useless as they get disabled when a text field is focused.

I tried to work around this with an extension (shortkeys), but even they don't support using umlauts for shortcuts.

I'm trying to adopt Firefox but I can't unless this gets fixed.

Thank you.

Задан agile.home0202 3 часа назад

Firefox 104-107 has square box symptom and numerous dots on printouts instead of letters

Greetings. I waited a long time before updating from FF 88 to FF 104, concerned that the header and footer issues I previously experienced (and resolved) with FF's print … (читать ещё)

Greetings. I waited a long time before updating from FF 88 to FF 104, concerned that the header and footer issues I previously experienced (and resolved) with FF's print preview interface would recur after updating to a newer FF version. Unfortunately after updating to FF 104 the very same issues recurred. The only solution was to disable FF's print preview interface once again and use the Mac print window instead for all printing tasks. Doing that solved the issue with headers and footers getting cut off pdfs and printed pages, but it did not solve two new issues that began after updating to FF 104, which have persisted through FF 107.

When printing emails and/or content from webpages, FF has been inserting what I believe is called square box symptom (multiple square boxes in a row with question marks in some of them) instead of the actual text that is on the email or webpage. FF is also printing a long series of dots across the page in certain areas of my emails, which I assume are the very bottom of the letters that are supposed to be there. These issues have never occurred in all my years as a Firefox user until updating to 104.

Does anyone else have these problems when printing emails and/or webpages? This behavior does not occur with every email or webpage that I print or save as a pdf, but it is prevalent enough that I am having to rely on Safari to create pdfs and/or printouts.

I've done everything I can think of to resolve these two new issues but the behaviors persist. I am attaching 2 screenshots of a recent order confirmation email that I saved as a pdf to demonstrate what the issues look like. The title of the email is cut off. All you can see is a bunch of tiny dots. The amount of the refund is nothing but dots. The title of each item in the order is a bunch of dots, as is the price on the far right. There is a row of square box symptom between some of the items in the order, followed by more missing titles and prices represented by dots, and more dots for the amount of the discount and subtotal.

I was going to submit a bug about this but wanted to inquire here first in case there is a solution that I have not tried. Clearing cookies, cache, and running Disk Utility has not resolved this. Any assistance you can give me is greatly appreciated. Thank you.

Задан youngjane 2 дня назад

Последний ответ от youngjane 6 часов назад

Newsletter unsubscription doesn't seem to work

Hello, In my newsletter subscription options, I did NOT checked the "Firefox Account Tips" option but I keep receiving mail saying this : "You're receiving this email bec… (читать ещё)

Hello,

In my newsletter subscription options, I did NOT checked the "Firefox Account Tips" option but I keep receiving mail saying this : "You're receiving this email because [edited] @gmail.com has a Firefox account and is subscribed to Firefox Account Tips."

Could you please fix this issue so that I don't receive these mails anymore ?

Thank you in advance,

Mikael

Задан mikael.debie 1 день назад

Последний ответ от mikael.debie 6 часов назад

How to delete all container entries from Addon Multi Account Container ?

Hi, with a lot of effort I edited three times all my container entries at about:preferences#containers, but the changes were not overtaken correctly. Now I want to start… (читать ещё)

Hi,

with a lot of effort I edited three times all my container entries at about:preferences#containers, but the changes were not overtaken correctly.

Now I want to start from the scratch without having to create a new Firefox profile. How can I delete the container entries permanently ? I already tried uninstalling and reinstalling the extension, but the entries were still there afterwards.

Thanks

Задан ranala 3 дня назад

Последний ответ от ranala 8 часов назад

  • Решено

browser video

Hi there I am having some problems with the browser I have a web base yoga app and there is a lot of you tube videos that just does not play. I disabled my extensions but… (читать ещё)

Hi there I am having some problems with the browser I have a web base yoga app and there is a lot of you tube videos that just does not play. I disabled my extensions but still nothing. I then installed chrome and the videos worked can you guys please give me an fix.

Задан jannes3de 11 часов назад

Дан ответ James 10 часов назад

Video DownloadHelper does not work anymore

my Video DownloadHelper does not work anymore, i constantly get the error message 'C:\Users\ADMIIN\AppData \Local\Temp\vdh-13324PiYekgRxnch0.tmp'. The file might be corr… (читать ещё)

my Video DownloadHelper does not work anymore, i constantly get the error message

'C:\Users\ADMIIN\AppData \Local\Temp\vdh-13324PiYekgRxnch0.tmp'. The file might be corrupted. (Details)

Failed aggregating "Klima-Kleber: Für diese Rede bekam Beatrix von Storch einen Ordnungsruf! AfD-Fraktion im Bundestag - YouTube"

ffmpeg version n4.1.5-vdhcoapp Copyright (c) 2000-2020 the FFmpeg developers

 built with gcc 9.3-win32 (GCC) 20200320
 configuration: --cross-prefix=x86_64-w64-mingw32- --sysroot=/usr/x86_64-w64-mingw32/ --extra-ldflags=-static-libgcc --target-os=mingw32 --arch=x86_64 --prefix=/home/mig/git/vdhcoapp/converter/src-build/win/64/converter-build --extra-version=vdhcoapp --extra-cflags=-I/home/mig/git/vdhcoapp/converter/src-build/win/64/deps/include --extra-ldflags='-static-libgcc -L/home/mig/git/vdhcoapp/converter/src-build/win/64/deps/lib -L/home/mig/git/vdhcoapp/converter/src-build/win/64/zlib' --extra-libs=-lpthread --pkg-config=/usr/bin/x86_64-w64-mingw32-pkg-config --enable-shared --enable-gpl --enable-pthreads --disable-w32threads --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx265 --enable-libxvid --enable-libx264 --enable-libaom --enable-avresample --disable-doc
 libavutil      56. 22.100 / 56. 22.100
 libavcodec     58. 35.100 / 58. 35.100
 libavformat    58. 20.100 / 58. 20.100
 libavdevice    58.  5.100 / 58.  5.100
 libavfilter     7. 40.101 /  7. 40.101
 libavresample   4.  0.  0 /  4.  0.  0
 libswscale      5.  3.100 /  5.  3.100
 libswresample   3.  3.100 /  3.  3.100
 libpostproc    55.  3.100 / 55.  3.100

C:\Users\ADMIN\AppData\Local\Temp\vdh-13324bR2BsjR5pf1a.tmp: Invalid data found when processing input

Задан stephanpoetsch2 10 часов назад

Последний ответ от jonzn4SUSE 9 часов назад

PR_CONNECT_RESET_ERROR

I am unable to open my outlook mail - however I am able to open other websites - how do I fix this I was able to access my outlook email yesterday so this only happened i… (читать ещё)

I am unable to open my outlook mail - however I am able to open other websites - how do I fix this

I was able to access my outlook email yesterday so this only happened in the last 24 hours

Any assistance will be greatly appreciated

Задан awhitford 10 часов назад

Последний ответ от jonzn4SUSE 9 часов назад

Unable to upload or download files

Hello all, For some reason, I can no longer upload or download files, with the pop-up window failing to appear entirely. I can upload folders through, for example, Dropbo… (читать ещё)

Hello all,

For some reason, I can no longer upload or download files, with the pop-up window failing to appear entirely. I can upload folders through, for example, Dropbox or Google Drive, but individual files don't work.

I've reset my browser, uninstalled and reinstalled it, opened it in troubleshooting mode, disabled enhanced tracking protection, but nothing seemed to work. I've tested another browser, and I was able to upload and download files just fine.

Is there anything I can do to fix this? I'm on Ubuntu 22.04 using Firefox 107.0.1.

Задан Erika Campbell 10 часов назад

Последний ответ от jonzn4SUSE 9 часов назад

Browser won't work

Hi, Firefox won't load any websites but other browsers do. Just get a blank screen and can't 'refresh' either (interestingly, Firefox View tab still works) I have checke… (читать ещё)

Hi, Firefox won't load any websites but other browsers do. Just get a blank screen and can't 'refresh' either (interestingly, Firefox View tab still works)

I have checked antivirus & firewall settings, and reinstalled Firefox several times. Any suggestions please? Thanks

Задан 75caferacer 10 часов назад

Последний ответ от 75caferacer 9 часов назад

AdBlocker banner won't go away on Titab TV website.

I've used Titan TV (https://partners.titantv.com/default.aspx) to check TV listings for years. Now when it loads, a banner asking me to disable all adblockers comes up. I… (читать ещё)

I've used Titan TV (https://partners.titantv.com/default.aspx) to check TV listings for years. Now when it loads, a banner asking me to disable all adblockers comes up. I have done so (AdBlock and uBlock Origin), including disabling them in Settings. The banner persists and there is no "X" to close it, nor does the Esc key do anything. I've told Titan and they do not respond. Could this be related to a Mozilla Firefox update (I am running the latest version)?

Задан mr_greg4 2 дня назад

Последний ответ от cor-el 10 часов назад

Password breaches

I have no record of having t up a password for data breaches which I am told involve passwords. So I have nothing to change. How can I keep my data secure in this situa… (читать ещё)

I have no record of having t up a password for data breaches which I am told involve passwords. So I have nothing to change. How can I keep my data secure in this situation?

Задан suetettix 1 день назад

Последний ответ от James 11 часов назад

Dragon NaturallySpeaking add-on broke

I use the Dragon NaturallySpeaking add-on to navigate Firefox (and my entire computer) by voice. Recently the extension stopped working properly, and when I tried to unin… (читать ещё)

I use the Dragon NaturallySpeaking add-on to navigate Firefox (and my entire computer) by voice. Recently the extension stopped working properly, and when I tried to uninstall and re-install the plug-in, it would not work at all.

This is the installation link Nuance provides: https://dnsriacontent.nuance.com/15/setup/ffinstall.html.

When you try to click the "Install" button, nothing happens. This has caused Dragon to stop working with almost the entirety of Firefox. Please advise on if an update is coming.

Задан chelsea.hansen33 3 месяца назад

Последний ответ от jscher2000 - Support Volunteer 17 часов назад

Debugging content scripts on a temporary extension.

I'm porting a chrome extension to firefox: it clearly loads on the page as I see some of it working. But other things are not happening. There are no errors in either the… (читать ещё)

I'm porting a chrome extension to firefox: it clearly loads on the page as I see some of it working. But other things are not happening. There are no errors in either the page or the background page. So I wanted to set a breakpoint in my content page, and I followed the instruction on this page: https://extensionworkshop.com/documentation/develop/debugging/#debugging-content-scripts Which clearly shows extensions icons in the Sources/Main Thread.

But for me, there are none. The first screenshot is from the page where the extension is loaded no extension is listed, the second is from the background page for the temporary extension.

Задан stephane.saux 22 часа назад

Последний ответ от stephane.saux 12 часов назад