Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

My own Google Map icons are not visible in Firefox 8

  • 15 ответов
  • 183 имеют эту проблему
  • 58 просмотров
  • Последний ответ от nico.mollet

more options

I have many Google Maps on my website and they contain both default Google icons and my own icons, each with their own URLs. They work correctly in all other browsers, and Firefox 7. However, yesterday I loaded Firefox 8. In Firefox 8 the Google default icons are still visible but my own icons are now invisible, but their placeholders are still there. They are still visible in other browsers. Also, if I now try and add one of my icons to a map, the process seems to work correctly, including a placemark name appearing, but the icon is invisible. The invisible icon is definitely there because you can click the placemark and be taken to the correct position on the map for editing, but the icon is not visible.

Изменено keith13

Выбранное решение

Thanks.

I've put the issue up on the MozillaZine Web Development/Standards Evangelism forum at http://forums.mozillazine.org/viewtopic.php?f=25&t=2359775.

Прочитайте этот ответ в контексте 👍 0

Все ответы (15)

more options

Which items do you mean?

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB).


If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check the permissions for all sites on the about:permissions page, via the location bar.
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images permissions.default.images

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.

more options

Thanks for your suggestions.

I have checked all permissions you suggested - everything seems to be in order.

The problem is all to do with icons that I have made and put into Google maps - default icons supplied by Google all work. My own icons all show on all other browsers, including FF7 - the problem is only in FF8.

I have attached two screenshots, one showing a Google map page in Chrome. Note there are 6 icons showing; Placemark 1 and Placemark 2 are my own icons (which show the works "Start" and "Finish" on the map, and Placemarks 3 to 6 are default Google icons.

The second screenshot shows the same map in FF8. The default icons are visible , but my own icons are not, even though they are still there - you can see they are still there because the Placemark 2 box is pointing to where the icon is in the Chrome screenshot.

more options

There is something seriously going wrong with the start.png and finish.png images.

On the about:cache page they have a mysterious cache entry prefixed with "anon&uri=" and produce an error in the Tools > Error Console when I check them in Tools > Page Info > Media

key: anon&uri=http://walkinginfrance.info/icons/start.png
key: anon&uri=http://walkinginfrance.info/icons/finish.png
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [imgIRequest.image]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/pageinfo/pageInfo.js :: makePreview :: line 849"  data: no]

The HTTP response Headers look quite normal to me:

HTTP/1.1 200 OK
Date: Fri, 11 Nov 2011 03:06:29 GMT
Server: Apache
Last-Modified: Sat, 22 Oct 2011 21:17:23 GMT
Etag: "dfc9a6-d9e-4afe9b7383ec0"
Accept-Ranges: bytes
Content-Length: 3486
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: image/png

The images do load normally if I paste the URL in the location bar.

Изменено cor-el

more options

Thanks.

There definitely is something seriously going wrong with the start.png and finish.png images, but only in FF8, and I have no idea what it is.

more options

Firefox 10 (Aurora) and Firefox 11 (Nightly) have the same problem.

Maybe someone at the mozillaZine Web Development/Standards Evangelism forum can help you wit this problem.
The helpers at that forum are more knowledgeable about web development issues.
You need to register at the mozillaZine forum site in order to post at that forum.

See http://forums.mozillazine.org/viewforum.php?f=25

more options

Выбранное решение

Thanks.

I've put the issue up on the MozillaZine Web Development/Standards Evangelism forum at http://forums.mozillazine.org/viewtopic.php?f=25&t=2359775.

Изменено keith13

more options

I am having the same problem. I stupidly spent quite a bit of time messing with it before I tried another browser, where they work fine.

Man I hope this is being looked at. I have some custom maps and I'm sure people are going to the website in FF8.

Thanks

more options

I don't know what the cause is in keith13 case. Maybe it is a cross domain security issue with that Google script because loading the images directly works. You may need to let the server send special headers in such a case.

more options

This problem is very anoying !!

I hope someone can save us !

Thanks

Изменено raguy

more options

Same problem here. The interesting thing is, that not all maps are affected.

Examples (problem only occurs in FF8):

http://www.wanderwege-nrw.de/wandern-in-nrw/ruhrgebiet/recklinghausen---duelmen.html (icons in the map are missing...)

http://www.wanderwege-nrw.de/wandern-in-nrw/ruhrgebiet/bachtaeler-und-die-ruhr-bei-muelheim.html (icons are shown without any problem...)

All icons are shown without a problem in IE, Chrome, Safari and FF7.

more options

Same problem with my maps. You posted that this issue is solved at http://forums.mozillazine.org/viewforum.php?f=25 but it is NOT SOLVED!!!!! I'm not a web developer, so I don't want a solution where I have write code or be a developer to figure it out. It works in every other browser & in FF7, so why can't you just figure it out & fix it, instead of making us have to write code or use our own developers to figure it out??

more options

It will stop working in other browser like Google Chrome as well if the solution is to send specific HTTP access control headers.

Изменено cor-el

more options

For you non-coders, (and yes, I am one of you) to fix this, open notpad.exe or whatever text editor you use. copy this one line of text or, if your site already has a .htaccess file, open your .htaccess file and add this one line of text to it.

Header set Access-Control-Allow-Origin *

Then save as... ".htaccess" (without the quotes) into your root website folder. Then upload the file to your server. and presto, now the icons show.

Изменено camparizona

more options

Seriously? I've got to write code to make something work that worked before the update? How long will it be before I'm writing pages of code to correct errors? I don't understand why the smart guys who created this problem can't fix it for everybody rather than let each individual fend for himself.

At the very least, they should post it in their "known issues" section, with a copy of a file to use.

I agree with cpyrsn above: This problem is NOT SOLVED.

more options

And what about users hosting content on file sharing services like Dropbox, Google Sites : we can't add htaccess properties because it's not allowed by those services.