Search Support

I am continually getting the following error message ... what happened:TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined

  • 15 ответов
  • 1390 имеют эту проблему
  • 4460 просмотров
  • Последний ответ от AliceWyman

more options

I am constantly getting the following error message ...

what happened:TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined

Выбранное решение

That is an indication of a problem with an add-on that is not compatible with Firefox 4 beta. You can try disabling your extensions until you find the one causing the problem. See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems for more details on how to fix this.

I see by your user agent string that you have the Ask toolbar, I don't think that toolbar has been updated to work with Firefox 4, try disabling that one first.

Прочитайте этот ответ в контексте 👍 70

All Replies (15)

more options

Выбранное решение

That is an indication of a problem with an add-on that is not compatible with Firefox 4 beta. You can try disabling your extensions until you find the one causing the problem. See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems for more details on how to fix this.

I see by your user agent string that you have the Ask toolbar, I don't think that toolbar has been updated to work with Firefox 4, try disabling that one first.

more options

Thank you ... this worked ... I disabled the Ask toolbar

more options

I get that same popup every time I click on notifications on facebook. Also, I do not have any toolbars installed

Изменено ashkee

more options

Ask toolbar is disabled, still got the same popup error

more options

I keep getting an error code. It is sec_error_expired certificate, It asks me to view the certificate then it doesn't allow mew to fix the problem

more options

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

See Secure connection failed and Firefox did not connect

more options

I got an error message while copying a text and pasting it into google translation section on Firefox 4.0 Beta. It says "Do not have enough storage space to process this command." This happened after doing some copy and paste work. I mean it didn't happen at first.

more options

There are three successive error messages before firefox starts. With the RC version the browser will load, in Beta 11 it would open but not connect to the internet. These are the messages.

[JavaScript Application] JavaScript fails to instanciate interface component!

[JavaScript Application] TypeError:_CHARTER_INST_.DTFox is undefined

[JavaScript Application] load: TypeError: Components.classes['@checkpoint.com/XPCOMTrustCheckerMozilla /TrustCheckerMozilla;1'] is undefined

These addons were recommended and I installed them, Addon Compatibility Reporter and Feedback. This is when the problem first occurred.

more options

type error:components.classes{'@mpzilla.org/manager;1']is undefined this is my problem

more options

type error:components.classes{'@mpzilla.org/manager;1']is undefined this is my problem

more options

TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined

more options

TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined

more options

TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined when i'm trying to use mozilla that happend

more options

I get similar errors. When I log onto some of my most used sites, the images don't appear and the site is almost entirely text. This does not work with bitmapped link images on sites like http://news.nnyln.net/feedback.html where I depend on the newspaper articles for genealogy research.

When I go to sides like http://www.cdcovers.cc/list/dvd/a and try to download cover art, if get a "TypeError: 0ticket undefined" message.

How do I correct this?

more options

Since the thread owner has marked the issue as "solved" I'm locking this thread. If anyone has other questions please start a new thread.