Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Firefox new install on XP, problems trying to get same-version-Firefox old W2K profile to run.

  • 3 ответа
  • 5 имеют эту проблему
  • 4 просмотра
  • Последний ответ от the-edmeister

more options

I'm moving from a W2KproSP4 (Win2000, Windows 2000) machine to an XPproSP3 (WinXP) machine. I was running AVG 9.0 and Firefox 3.6.7 with FireFTP, NoScript, WOT, and screengrabber(?). I installed Firefox on the XP machine, launched it to create a profile, and closed it. I copied the old profile folder contents into the new one. On launch: "Malformed file" "Firefox could not install this item because "install.rdf" (provided by the item) is not well-formed or does not exist. Please contact the author about this problem." (This error disappears in Firefox Safe Mode.) Install.rdf is on the old drive at \Program Files\AVG\AVG9\Firefox. "alert" "Could not initialize the application's security component. The most likely cause is problems with files in your application's profile directory." When I click on Tools/Addons, "An error occurred during a connection to services.addons.mozilla.org:443. Can't connect securely because the SSL protocol has been disabled." I tried uninstalling AVG and Firefox and installing Firefox first. (That helped me with Link Scanner related non-launch on another XP machine.) Depending on which combination of old & new profile files I have, I get some combination of the above 3 errors and not launching at all. (It may show for about 1 second in Task Manager, then quit.)

P.S. I am posting this from my old W98SE machine, running Firefox 2.0 since it won't launch anything newer. I never did solve that mystery.

This happened

Every time Firefox opened

== I am moving to a new O/S

Все ответы (3)

more options

1. Firefox is the last ever version of Firefox for Win98 / SE / ME. It is two years newer (12.18.2008) than what you are now using. Get it from here: ftp://ftp.mozilla.org/pub/firefox/rel.../en-US/

2. The potential for problems like you are seeing with that AVG addon is why Mozilla help doesn't recommend copying an entire Profile to another PC. http://support.mozilla.com/en-US/kb/Recovering+important+data+from+an+old+profile

3. That "Malformed File" message would be related the new installation, not the old W2K location; deleting the 4 "extension" prefs file in the Profile folder might fix it.

extensions.cache extensions.ini extensions.rdf and compatibility.ini

--- I had a similar problem 3 years ago (related to other extensions) when copying Profiles that were used on W2K over to a new WinXP laptop; I deleted the prefs.js file with Firefox closed, and Firefox created a new one when it was launched - that problem was gone. But my problem didn't involve Firefox extensions that were sitting in another applications program files, as with your AVG problem.

more options

Hi the-edmeister, thank you so much for your time.

I'm proceeding more cautiously now, and trying to get my most crucial info back one step at a time. The situation seemed to be getting worse, so I fell back a ways for a fresh swing at it:

I just restored to a Ghost of the XP before I installed Firefox, uninstalled AVG, and installed the same version of Firefox (3.6.7) as my old computer had. The W2K's old drive is slaved to my new HD, so I have access to the old files in (what is now) H:. I tried to restore bookmarks-2010-07-24.json from my old bookmarkbackups directory and got "unable to process backup file". (I also tried copying several files to the bookmarkbackups dir and restoring from there, but got the same error message.) Help>TroubleshootingInfo confirms the current profile folder, and the copied JSONs were seen by OrganizeBookmarks>Import-and-Backup>Restore.

Then I copied places.sqlite from the old profile to the new one, but Firefox doesn't see my bookmarks. When I backup bookmarks to my desktop, I get a zero length .JSON file. Is there a trick to making places.sqlite active?

BTW, yes, I've tried to update the Firefox version 2.0 on the W98SE, most recently to, but whenever I do, it runs invisibly (is present in Program Manager but doesn't display the window.) I have to uninstall and reinstall 2.0 to have a working Firefox on this beast. Thanks for noticing. That's another topic, tho.

more options

I gave up on trying to get the W2K files to work. I deactivated AVG's Link Scanner, installed Firefox 3.6.8, and found a backup of the W2K machine's bookmarkbackups folder from mid-July (yay). Restored the most recent .JSON file from that without difficulty, so I have most of my bookmarks. I then reinstalled FireFTP and ran the .XPIs for NoScript, and Screengrab. I'll try to get WebOfTrust after I go online. I re-activated AVG's Link Scanner, and I'm just about to plug in the Ethernet cable.