Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

HTTPS overkill by Firefox

  • 8 ответов
  • 1 имеет эту проблему
  • 31 просмотр
  • Последний ответ от zeroknight

more options

Later version refuses to connect to my modem, and goes into security web mode. This modem uses HTTP/HTTPS for access, i.e., connects directly it's IP address, then the user enters a username and password. At that point, the the modem switches to HTTPS for control.

With this recent update, there is NO WAY to access the modem for any work, or upgrade the HTTPS certificate on the modem. This is a BUG.

What should happen is that if the web site will accept a HTTP connection, Firefox should NOT refuse connection or test for security issues UNTIL the user or the device switches to HTTPS.

As an aside, I've used Firefox on this Zywall modem for years until recently.

Later version refuses to connect to my modem, and goes into security web mode. This modem uses HTTP/HTTPS for access, i.e., connects directly it's IP address, then the user enters a username and password. At that point, the the modem switches to HTTPS for control. With this recent update, there is NO WAY to access the modem for any work, or upgrade the HTTPS certificate on the modem. This is a BUG. What should happen is that if the web site will accept a HTTP connection, Firefox should NOT refuse connection or test for security issues UNTIL the user or the device switches to HTTPS. As an aside, I've used Firefox on this Zywall modem for years until recently.

Все ответы (8)

more options

Is this with HTTPS-Only Mode enabled or disabled or both ?

Полезно?

more options

Make sure the address starts with "http://". Private windows will try to use HTTPS first and if the modem is temporarily inaccessible, Firefox will fall back to HTTPS.

Полезно?

more options

http://192.168.1.1 Immediately turn it in to: https://192.168.1.1/redirect.cgi?arip=192.168.1.1

Полезно?

more options

Don’t enable HTTPS-Only Mode is selected. And... Exceptions makes no diference

Полезно?

more options

That indicates it is successfully connecting and redirecting.

Do a quick test with Developer Edition to see if it works there with a clean profile.

Полезно?

more options

Same with Development addition, but first try switched from 192.168.1.1 to "Bad Certificate" in https mode, then to "Accept risk", then to "Secure Connection Failed". After that, it went directly to failed even after deleting all history.

As I do have certificates through Sectigo, there is no way to update the router cert because I can no longer log on to it. As an aside, I've used Firefox for years to control the routing of incoming to the proper server or computer. This is no longer possible.

Полезно?

more options

Same with Development addition, but first try switched from 192.168.1.1 to "Bad Certificate" in https mode, then to "Accept risk", then to "Secure Connection Failed". After that, it went directly to failed even after deleting all history.

As I do have certificates through Sectigo, there is no way to update the router cert because I can no longer log on to it. As an aside, I've used Firefox for years to control the routing of incoming to the proper server or computer. This is no longer possible.

Полезно?

more options

Does the "Secure Connection Failed" page have an error code?

Did you try importing the certificate into Firefox (about:preferences#privacy > View Certificates)?

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.