Avatar for Username

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Some pages of the site Mouser.com open incorrectly

more options

For example, look at how the same page looks in Firefox 106.0.2 (64 bits) and Yandex Browser (22.9.4.866).

https://www.mouser.de/ProductDetail/Xilinx/XC7S6-1FTGB196C?qs=unwgFEO1A6taa4TM2WgIJg%3D%3D

I tried changing the user agent, it didn't help. I think the problem is in the Java engine.

For example, look at how the same page looks in Firefox 106.0.2 (64 bits) and Yandex Browser (22.9.4.866). https://www.mouser.de/ProductDetail/Xilinx/XC7S6-1FTGB196C?qs=unwgFEO1A6taa4TM2WgIJg%3D%3D I tried changing the user agent, it didn't help. I think the problem is in the Java engine.
Приложенные скриншоты

Выбранное решение

Thank you so much for your advice. I tried the options you suggested, but it didn't help. You gave me the idea that I need to play with the browser settings.

The first thing I set up settings for clearing history. Then I started changing the browser settings. After changing the settings, I restarted the browser. It turned out that the problem occurs only in one case when in the settings "Web Page Language Settings" the first line is "Russian [ru-ru]". As soon as you move "Russian [ru-ru]" below, the problem goes away.

Прочитайте этот ответ в контексте 👍 0

Все ответы (3)

more options

It's possible Firefox blocked a file or data that is needed to render the page. Usually that would be either Firefox's Enhanced Tracking Protection feature, or an add-on that counter ads and tracking. Worth checking:

(A) The Tracking Protection shield icon toward the left end of the address bar usually turns a bit purplish when content is blocked. Click the icon to learn more or make an exception. See: Enhanced Tracking Protection in Firefox for desktop.

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix usually provide a toolbar button to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you sometimes need to click the button to see what's going on and test whether you need to make an exception for this site.


One method to suss out an issue with settings or add-ons is:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Take a quick glance at the page and make a mental note of which Profile has this notation: This is the profile in use and it cannot be deleted. That is your current default profile.

Click the "Create a New Profile" button, then click Next. Assign a name like Test2022, ignore the option to relocate the profile folder, and click the Finish button.

Firefox will switch your default profile to the new one, so click the Set as Default Profile button for your regular one to avoid an unwanted surprise at your next startup.

Scroll down to Test2022 and click its Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system to get a clean test. Then you can copy/paste the URL from your regular profile window to the new profile window.

Do problem site(s) work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Test2022 will remain available for future testing.)

more options

Выбранное решение

Thank you so much for your advice. I tried the options you suggested, but it didn't help. You gave me the idea that I need to play with the browser settings.

The first thing I set up settings for clearing history. Then I started changing the browser settings. After changing the settings, I restarted the browser. It turned out that the problem occurs only in one case when in the settings "Web Page Language Settings" the first line is "Russian [ru-ru]". As soon as you move "Russian [ru-ru]" below, the problem goes away.

more options

That's good to know. Maybe ru-ru is non-standard?