Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Cursor goes to address bar instead of search bar

  • 12 ответов
  • 5 имеют эту проблему
  • 1328 просмотров
  • Последний ответ от Radsan

more options

In Ubuntu 18.04, I bring up a new page, click in the search bar in the middle of the page. Then when I start typing it jumps to the address bar although I have already placed and preferred the search bar to the right. No! NO! NO!

I use Duck Duck Go but Google does the same.

It is bad enough that the upgrade was automatically loaded but on top of that, changing preferences including dumping my home page. Change privacy settings without asking ( to a lower level on top of that ).

Really POOR form.

Выбранное решение

This is a new feature of the built-in Firefox Home / new tab page. No good? There is a preference for this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator.]

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Success?

More info on about:config: Configuration Editor for Firefox.

Прочитайте этот ответ в контексте 👍 6

Все ответы (12)

more options

Выбранное решение

This is a new feature of the built-in Firefox Home / new tab page. No good? There is a preference for this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator.]

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Success?

More info on about:config: Configuration Editor for Firefox.

Изменено Chris Ilias

more options

By the way, you shouldn't lose preferences during a normal update. Did your Firefox perform a Refresh? The tell-tale sign is a new folder on your system desktop named Old Firefox Data.

more options

Thanks for the info, it worked. FireFox did pop up a notice that it had installed a new version and asked if I wanted to try it but I clicked later ( or similar ). This happened on 2 of my computers so far. No new folder was on my desktop but it was definitely changed. Lost my menus, search bars, etc.

Perhaps I was a bit touchy about it but I have enough issues, running 4 each 8 core servers with 4 to 5 each 2 or 3 TB drives on each plus several other systems and it is demanding enough without surprises.

more options

Same problem on a 3rd computer. Thanks for the fix but really, ask before changing.

more options

P.S. I'm just a support volunteer, I won't be calling you about future changes.

more options

Thanks for the help jscher2000. When I said "ask before changing" I was not referring to you but to whoever is in charge of the updates. I just had this same problem on a new install. At least I knew what to do but something like this should NOT have been made a default. It is a problem that I have seen across the board with Linux lately, someone making decisions for everyone. Just because some admin or programmer likes a feature or a way of doing things does not mean that it should be forced on everyone.

more options

@jscher2000

Thanks for the helpful information.

Do you have any idea why Mozilla did this? Why fix something that's not broken? And why not have a pop-up notification about it?

Oh well, I suppose this is progress.

more options

This has been driving me crazy for months! Thank you finally a working solution!

more options

Works great. Thanks!

Изменено Qismet

more options

This solution does not work anymore on firefox 94. Does someones has a solution ?

Изменено fr.viewer

more options

fr.viewer said

This solution does not work anymore on firefox 94.

It still works for me. What if you double-click browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar to switch it to true, and double-click it again to switch it back to false?

If your problem is the size/design of the shortcut tiles (smaller icons), that is a different issue discussed in other threads.

more options

The given solution has worked perfectly for me! I have tried so many other solutions on the web which didn't work, but at last, I found one that worked. I just had to restart my browser after making that change, and everything was then how it should be.