Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Down/up arrow key jumps pages instead of scrolling a few lines when reading pdf

  • 3 ответа
  • 1 имеет эту проблему
  • 699 просмотров
  • Последний ответ от ChaoticCube

more options

Whenever I first open a pdf, the up/down arrows work as normal (they scroll a few lines at a time), but whenever I jump to a new chapter/section using the sidebar, the up/down arrow keys just start to scroll one page at a time and I am unsure of how to fix this.

Below is a sample pdf in which this issue has occured.

Whenever I first open a pdf, the up/down arrows work as normal (they scroll a few lines at a time), but whenever I jump to a new chapter/section using the sidebar, the up/down arrow keys just start to scroll one page at a time and I am unsure of how to fix this. Below is a sample pdf in which this issue has occured.
Приложенные скриншоты

Выбранное решение

Alright, so I was playing around with a few more settings and found out where the issue was. Apparently, jumping to a new section from the sidebar changes the zoom setting to "Page Fit," which is where the arrow keys start acting up for some reason. Changing the zoom setting to something like "Page Width" fixed the issue.

Прочитайте этот ответ в контексте 👍 0

Все ответы (3)

more options

Could you check to make sure the "caret browsing" feature is not enabled? You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type cursor and Firefox should filter to the "Browsing" section. If the box is checked for "Always use the cursor keys to navigate within pages" then uncheck that box.

If you changed that, does it make any difference?


More generally, when there are two different scrolling regions in a page, it sometimes helps to click in the region that you want the cursor keys to scroll. Does that make any difference?

more options

Unfortunately, caret browsing does not seem to be the issue. I just looked and the "Always use the cursor keys to navigate within pages" button was always unchecked and testing it again showed no new results.

I have tried clicking in various regions of the page, but it didn't seem to do anything either. I'll put a screenshot of where I tried clicking in case I missed something.

more options

Выбранное решение

Alright, so I was playing around with a few more settings and found out where the issue was. Apparently, jumping to a new section from the sidebar changes the zoom setting to "Page Fit," which is where the arrow keys start acting up for some reason. Changing the zoom setting to something like "Page Width" fixed the issue.