Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Stopping automatic pdf downloads on Firefox using MacOS

  • 1 ответ
  • 1 имеет эту проблему
  • 51 просмотр
  • Последний ответ от jscher2000

more options

It does not matter how many times I change this setting in preferences to "Open in Firefox" I still get this pop-up every time I click a pdf.

It also does not matter how many times I select "open with preview" and click "Do this automatically for files..." box. Every time I click the next pdf the same thing pops up!?!?!?!

And additionally no matter my selection I make ends up leading to a pdf being downloaded automatically.

This is beyond frustrating. Please help.

Приложенные скриншоты

Все ответы (1)

more options

Are there sites where it works and sites where it doesn't?

When sending a download, sites set multiple HTTP headers. Sites can set two of these to trigger the download dialog, bypassing Firefox's automatic handling of downloads:

(1) Content-Disposition

If a server sends a Content-Disposition header set to attachment, which bypasses viewing in a tab, Firefox will always show the download dialog.

(2) Content-Type

The setting on the Options/Preferences page is keyed to the content type application/pdf, not the .pdf file name extension. If the server sends a different content type, Firefox won't use the PDF instructions.

If you would consider using an add-on to address these issues, I have one here:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

When using a site that has this issue, click the Zzzz button to wake up the extension, then click the button again and select the "Follow my settings (inline)" option:

<center></center>

Изменено jscher2000