Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

Firefox cache too aggressive

  • 13 ответов
  • 1 имеет эту проблему
  • 60 просмотров
  • Последний ответ от jscher2000

more options

Hello,

Since one week (but i was in holidays the 2 previous weeks) Firefox cache turn me crazy. I disconnect from an account or reload a page (where content have been changed) and data are not updated. I have to empty cache each time to be sure data are the good one. To work in sites backoffice it's just a nightmare !

Also when i save a form 50% of time it don't save values. It's crazy ... Big problem with cache system since one or 2 versions. Please correct this fast. Firefox become unusable.

Also : HOW TO CHANGE CACHE BEHAVIOUR ??? Now more option to set this ... In this situation i would like to set cache to be off ... But no more settings for that.

Regards.

Все ответы (13)

more options

Hi pascal12, try turning off disk caching to see whether that helps:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste cache and pause while the list is filtered

(3) Double-click the browser.cache.disk.enable preference to switch the value from true to false

About this part --

pascal12 said

Also when i save a form 50% of time it don't save values.

-- I'm not sure what you mean by saving the form. Do you mean when you submit the form, it isn't getting submitted successfully? That seems like a different problem, probably not related to excess caching.

Полезно?

more options

Thanks for help, i disabled cache and i will test like that.

For other part, y it seems form saving work bad ...

Полезно?

more options

I have other problems like image list in joomla CMS not refreshed or empty. Too much problems with this new cache system ... I have to switch to Chrome for work.

Please do more intensive tests before publishing such changes. it totally ruin efforts to bring back Firefox to front ... Sad !

Полезно?

more options

Hello, any news about this bug ?

Yes i call it a bug cause many of our customers working with Firefox have the same problem.

Working in websites backoffice (Joomla, Prestashop, etc ...) is now almost impossible ! We have to use CTRL-F5 each time we load or relaod a page ...

Is Mozilla technical team aware of this problem ??

Изменено pascal12

Полезно?

more options

On some page (mostly with ajax) we have to empty cache + use CTRL F5 to get right version ...

Полезно?

more options

Hi pascal12, the developers are aware that style sheets are cached more persistently, and that has side effects primarily for developers. If users cannot see content changes in their CMS due to aggressive caching, please file a separate bug for that:

Полезно?

more options

The problem go much more far than style sheets cached too persistantly ... It is the same for lot of other things on page including form fields, or session elements (like informations displayed when logged in that still display when logged off).

And it's not only for developpers. All my customers using firefox to manage their sites called me cause they have strange behaviours ... And now all use Chrome ... Very bad move.

Полезно?

more options

You can file a bug as I mentioned earlier. The only CMS I use is WordPress, so I cannot test Joomla, etc.

Полезно?

more options

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Полезно?

more options

pascal12 said

And it's not only for developpers. All my customers using firefox to manage their sites called me cause they have strange behaviours ... And now all use Chrome ... Very bad move.

Yes, we have tha same problem, we send emails to our all customers to not use firefox for administering their websites!

Полезно?

more options

When I tested whether Firefox 80 and Chrome 85 reload cached style sheets when I press F5, I got the same results on this test page:

https://www.jeffersonscher.com/csscache/index.html (check time stamps after pressing F5)

Maybe there is a different combination of headers I haven't tested that will show a difference.

Полезно?

more options

On our side we have reviewed and modified cache policy on our servers.

Nginx config was changed from this :

map $sent_http_content_type $expires {

   default                    31d;
   text/css                   90d;
   text/js                    120d;
   application/javascript     120d;
   ~image/                    90d;

}

To this :

map $sent_http_content_type $expires {

   default                    off;
   text/html                  epoch;
   text/css                   max;
   text/js                    max;
   application/javascript     max;
   ~image/                    max;

}

It seems to solve the problem ... BUT now we have no more HTML elements cached by browser :/

Изменено pascal12

Полезно?

more options

For developers, I created an extension you can use to temporarily prevent caching of CSS files from your own servers (or any servers, you create the host list and set the host permissions):

This doesn't help your site visitors, who will still have old CSS files cached for a while. I notice in some CMS the href in the stylesheet link tag has a version number argument (this may be part of a WordPress theme, for example):

<link rel="stylesheet" href="style.css?ver=3.1">

Maybe that could be a workaround to address the end user situation once changes are final and roll out to production.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.