Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

download goes to wrong location

  • 30 ответов
  • 2 имеют эту проблему
  • 206 просмотров
  • Последний ответ от mike_coreit

more options

In Options, I have C:\Downloads⁩ as the location that my internet files are downloaded. Instead, they go to a different location, specifically: C:/Users/**/AppData/Local/Temp.

How do I make Firefox download my files to the correct location?

Thanks.

Все ответы (10)

more options

I set the location in Options, not the ask me function. Will try that.

See previous post. I changed the permissions of the downloads file to the same as the temp file without any change. Notice that this worked at one point.

Полезно?

more options

Chris Ilias said

Hi Lokimeister, Would you mind sending us a video of what you're seeing? For instructions, visit the following: Upload the video to a cloud service, like YouTube, OneDrive, Google Drive, or Dropbox, and paste a link to the video in this forum thread.
NOTE: This forum is public!

https://www.dropbox.com/s/34h5gjoedq2y3xq/2020-04-07%2011-27-49.mkv?dl=0

Полезно?

more options

Hi Lokimeister Thanks for the video! That clears things up.

Usually, when a person clicks on a file, a prompt should appear asking if you want to Save the file or Open it.

  • If you select Save, it will download to your preferred location.
  • If you select Open, it will download to the Windows TEMP folder, and get cleared with other temporary data when you close Firefox.

In this case, it looks like you have set PDF files not to use the Open option, without prompting you.

  1. Go to Options > General, and scroll down to the Applications section.
  2. In the search field, type PDF.
  3. There should be one search result. Click on the Action for that result, and set it to Always ask.

The next time you click on a PDF file, it will prompt you to Open or Save. Select Save.

If you still have the issue, please let us know.

Полезно?

more options

Okay that works, but it doesn't solve the actual issue: the auto save doesn't work.

Полезно?

more options

When I open in Acrobat, not save it, the file is still found in the temp file.

Probably going to have to discontinue use of Firefox if I don't get this resolved soon.

Полезно?

more options

Files that you open in an external application like the Adobe Reader will always be downloaded to the temp folder and you can't prevent or bypass this. Downloading and saving files to a specific folder is only possible for a normal 'save' download and not for files you pass to another application.

Полезно?

more options

Yeah, it didn't work that way before. EVERYTHING used to go to the file I wanted it to go to.

Note that the initial issue HAS NOT been fixed.

The "solution" takes more clicks.

Полезно?

more options

I've just had the same problem C:\Users\Santina\AppData\Roaming\Mozilla\Firefox\Profiles\tykmyfxl.default-1581603518331 but then I realised I had set it to 'Open with' rather than 'Save to'. So I unchecked the 'Open with' box on the download app and they are now going back to the download folder, as they previously did :-) Good luck!

Полезно?

more options

I've had the same problem. Turns out I had my pdf reader listed under PDF in Options. I changed it to Save File and it now saves to my designated folder.

Полезно?

more options

Hi I have recently had this issue since updating to version 79.0. In options it is set to always ask where to save the downloaded file, and I prefer this to always saving in 1 folder.

Whenever I click a link to download (e.g. a .zip file) a new window flashes up very briefly, then closes. When I look at networking activity in Task Manager I can see there is a lot of usage, and then it seems the .part file is created under %tmp%. When I go to Tools, Downloads there is no notification of any download in progress.

I use Avast anti-virus which I have disabled, but the issue continues.

It seems there is a work-around if I right click a download link then choose Save Link As then the save dialog will appear and work normally. Also I am using Windows 7 64-bit (I know it is unsupported).

Полезно?

  1. 1
  2. 2
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.