X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

How can I Completely Disable Popup Blocker - Unchecking Box Doesn't Work

Размещено

I have unchecked the box in Settings which is apparently supposed to disable the popup blocker however it is still active. I have also disabled Content Blocking for the sites in question with no change in the popup blocker's behavior. I would like to COMPLETELY disable this feature since it is preventing me from access sites I use often for both home and work. As it stands now I'm forced to use Chrome still for many sites.

My systems are OSX, Windows 7, and Windows 10. I've even tested this with a fresh image of Windows 10 and without logging in to my Firefox account or anything, same results.

I have unchecked the box in Settings which is apparently supposed to disable the popup blocker however it is still active. I have also disabled Content Blocking for the sites in question with no change in the popup blocker's behavior. I would like to COMPLETELY disable this feature since it is preventing me from access sites I use often for both home and work. As it stands now I'm forced to use Chrome still for many sites. My systems are OSX, Windows 7, and Windows 10. I've even tested this with a fresh image of Windows 10 and without logging in to my Firefox account or anything, same results.

Выбранное решение

Aha, it's a different preference. Here's where you turn off the redirect block:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste access and pause while the list is filtered

(3) If the accessibility.blockautorefresh preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

Прочитайте этот ответ в контексте 1
Цитата

Дополнительные сведения о системе

Установленные плагины

I've tested this with no plugins or extensions installed on my systems plus I loaded a brand new image of Windows 10 to try this without logging into Firefox or anything, same results. This is happening on both Windows and OSX.

Приложение

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:67.0) Gecko/20100101 Firefox/67.0

Дополнительная информация

jscher2000
  • Top 10 Contributor
8580 решений 70167 ответов
Размещено

Полезный ответ

Hi btv01020, could you describe the behavior you're seeing, for example:

  • You click a link/button and Firefox display an infobar indicating that it blocked a popup
  • A new window opens and immediately shuts
  • A website says it tried to open a window but was blocked
  • Something else

Do either the second or third links on my test page work: https://www.jeffersonscher.com/res/popit.html

(They should always work because the built-in popup blocker doesn't block new windows opened directly in response to a click.)

Hi btv01020, could you describe the behavior you're seeing, for example: * You click a link/button and Firefox display an infobar indicating that it blocked a popup * A new window opens and immediately shuts * A website says it tried to open a window but was blocked * Something else Do either the second or third links on my test page work: https://www.jeffersonscher.com/res/popit.html ''(They should always work because the built-in popup blocker doesn't block new windows opened directly in response to a click.)''
Помогла ли вам это? 1
Цитата
Размещено

Задавший вопрос

Sorry for the late response. The issue is when I click on almost any link which opens in a new tab or some sites that aren't opening a new tab or window but are reloading the page. When this happens I get the box at the top to allow the pop-up. The problem is that I've encountered several sites that this happens when logging in and it prevents being able to login to that site at all using Firefox. I've re-enabled the pop-up blocker and excluded the entire domain but there is no change.

All three of those link tests worked without a pop-up warning or anything however I do get the pop-up warning quite often when clicking on a link in email or on a website.

Sorry for the late response. The issue is when I click on almost any link which opens in a new tab or some sites that aren't opening a new tab or window but are reloading the page. When this happens I get the box at the top to allow the pop-up. The problem is that I've encountered several sites that this happens when logging in and it prevents being able to login to that site at all using Firefox. I've re-enabled the pop-up blocker and excluded the entire domain but there is no change. All three of those link tests worked without a pop-up warning or anything however I do get the pop-up warning quite often when clicking on a link in email or on a website.

Изменено btv01020

Помогла ли вам это?
Цитата
jscher2000
  • Top 10 Contributor
8580 решений 70167 ответов
Размещено

Can you confirm it's the built-in popup blocker? Firefox should show an icon in the "site information" area and unless it was turned off, the "infobar" pictured in the attached screenshot.

After turning off the popup blocker on the Preferences page, could you take a look under the hood here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste open and pause while the list is filtered

(3) The dom.disable_open_during_load preference should be bolded, have a status of "modified" and a value of false -- does that match yours?

(4) In the search box above the list, type or paste popup and pause while the list is filtered

(5) If any of the listed preferences have been customized (bolded, modified), you can restore the original value using right-click > Reset (or on a one-button mouse, Ctrl+click > Reset)

Can you confirm it's the built-in popup blocker? Firefox should show an icon in the "site information" area and unless it was turned off, the "infobar" pictured in the attached screenshot. After turning off the popup blocker on the Preferences page, could you take a look under the hood here: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''open''' and pause while the list is filtered (3) The '''dom.disable_open_during_load''' preference should be bolded, have a status of "modified" and a value of false -- does that match yours? (4) In the search box above the list, type or paste '''popup''' and pause while the list is filtered (5) If any of the listed preferences have been customized (bolded, modified), you can restore the original value using right-click > Reset (or on a one-button mouse, Ctrl+click > Reset)
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Regarding #3 that does match mine. On #5 all of those settings are default with no modifications. I'm attaching a screen shot of the popup block notification, this occurred when clicking the email link to reply here.

Regarding #3 that does match mine. On #5 all of those settings are default with no modifications. I'm attaching a screen shot of the popup block notification, this occurred when clicking the email link to reply here.
Помогла ли вам это?
Цитата
jscher2000
  • Top 10 Contributor
8580 решений 70167 ответов
Размещено

Выбранное решение

Aha, it's a different preference. Here's where you turn off the redirect block:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste access and pause while the list is filtered

(3) If the accessibility.blockautorefresh preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

Aha, it's a different preference. Here's where you turn off the '''redirect block''': (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''access''' and pause while the list is filtered (3) If the '''accessibility.blockautorefresh''' preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false
Помогла ли вам это? 1
Цитата
Размещено

Задавший вопрос

You sir, are a life saver! That has been causing problems since I switched over to Firefox from Chrome and I'm not sure how it became modified.

Thank you very much for your help!

You sir, are a life saver! That has been causing problems since I switched over to Firefox from Chrome and I'm not sure how it became modified. Thank you very much for your help!
Помогла ли вам это?
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.