Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Page wont load when using Firefox Developer in Visual Studio 2017

  • 6 ответов
  • 1 имеет эту проблему
  • 8 просмотров
  • Последний ответ от tmslayton

more options

When using Firefox Developer Edition as the default browser in Visual Studio the site does not load. When I launch my project the browser window opens but the page never loads. It works in regular Firefox but not the developer edition. I have seen this on multiple installations across several different PC’s. I have it working on one of four PC’s. I develop on all of them for different companies and really would like it to work so I can use the developer edition. If you know of any settings that need to be changed please let me know.

Thanks.

Все ответы (6)

more options

Hi, sorry having issues. Have you seen this ? https://marketplace.visualstudio.com/items?itemName=hbenl.vscode-firefox-debug

Let's start with : Safe Mode

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Performance > Uncheck to view)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

What Extensions are you running as well as Security Software ?

more options

Thanks for the feedback.

I am not using Visual Studio Code. I am using Visual Studio Professional 2017. So the first piece doesn't apply. I did try launching the browser in safe mode. I really don't have any extensions except for a couple of themes installed. It is really strange because I can debug with all other browsers including standard Firefox but not the developer edition.

I and just using Windows Defender for security software.

The issue still persists....

more options

Does it make a difference whether DE is running or needs to be started?

What commands do you use to launch the browser?

more options

Thanks for the reply.

It doesn't matter if the DE is running. To launch the browser you press F5 or click run in Visual Studio. The browser launches but the page never loads.

more options

tmslayton said

Thanks for the reply. It doesn't matter if the DE is running. To launch the browser you press F5 or click run in Visual Studio. The browser launches but the page never loads.

What happens if you change the Browser to IE or another?

more options

All other browsers, including standard Firefox work. Only FFDE does not. Very strange.