X
Нажмите здесь, чтобы перейти на мобильную версию сайта.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Форум поддержки

I delete Google from the list of available search engines, but it keeps reappearing

Размещено

I've been deleting Google from the list of available search engines from the "Search" settings tab, but it keeps reappearing, not as the default search engine, but as a potential search engine. Although I could just ignore Google, I don't like it there. Firefox is the most configurable browser, and it does respect users' decisions and preferences, except in this matter. How can I permanently delete Google from my search engines list?

I've been deleting Google from the list of available search engines from the "Search" settings tab, but it keeps reappearing, not as the default search engine, but as a potential search engine. Although I could just ignore Google, I don't like it there. Firefox is the most configurable browser, and it does respect users' decisions and preferences, except in this matter. How can I permanently delete Google from my search engines list?

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0

Дополнительная информация

FredMcD
  • Top 10 Contributor
4385 решений 61542 ответов
Размещено

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ Google “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''(<Control> ''[Mac=<Command>]'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Remove “ Google “ '''Anything. ''' Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine Now do the same in the computer’s '''Programs Folder. ''' '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the '''Applications''' folder. '''Linux:''' Check your user manual.
Happy112 561 решений 5694 ответов
Размещено

If the above doesn't do the trick, would you please take a look at the article :

How to fix preferences that won't save

If the above doesn't do the trick, would you please take a look at the article : [https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save How to fix preferences that won't save]
cor-el
  • Top 10 Contributor
  • Moderator
17845 решений 161524 ответов
Размещено

Try to rename/remove search.json.mozlz4 in the Firefox profile folder with Firefox closed to reset the search engine registry file.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Try to rename/remove <b>search.json.mozlz4</b> in the Firefox profile folder with Firefox closed to reset the search engine registry file. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox