Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will no longer open Google without a "This Connection is Untrusted" error, and no option to get a temporary certificate is available.

  • 44 ответа
  • 244 имеют эту проблему
  • 119095 просмотров
  • Последний ответ от cor-el

more options

This problem popped up for the first time a few months ago. but I was able to work around it by by clicking on "I understand the risks" on the "This Connection Is Untrusted" warning page, and then by adding a security exception. That fix would work for random lengths of time... sometimes for days, sometimes for minutes. Now, after updating to the latest version of Firefox, I get the same security warning but the option to click "I Understand the Risks" is gone. I get this error message on the technical details page: (Error code: sec_error_unknown_issuer

I have done everything listed here many, many times: https://support.mozilla.org/en-US/kb/connection-untrusted-error-message I mean everything. Delete cert.db, start in safe mode, empty cache, delete and reinstall.... Nothing works.

Your help would be greatly appreciated!

Выбранное решение

In Firefox, you need to import into Authorities. The certificate usually will have a .cer extension.

Прочитайте этот ответ в контексте 👍 4

Все ответы (4)

more options

With regard to Google certificates in other browsers, I have Edge and Chrome but haven't found a way to view the certificates.

more options

h_g said

With regard to Google certificates in other browsers, I have Edge and Chrome but haven't found a way to view the certificates.

Could you look at this post: https://support.mozilla.org/questions/1094777#answer-807808

more options

Chrome shows the same certificate that I imported into Firefox from the list of "Authorities". Edge doesn't show the certificate but states that the same authority "GeoTrust Global CA" which issued the Chrome and Firefox certificates identifies the site as www.google.com. As I stated, Chrome and Edge have no problem. I'm beginning to believe it's simply a Firefox bug.

more options

Did you check the issuer of the certificate?

You can check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

  1. 1
  2. 2
  3. 3