Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Is there a fix for bookmarks that don't appear when exporting all bookmarks as HTML because of missing hyperlink text?

  • 5 ответов
  • 1 имеет эту проблему
  • 2 просмотра
  • Последний ответ от Rockbarkskillet

more options

There is an issue when exporting bookmarks as a HTML file and then viewing that exported file in any browser, certain bookmark entries don't appear. I noticed the reason is because the text that is usually inserted as hyperlink text between the "<a href> </a>" tags is missing. (I'm unsure what qualifies or determines what text is to be inserted for the hyperlink text. It would be appreciated if someone could explain that.) The bookmarks aren't completely missing though.

They are technically still there because you can see them in the HTML source code. It's not that the bookmarks are missing, but the hyperlink text is missing. This is remarkable inconvenient when you want to export and view your bookmarks as an HTML file. And the thing is, this was never a problem for earlier versions of Firefox; sorry, I don't know which version this started happening. Can this be fixed so the bookmarks will properly appear as hyperlinks?

Все ответы (5)

more options

On my windows 7, firefox 35.0.1 it shows up perfect That is all my bookmarks even when I enter 192.168.0.100 (which isn't used) and saves it it will get a hyperlink txt. and exporting will work

<A HREF="http://192.168.0.100/" ADD_DATE="1424606650" LAST_MODIFIED="1424606650" LAST_CHARSET="UTF-8">http://192.168.0.100/</A>

more options

Do these missing entries show with a name in the Bookmarks Manager (Library)?

You can check for problems with the places.sqlite database file in the Firefox profile folder.

more options

Thanks for the replies. They helped me realize that it's the names go missing when I save all the open tabs in a window as bookmarks with Ctrl+Shift+D.

I tested this by making some new tabs in a window. Then I used Ctrl+Shift+D to create the bookmarks in a folder and all their names were missing when I check the Bookmark Manager/Library. But if I save them individually the names register normally. Just to add this happens whether I use normal browsing mode or private browsing mode.

Is there a way to fix this? Would this a problem with the places.sqlite database file?

more options

Are that tabs that you opened in the current session or are there tabs from previous session(s) that you haven't visited in the current session?

more options

The tabs were created in a new/current session. I usually start with a new session whenever I open up Firefox.

I tried using the Places Maintenance addon with the preset Deep Check, but it didn't seem to have any effect. Then I tried enabling all the options and running it again, but that didn't help either.

I've also tried reinstalling Firefox in case it was the places.sqlite file. One was a clean install of the current Firefox, and another was updating from an older version. But still when I saved bookmarks with Bookmark-All-Open-Tabs (ctrl+shift+d), their names would be missing. Then the hyperlink text would be missing when I exported the bookmarks as a HTML file.