Showing questions tagged: Show all questions

Local Html files are not being displayed correctly.

<html> <h1>hello 23</h1> </html> When I am loading this local .html(above template) file , then as in heading h1 , only hello is being displayed ,… (read more)

<html> <h1>hello 23</h1> </html>

When I am loading this local .html(above template) file , then as in heading h1 , only hello is being displayed , the number 23 is not being displayed .

This is happening in all my Html files. The integers are not being displayed in my web browser.

Asked by ashu 3 days ago

Last reply by cor-el 3 days ago

  • Solved

How to hide all tabs in one or more containers

https://support.mozilla.org/en-US/kb/containers seems to suggests that it's possible to hide all tabs in certain containers, but does not explain how to do that. "Hide an… (read more)

https://support.mozilla.org/en-US/kb/containers seems to suggests that it's possible to hide all tabs in certain containers, but does not explain how to do that.

"Hide and Show: Assume you use your browser for both Work and Personal tasks. When you come home at the end of the day, you don’t want to be thinking about “Work” anymore, but your browser is full of Work tabs. You can “Hide” your Work tabs and proceed with your Personal tasks. Then the next day, when you are back at work, you can “Hide” your Personal tabs and “Show” your Work tabs."

On an aside, I'm also getting pretty confused between collections (mobile), containers (desktop), sessions, tab groups, etc... they all seem to have overlapping but different functionality.

Asked by chrisvdb 5 months ago

Answered by RobertJ 5 months ago

Video Lagging at other platforms other than youtube.

I dual booted Ubuntu 19.10 in my laptop alongside Windows 10. The videos in my Firefox browser (on Ubuntu) lags in between, it plays smoothly and after sometime it lags.… (read more)

I dual booted Ubuntu 19.10 in my laptop alongside Windows 10. The videos in my Firefox browser (on Ubuntu) lags in between, it plays smoothly and after sometime it lags. The lagging is not so worse, but still it disturbs me from watching the video. If I play the same video in Windows in Firefox the video plays well. The main problem is with the site ' www.geeksforgeeks.org ' in Ubuntu (Linux) and the same site plays well in Windows Firefox. I have tried fixes like : 1) 'set media.benchmark.vp9.fps = 0' 2) https://support.mozilla.org/en-US/questions/1245735 but they didn't work.

System specs : 8gb of RAM 4gb of Dedicated Graphics card of AMD Radeon RX 560X AMD Ryzen 5-3550H processor

Asked by Bipin Jadav 4 days ago

Last reply by Bipin Jadav 4 days ago

Cookies get changed unexpectedly when making requests to web app

I'm Developing a Web Application I make a GET request to a web app with Fetch API, It shows "No headers for this request" in developer tools, and the cookies get changed … (read more)

I'm Developing a Web Application

I make a GET request to a web app with Fetch API, It shows "No headers for this request" in developer tools, and the cookies get changed as if the request were sent without any cookies and the web app assigned a new cookie. Are cookies sent by default with GET request using Fetch API in firefox?

When accessing page directly instead of Fetch API the request seems to go through every other "F5 Press", and otherwise the same problem occurs.

It works on chromium - trying to figure out what could be different - if it's a problem with firefox or my backend - any ideas? Thanks

Firefox Version 79.0 on ArchLinux Flask/Gunicorn/Nginx on Debian

Asked by eingleVi 4 days ago

Last reply by eingleVi 4 days ago

  • Solved

opening menu=folders on bookmark toolbar opens the menu far far away on another display on Linux/Ubuntu 18.04/Gnome

I'm using FF 77.0.1 (64-bit) [Mozilla Firefox for Ubuntu canonical- 1.0, but the problem has been present for the last 2-3 months over those versions current. When I open… (read more)

I'm using FF 77.0.1 (64-bit) [Mozilla Firefox for Ubuntu canonical- 1.0, but the problem has been present for the last 2-3 months over those versions current. When I open a folder on my bookmarks toolbar, the menu pops up on another display. If I just move my mouse down, as if the menu were immediately below the folder link, the corresponding rows on the menu on the other display are highlighted. However, clicking at that point does not select that menu entry. I must move my mouse over to where the menu is displayed, all the way being careful to not move outside of the Y dimension range of that menu (or it vanishes). This does not happen on all folders on the menu, but the ones it happens on vary from day to day. Prior to the version of FF that I am on, it would only happen once to a given menu and then it would start opening the menu where it should. I currently have 15 folders showing on the toolbar and 5 of them consistently misbehave.

I'm on Ubuntu Linux 18.04 using the Gnome desktop/window manager (not Wayland). I am using a Dell Laptop XPS-13, connected to a Dell DisplayPort dock which drives two external displays, on which I usually do all my work. If I drop back to just the laptop, all the folder menus display properly. In addition, with the dock connected and the two external displays, if I move the FF window to the laptop's display, the menus display properly. However, in my use of multiple applications, no application besides FF exhibits this problem. If I open a private session, the problem is not exhibited.

Adding a screenshot example. I had to crop it on the bottom side to fit in the 1024 Byte limit for attachments. On the bottom, you see a black area on the left, which is where there is no monitor. On the right is a portion of my laptop's display (cropped on the bottom). On the top are the two displays, and the portion just above the laptop display is my right display, and left is left.

Asked by Kevin Buchs 1 week ago

Answered by Kevin Buchs 4 days ago

Moving my passwords from old profile to profile in a newer version of firefox

Dear community, Transferring my passwords from an old profile backup (v 49) to a profile in a newer version of Firefox (v 77.01). I'm copying across the logins.json and k… (read more)

Dear community,

Transferring my passwords from an old profile backup (v 49) to a profile in a newer version of Firefox (v 77.01). I'm copying across the logins.json and key4.db files like it says here: https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile#w_passwords. but it still doesn't seem to show my passwords in the new Firefox version when I look in the preferences. I did happen to notice that the key file version is named 'key3.db' in the old profile whereas the corresponding file in the new profile is 'key4.db'. I don't think they're compatible. My question is can I move my passwords from the old profile to the new profile in Firefox v 77.01? Please can you tell me if I can do it offline/locally like this? I don't want to do it with Firefox sync. I'm currently having problems signing into Firefox sync so that isn't an option.

Kind regards,

Matt

Asked by mdv.fox 1 month ago

Last reply by cor-el 4 days ago

  • Solved
  • Locked

Videos won't play in Nightly

I installed Nightly hoping to be able to play videos. It worked for a while but has recently stopped. I have a screen shot with the error and the version of nightly. I… (read more)

I installed Nightly hoping to be able to play videos. It worked for a while but has recently stopped. I have a screen shot with the error and the version of nightly. I am running Fedora 64 bit with the updates installed.

Asked by vhradice 5 months ago

Answered by vhradice 5 months ago

Add-on shortcuts are missing

I've just installed Firefox 79.0.1 on Manjaro and the add-on shortcuts that normally appear to the right of the address bar are missing. Even when selecting "Customize", … (read more)

I've just installed Firefox 79.0.1 on Manjaro and the add-on shortcuts that normally appear to the right of the address bar are missing.

Even when selecting "Customize", there are no icons/shortcuts for my installed add-ons. I tried selecting "Restore Defaults" on the customize page but the add-on shortcuts are still missing.

I also have tried uninstalling and reinstalling the add-ons and reintalling firefox itself multiple times.


This is particularly frustrating because one of my add-ons is a password manager and without the shortcut I have to manually enter all my passwords. =(

Asked by Oregano Joe 4 days ago

Last reply by cor-el 4 days ago

How can I restore the default theme?

Recently, I wanted to try the dark theme for Firefox, but when I decided to switch back to the default theme, the result was that I still have the dark theme. How can I r… (read more)

Recently, I wanted to try the dark theme for Firefox, but when I decided to switch back to the default theme, the result was that I still have the dark theme. How can I really return to the default theme?

I am running 68.11.0esr on 64 bit Linux.

Asked by goto_hell 5 days ago

Last reply by cor-el 5 days ago

How do I use "window.open" to open a new window with a menubar?

menubar no longer shows in a new window opened with window.open? I am running Firefox Ver. 79.0 (64-bit); Mozilla Firefox for Ubuntu canonical - 1.0; on Ubuntu Bionic 18.… (read more)

menubar no longer shows in a new window opened with window.open? I am running Firefox Ver. 79.0 (64-bit); Mozilla Firefox for Ubuntu canonical - 1.0; on Ubuntu Bionic 18.04 I use the following javascript code in <head> to open a new window: <script> </script> The body is as follows: <body bgcolor="#F2E8DE" onLoad="nameThisWindow()">

Click <a href="javascript:openHomePage()">Open Homepage</a> to open Homepage.htm in a new Window. </body> This code will not display the menubar in the new window (HomePage). The new window opens, resizes, relocates, has scrollbars, has address bar and has the [Open menu] option to the right of the address bar. The way it should except for the menubar on my desktop computer. If I right click on [Open Menu] in the new window it shows a check mark before Menu Bar. If I uncheck it, it closes the menubar in the window that opened it (HomePageCaller). If I click on Customize in HomePage, it opens the customize window in a new Tab in HomePageCaller. If I open a link in HomePage with "Open Link in New Tab" it opens the link in HomePageCaller. If I open a link in HomePage with "Open Link in New Window" it opens the new window with a menubar like it should. I have opened about:config to change all nine of the "dom.disable_window_open" options to "false" and restarted the computer. This did not change anything? I have removed all content from the<head> except the <title> in the new window page. I have removed all content from the <body> except a line that says it is the new window. All to no avail. Thank you for any help someone can provide, Rob

Asked by Rob 5 days ago

MainThread process in Linux: is it just a new name for firefox?

In the last few days, a process called MainThread, using a lot of CPU time, has started appearing in my Ubuntu system monitor "top". I was worried that it was malware, a… (read more)

In the last few days, a process called MainThread, using a lot of CPU time, has started appearing in my Ubuntu system monitor "top". I was worried that it was malware, and checked to see if it might be part of software I had recently installed. After checking with the software providers I had most recently dealt with, I didn't find any that said the MainThread process belonged to them. Then I noticed that the "firefox" process had disappeared from the system monitor. I suspect that MainThread is the new name for firefox, but I would like some confirmation of that theory. If that is the case, why change the name of the process from something recognizable to something unrecognizable? Thanks for any help you can give!

Asked by nhpeacenik1 5 days ago

Distorted colors in mp4 video

Colors are distorted in MP4 video as you can see in the attached screenshot. The distorted colors impact video on many sites including yourlearning.ibm.com, webex.com, tw… (read more)

Colors are distorted in MP4 video as you can see in the attached screenshot. The distorted colors impact video on many sites including yourlearning.ibm.com, webex.com, twitter.com, mlb.com, etc. They do not impact youtube.com which displays video correctly. My Firefox version is 68.10.0esr (64-bit) and my OS is RHEL 7.8, kernel version 3.10.0-1127.13.1.el7.x86_64, Gnome Version 3.28.2

I have tried running in safe mode but the issue persists.

How do get Firefox to display MP4 video with correct colors?

Asked by scottwn 1 week ago

Last reply by scottwn 6 days ago

  • Solved

New CSS styles not picked in Firefox.

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren'… (read more)

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren't displayed in the web page nor in the developer tools inspector.

They are visible in Chromium browser and dev tools.

I have cleared the cache and refreshed the page to no avail. It is only when I restart the browser that the new style rules take effect in the browser and show up in the dev tools.

Asked by mt3ch 1 week ago

Answered by cor-el 1 week ago

Opening links in any desktop app to open up in Nightly broken, what's going on?

Opening links in any desktop app to open up in Nightly is broken for me since a few months, I didn't really change anything on my side. The bug report so far has been ign… (read more)

Opening links in any desktop app to open up in Nightly is broken for me since a few months, I didn't really change anything on my side. The bug report so far has been ignored, and this is a pretty major breakage. Does anyone have an idea what I could check out on my system to get this fixed or provide info for the bug so that somebody actually looks at it? EDIT: Please note Nightly initially launches fine, SO THERE IS NO PROBLEM OPENING THE PROFILE. There is also no problem with a previous instance being stuck preventing the new one from launching - I don't want to launch a new instance, I want to open a link, and I can interact with the running instance just fine and it's definitely not stuck.

This is what I get 50% of the time I try to open a link:

"Close Firefox" "Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile."

(While firefox is perfectly happily running.)

xdg-open https://same-url-iclicked

works. So that makes it even weirder. My system is a boring Fedora 32 desktop, and I didn't change anything I could think of when this suddenly broke.

Here is my two months old ticket that so far went ignored: https://bugzilla.mozilla.org/show_bug.cgi?id=1645038

Asked by itsbrokenforsomereason 6 days ago

Last reply by itsbrokenforsomereason 6 days ago

How can I get back my status bar in Ubuntu?

In Firefox 79.0 running under Windows 8.1 I see the URL of a link when I mouse over it. I have seen several complaints about this as well as workarounds to get rid of it… (read more)

In Firefox 79.0 running under Windows 8.1 I see the URL of a link when I mouse over it. I have seen several complaints about this as well as workarounds to get rid of it. However, I find it very useful as I like to know what I am clicking on before I do so. Unfortunately, this URL preview does not appear in Firefox 79.0 running under Ubuntu Studio 18.04. I have not knowingly overridden this feature, nor can I find a userChrome.css file on the system. How can I get it back in Firefox running under Ubuntu?

Asked by rsbrux 6 days ago

Last reply by cor-el 6 days ago

Can't close tabs in Firefox browser on Chromebook

Installed Firefox on chromebook. Opens fine. But can't close tabs using X at top except main one which then askes to close all tabs. Just keep creating new tabs for eac… (read more)

Installed Firefox on chromebook.

Opens fine. But can't close tabs using X at top except main one which then askes to close all tabs.

Just keep creating new tabs for each link clicked.

Asked by lukaswillcocks 6 days ago

  • Solved

Why isn't DuckDuckGo, Startpage, Searx, etc. Default search engine?

Hello SUMO Team! I always had this question but never really asked it. Why isn't DuckDuckGo or a more privacy based Search engine set as default? You even have to manua… (read more)

Hello SUMO Team!

  I always had this question but never really asked it. Why isn't DuckDuckGo or a more privacy based Search engine set as default? You even have to manually add Startpage and others... 

 It just hurts me how a privacy browser has the Google search engine as default after all, most people come to Firefox for privacy and Google is the opposite. Maybe one of the developers can change that?

Thank you so much for trying to help me and Stay Safe!

Asked by Tommy 2 months ago

Answered by McCoy 1 month ago

YOUTUBE: No Home Page & No Initial Comments Section via FireFox

YOUTUBE: No Home Page & No Initial Comments Section via FireFox: In YouTube via FireFox the YouTube Home Page and Comment Entry on videos is missing. Why is this? Eve… (read more)

YOUTUBE: No Home Page & No Initial Comments Section via FireFox: In YouTube via FireFox the YouTube Home Page and Comment Entry on videos is missing. Why is this? Ever since the dawn of FireFox this has always been missing. Please go use Chrome, Chromium, and Brave. You will see when you select a certain YouTube Channel, you will get a Home Page. You do not get this in FireFox. The second issue that has always been is the fact that you cannot comment on videos because the Comment Entry is missing via FireFox.

FireFox needs to correct this problematic issue. I am using Linux Mint 19.3 Tricia. I have also used Windows 10 and the same problem exist there. I want the FireFox Team to use Linux Mint to see what you get from the FireFox Browser in the Software Manager. Question; is this the same Browser that is currently available via the website? If not, then we have a huge problem with the Linux Team and Linux period that needs to be resolved. Both the FireFox Team & the Linux Team needs to work together to get this fixed.

I would provide Screenshots but I want people to actually go and see for themselves. Go get Linux Mint and install FireFox via the Software Manager. Go to YouTube to see what I am talking about.

Sincerely, KLCJR77 Productions

Asked by KLCJR77 PRODUCTIONS 6 days ago