Támogatás keresése

Kerülje el a támogatási csalásokat. Sosem kérjük arra, hogy hívjon fel egy telefonszámot vagy osszon meg személyes információkat. Jelentse a gyanús tevékenységeket a „Visszaélés bejelentése” lehetőséggel.

Learn More

A témacsoportot lezárták és archiválták. Tegyen fel új kérdést, ha segítségre van szüksége.

Silent install of extension on MAC os

  • 2 válasz
  • 1 embernek van ilyen problémája
  • 36 megtekintés
  • Utolsó üzenet ettől: dcarva

more options

Hello!

I can successfully install a Firefox extension, enabled, on Windows OS using the autoconfig.js in conjunction with mozilla.cfg. However, in MAC OS I can get the extension to install but it still prompts me to install, unlike Windows. It’s as if the mozilla.cfg file is not taking effect and overriding the prompt. Here is where I placed the files:

1) Copied the autoconfig.js file under Applications/firefox.apps/contents/Resources/defaults/pref.

autoconfig.js has:

// Comments - do not remove this line pref("general.config.filename", "mozilla.cfg"); pref("general.config.obscure_value", 0);

2) Copied the mozilla.cfg under Applications/firefox.apps/contents/. Note: I tried putting the mozilla.cfg file in different locations as well. No luck.

Mozilla.cfg has:

pref("extensions.enabledScopes", 15); pref("extensions.autoDisableScopes", 0); pref("extensions.enabledAddons", true);

Any suggestions?

Thanks Danny

Hello! I can successfully install a Firefox extension, enabled, on Windows OS using the autoconfig.js in conjunction with mozilla.cfg. However, in MAC OS I can get the extension to install but it still prompts me to install, unlike Windows. It’s as if the mozilla.cfg file is not taking effect and overriding the prompt. Here is where I placed the files: 1) Copied the autoconfig.js file under Applications/firefox.apps/contents/Resources/defaults/pref. autoconfig.js has: // Comments - do not remove this line pref("general.config.filename", "mozilla.cfg"); pref("general.config.obscure_value", 0); 2) Copied the mozilla.cfg under Applications/firefox.apps/contents/. Note: I tried putting the mozilla.cfg file in different locations as well. No luck. Mozilla.cfg has: pref("extensions.enabledScopes", 15); pref("extensions.autoDisableScopes", 0); pref("extensions.enabledAddons", true); Any suggestions? Thanks Danny

Kiválasztott megoldás

Sorry to waste a posting. I was able to find a separate MAC machine and my steps worked on that machine. Not sure why two Sierra machines would behave differently. I will look into that.

Válasz olvasása eredeti szövegkörnyezetben 👍 0

Összes válasz (2)

more options

Note: Browser version is 49 and Mac OS 10 Sierra.

more options

Kiválasztott megoldás

Sorry to waste a posting. I was able to find a separate MAC machine and my steps worked on that machine. Not sure why two Sierra machines would behave differently. I will look into that.