Can't add, change or save bookmarks - How to fix

A közreműködők még nem fordították le ezt a leírást. Csatlakozzon és segítsen ebben!

This article shows you what to do if you cannot add new bookmarks or make other changes to your bookmarks.

Note: If you have been able to save bookmarks but they are now missing, see Recover lost or missing Bookmarks.

I can't add or change bookmarks

If you can't add new bookmarks or if changes you make to the toolbar are not saved when you restart Firefox, see Changes to toolbars and window sizes are not saved.

If you can't add new bookmarks or make other changes to your bookmarks and you have a Firefox extension related to bookmarks installed (for example, one that synchronizes bookmarks) follow the instructions in Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems to determine if an extension is causing the problem.

I can add or change bookmarks but they are lost when I restart Firefox

If you are able to add, delete, rearrange, and make other changes to your bookmarks but your changes are lost whenever you restart Firefox, try these solutions.

Note: It is recommended that you disable any extensions related to bookmarks, as explained here, before proceeding with the solutions suggested below.

Fix the Bookmarks file

If your changes to your bookmarks do not appear when you restart Firefox, the issue may be that your bookmarks file is write-protected. A write-protected file can't be changed, which prevents Firefox from saving any changes you have made.

Allow Firefox to save bookmark changes:

  1. Open your profile folder:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

    Click the menu button New Fx Menu and then click ExitQuit Close 29

  5. Right-click the file places.sqlite, and select Properties to open the Properties window.
  6. In the Properties window, select the General tab. Near the bottom of the window, verify that Read-only is NOT selected.

    bookmarksnotsaved-readonly.png

To enable writing of your bookmarks file:

  1. Open your profile folder:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

    Click the menu button New Fx Menu and then click ExitQuit Close 29

  5. Select the file places.sqlite.
  6. From the menu bar select the File menu and select Get Info. The places.sqlite info window will open.
  7. In the places.sqlite info window, remove the check mark from the Locked check box.

Create a new Bookmarks file

Bookmarks and browsing history are stored in the Firefox profile folder in the file places.sqlite. If there is a problem with this file, your bookmark changes may be lost whenever you restart Firefox. You can force Firefox to create another places.sqlite file by deleting the existing one.

You might want to print these directions out, or copy them down to reference because you will have to close Firefox to delete the files.

Warning: Once you delete the places.sqlite file, you will lose all of your browsing history.
  1. Open your profile folder:

    At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  2. Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  3. Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

  4. At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

    Click the menu button New Fx Menu and then click ExitQuit Close 29

  5. In your profile folder, delete the places.sqlite file and, if it exists, places.sqlite-journal.
  6. (Optional) Also delete the file localstore.rdf. This will reset any toolbar customizations you have made.

Firefox will create a new places.sqlite file and automatically import the most recent bookmark backup file. Your bookmarks will be backed up, but you will lose your browsing history.




Based on information from Bookmarks not saved (mozillaZine KB)



Share this article: http://mzl.la/ON1mdk

Hasznos volt a leírás? Kérem, várjon...

A következő remek emberek segítettek a leírás megírásában: Tonnes, Verdi, scoobidiver, Swarnava, greasemonkey, adampeebleswrites. Ön is segíthet – tudja meg, hogyan.