Blokklistára kerülnek azok a kiegészítők, amelyek stabilitási és biztonsági problémát okoznak

A Firefox 57-es verziójától verziójától csak a WebExtensions API-k és az új technológiával fejlesztett kiegészítők fognak működni. Ezzel kapcsolatos további információért tekintse meg A Firefox kiegészítők technológiája modernizálódik és a Gyakran ismételt kérdések leírást.

A blokklista (vagy blokkolás) a végső intézkedés, amelyet a Firefox védelme érdekében olyan kiegészítők (kiterjesztések, témák és bővítmények) ellen alkalmaznak, amelyek megszegik a Mozilla kiegészítők útmutatóját.

Mire jó ez a blokklista?

A blokk beállítása után a Firefox blokkolja a nem biztonságos bővítményt a betöltésből. A blokkokat a különböző problémák súlyosságától függően különböző szinteken lehet kibocsátani.

  • A Puha blokkok alapértelmezés szerint letiltják a kiterjesztést, de azt a felhasználó felülbírálhatja és a bővítményt továbbra is használhatja. A puha blokkokat nem rosszindulatú bővítményekhez használják.
  • Kemény blokkok letiltják a bővítményt, és nem engedélyezik, hogy a felhasználó ezt felülírja. Kemény blokkokat a rosszindulatúnak kiegészítők esetén használják.
  • Kattintásra aktiválható blokkok alapértelmezés szerint letiltják a bővítményt, de lehetővé teszi az egyes webhelyek bővítményeinek engedélyezését. Ezt a típusú blokkot nem a rosszindulatú bővítményekhez hazsnálják.

Hogyan lehet megtudni, hogy a kiegészítő blokkolva van-e?

A következő Firefox-értesítés jelenik meg:

A Firefox megállapította, hogy a következő kiegészítők ismert stabilitási és biztonsági problémákat okoznak:


Add-ons Blocklist Mac1

Ahhoz, hogy megakadályozza, hogy ezek a bővítmények fussanak, kattintson a Firefox újraindítása gombra.

Ha a bővítményt kemény blokk fogta meg, akkor nem tudja felülírni a blokkot.

Bekapcsolható a kiegészítő a blokkolás után?

Ha egy bővítmény rajta van a blokklistán, akkor az nem jelenik meg az addons.mozilla.org galériájában, amíg a fejlesztő fel nem tölt egy új verziót, amely megoldja a blokkolás okát.

Ezenkívül a Firefox megakadályozza, hogy telepítse a blokklistán található, nem biztonságos bővítményt azáltal, hogy megjeleníti ezt az üzenetet:

A(z) "kiegészítő_neve" kiegészítő nem telepíthető, mert nagy a kockázata annak, hogy stabilitási vagy biztonsági problémákat okoz.

Ha egy kiegészítő telepítése blokkolva van, akkor ellenőrizze, hogy van-e újabb verzió a telepíteni kívánt kiterjesztésből. Előfordulhat, hogy néhány blokkolás nem oldható fel, és esetleg más bővítményt kell találnia.

Megakadályozza, hogy a bővítmények automatikusan fussanak

A Firefox megakadályozza a bővítmény automatikus futtatását (amely számos problémát előzhet meg). Ha a Firefox blokkol egy bővítményt, egy ehhez hasonló üzenet jelenik meg:

Click to play 1 new

Kiválaszthatja, hogy a bővítményt futtatja, vagy (ha rendelkezésre áll frissítés) frissíti. Ezzel kapcsolatos további információ a Miért kell a bővítmények aktiválására kattintanom? leírásban olvasható.

Az Adobe Flash kivételével az összes NPAPI bővítmény támogatása megszűnt, a Firefox 52-es verziójától kezdve. Ezzel kapcsolatos további információ a kompatibilitás dokumentumban és ebben a leírásban található.

Mi a teendő, ha egy blokklista értesítést kap?

Ha a telepített bővítmény le van tiltva

Fogadja el az értesítést, és indítsa újra a Firefoxot. Ha úgy dönt, hogy felülír egy puha blokkot, akkor azt saját felelősségére tegye.

Bővítmények

Ellenőrizze, hogy van-e a bővítménynek frissített verziója. Ha nincs elérhető bővítményfrissítés, akkor vegye fel a kapcsolatot a blokkolt bővítmény fejlesztőjével.

Feloldható a blokkolás?

A jogsértés súlyosságától, a fejlesztő múltjától és egyéb releváns tényezőktől függően néhány blokkot fel lehet oldani, ha a fejlesztő új jóváhagyott verziót tölt fel. Ha ez megtörténik, azok a felhasználók, akik korábban letöltötték a bővítményt, azonnal újra felhasználhatják, ha újra megjelenik az addons.mozilla.org listájában.

Annak érdekében, hogy mindig a bővítmény (kiterjesztés vagy téma) legfrissebb verzióját használja:
  1. Kattintson a menügombra Fx57menu , majd kattintson a Fx57Addons-icon Kiegészítők menüpontra, és válassza a Kiegészítők panelt.
  2. Kattintson a Add-on Tools Icon beállítás ikonra a menüben, és győződjön meg róla, hogy a Kiegészítők automatikus frissítése beállítást használja.

Milyen, nem biztonságok kiegészítők vannak a blokklistán?

A teljes blokklista itt található.

// A következő remek emberek segítettek a leírás megírásában: Kéménczy Kálmán, misibacsi. Ön is segíthet – tudja meg, hogyan.

Hasznos volt a leírás? Kérem, várjon...

Jelentkezzen a Mozilla támogatás önkéntesének