חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have Firefox 3.08. I cannot update with 3.6 nor 3.5. How do I update my Firefox?

  • אין תגובות
  • 4 have this problem
  • 3 views
more options

I have a Mac OS X, 10.5.8. My Firefox is version 3.0.8. I cannot upgrade to 3.6. I have tried upgrading to 3.5, but I get the error message in regards to not having sufficient privileges for some items.