Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox does not route audio through macOS speakers configuration, it overrides and writes audio straight to master out so audio cannot be routed

more options

Firefox does not obey "Audio MIDI Setup" in Apple macOS at all! It overwrites to whatever selected device master out preventing the audio from being properly routed according to the "Audio MIDI Setup" standard Apple macOS Audio Setup. If you need to route to a Quadraphonic, or anything other than Stereo you won't be able to do it. If you need to route the audio through a special set of virtual audio channels where you can add compressors, EQ, filters, it will not let you. Google Chrome and Safari do this right without any need to change any settings or configurations on the browser side, all you need to do is configure the System-Wide Audio Settings in "Audio MIDI Setup", which is the only way and standard to the audio configuration on any macOS systems.

I am a Linux/Unix System Administrator/Engineer, and I also work with Music Production using special professional interfaces from UA United Audio Apollo x8p and Focusrite. Those interfaces are connected to different sets of speakers, and they also have virtual audio channels where you can add a chain of plugins to treat the audio signal passing through them.

This behavior should be considered a bug, although it is probably by design, which needs to be changed to adhere to the macOS system configuration standards for audio routing.

I tested this with the latest and greatest stable Firefox version, Google Chrome, and Safari. The only browser misbehaving is the Mozilla Firefox.

All Replies (4)

more options

Hi

Please file a new bug about midi on OS X (I searched for an old bug but couldn't find one):

https://bugzilla.mozilla.org/enter_bug.cgi

Cheers! ...Roland

more options

See also:

  • Bug 1552928 - No audio output from Firefox when system sound is routed through third-party driver (Universal Audio Virtual Channels).
  • Bug 1559622 - MacOS audio only works on channels 1&2 on multichannel audio interfaces
more options

Hello Roland, Thank you for the link! I’ll submit a bug. However this has nothing to do with MIDI but with audio signal routing.

more options

Hello cor-el,

Thanks for trying to help.

There is audio output from Firefox when the system is routed through third-party drivers, even Universal Audio Virtual Channels.

So Bug 1552928 does not apply.

Bug 1559622 speaks of macOS audio only working on channels 1 and 2 on multichannel audio interfaces. This should not be a bug, it is normal behavior on macOS, this is solved by reconfiguring the speakers' output for the interface on macOS "Audio MIDI Setup".