Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I click on a link in Twitter, Facebook, other, the page opens but then goes to Yahoo search. How do i kill that?

  • 25 replies
  • 7 have this problem
  • 1451 views
  • Last reply by DavidRopeik

more options

I have Google set as my default search engine. When I am in any of a number of sites and click on a link to open it, the page does open but only momentarily, and then the browser switches over to Yahoo search for that topic. I'd like to keep this from happening but don't know how. I'm on a Mac Book Pro, OS 10.9.5. this was not happening before the switch to Yahoo as the default Firefox search engine.

thanks

Email address removed by moderator. Please do not post sensitive information, and follow Mozilla Support rules and guidelines

Modified by Andrew

Chosen solution

Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.


https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Read this answer in context 👍 0

All Replies (20)

more options

I believe that the British English version still uses Google. You could switch to that, if all else fails.

more options

Chosen Solution

Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.


https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

more options

DavidRopeik said

I have Google set as my default search engine. When I am in any of a number of sites and click on a link to open it, the page does open but only momentarily, and then the browser switches over to Yahoo search for that topic. I'd like to keep this from happening but don't know how. I'm on a Mac Book Pro, OS 10.9.5. this was not happening before the switch to Yahoo as the default Firefox search engine. thanks Email address removed by moderator. Please do not post sensitive information, and follow Mozilla Support rules and guidelines
more options

Fred

thanks. seems to be working.

David

more options

Some installers will change settings without permission from the owner. Safe Surfing.

more options

That seems to happen more often these days. I have user.js files for all my Mozilla applications to preserve my settings the way I like them.

more options

Fred, fitniarry..thanks for your suggestions, but...

Didn't work. In Twitter when I go to a link up comes the page, then it switches over to Yahoo. but only on when I click on some links. This is not about Yahoo as the default browser. That's fine. It's about clicking on links that open, but then the page switches to Yahoo.

more options

I want you to follow these instructions.

Open that web page. Move the mouse over one of the links, then right click and select Copy Link Location. Now paste it someplace. Now go back to that same link. A small windows will open at the bottom of the browser window. Is the link in the small window the same as what you copied before. And post the links(s) here.

more options

FredMcD, thank you for your help in this.

I copied the link http://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0CCAQFjAA&url=http%3A%2F%2Fwww.aaas.org%2F&ei=_CDMVJDjJYu6ggSUrICwCQ&usg=AFQjCNF2TmSKtn3_NU20wh7uJAsOC7HYVg&bvm=bv.85076809,d.eXY

and compared it to the one in the bottom window and they are the same. The problem is, when I click on the link to open it (the home page of the AAAS in this case), it defaults to a Yahoo search page with 'errorhandler' in the url. I have copied the entire url of the Yahoo page that comes up, below.

https://search.yahoo.com/yhs/errorhandler?hspart=gt&hsimp=yhse-gt&q=www.aaas.org%2Fsites%2Fall%2Fthemes%2Faaas_main%2Fimg%2Fbg_mini_blue_2015&type=769480

more options

See if this works better; http://www.aaas.org/

more options

Fred...thanks, but this is not about one site. The same thing happens often, with many sites, when i click a link that has come up in Google search, or on Twitter or Facebook or within a story I'm reading. The link takes me to the url of what it was supposed to take me too, then within a second or so it switches to that Yahoo 'error handler' url, a page that offers search for similar sites. Again, thank you.

more options

Open your Add-ons Manager, and disable Google or Yahoo Anything ! Then open your computers Programs folder, and do the same here.

more options

Sounds awesome, but I'm too dumb to know where "Add-Ons manager" or Programs Folders are. Can't find them in System Preferences or Finder Preferences, with a spotlight search, or in Applications. I'm running a Power Book Pro Mac OS 10.9 Signed, Embarrassed. (thanks)

more options

Oops, Sorry  ;-/

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac:<Command>) <Shift> A)


Using your file browser, open the Programs folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.

more options

AAAIIGGH! when i first typee about:addons in the address bar of the browser and clicked...it opened and a quick scan showed nothing about Google or yahoo. But that was on "extensions' and when i clicked on another option in the left column to see if Google or yahoo were elsewhere...Firefox took me to the YAHOO PAGE OF DEATH! AAAAAIIIGGGH

Re; Programs folder...sounds like on a Mac that's simply my Applications folder. Google chromes is there as an app (nothing about yahoo), but won't deleting delete all my bookmarks, etc.? (thanks)

more options

It sounds as if Firefox using American English is hard-coded to switch to Yahoo, even if a web page has a search box for Google embedded in it. I believe that British English Firefox does not do that? Not sure, since I use SeaMonkey for browsing these days.

more options

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

Fred, glad you're still with me! Here's the screenshot. what happens is, step by step; I am in a Firefox browser window and click AAAS in the Google search window. (remember, this happens with way more than just the AAAS site, I'm just using that as an example.) The Google page opens up with search choices for :"AAAS" and I click on the first one, and the AAAS page open for about one second, and the the screen changes to....what you see in the screen shot. This also sometimes happens when I am in Twitter, or Facebook, or just reading some article, and click on an interesting link...that link opens, but quickly changes to the Yahoo search page that seems to be related to that subject.

more options

I think it's time to get tough.

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

http://www.clamxav.com/ free malware scanner for Mac OS X https://discussions.apple.com/docs/DOC-3291

more options

FredMcD,

Hi again. I tried to download a fresh version of firefox. No luck. and I noticed something that may be relevant at the top of the YAHOO SCREEN OF DEATH that pops up "DNS Yahoo solution error" at the top of the page. screenshot attached.

  1. 1
  2. 2