Ehechauka porandu heramoĩpyréva: Ehechaukapaite porandu
  • Jokopyre

this forum board

Locking this thread, please continue here: [/questions/1440721] Can someone please tell me how to answer questions asked, in emails to me, receoved from support helpers. … (emoñe’ẽve)

Locking this thread, please continue here: [/questions/1440721]
Can someone please tell me how to answer questions asked, in emails to me, receoved from support helpers. In ~6 emails received so far, my only response option looks like clicking the "Mark It as Solved" button...I can't see how to answer, for example, that I'm using Debian Buster, with KDE. Also, jonzn4SUSE asked me to "see screenshot" of his SUSE distribution, but I can't see that image, nor a file attachment. Thanks again.

Oporandu lee.hinklemanOjapo 1 jasy

  • Moĩporãmbyre

Installing custom Firefox extension

I'm at a loss for words here. I have a website I frequent and it has a really annoying behavior. I'm a developer so finally I mustered the strength to do something about … (emoñe’ẽve)

I'm at a loss for words here. I have a website I frequent and it has a really annoying behavior. I'm a developer so finally I mustered the strength to do something about it. I googled how to create an extension in Firefox and within 5 minutes I had a working extension that solved their annoyance. However, I can only load it temporarily. If I close Firefox, it goes away. When I try to actually install it, it says I need to have it signed. I have now spent the better part of an hour trying to find out how to self sign it. I refuse to believe that I have to submit this to Mozilla for me to be able to install my own code. Can someone please send me in the direction of how i self sign and install my own extension. I have no intention of publishing, I only want to run this for myself.

Oporandu viktor37Ojapo 1 jasy

Ombohovaipyre cor-elOjapo 1 jasy

  • Moĩporãmbyre

JavaScript in firefox.cfg can't access `document`

As I understand, `autoconfig.js` (with `firefox.cfg`) can be used to have JavaScript run during startup to control Firefox's UI elements. I have set up `autoconfig.js` i… (emoñe’ẽve)

As I understand, `autoconfig.js` (with `firefox.cfg`) can be used to have JavaScript run during startup to control Firefox's UI elements.

I have set up `autoconfig.js` in my `/usr/lib/firefox-developer-edition/defaults/pref` folder (I'm on EndeavourOS Linux). As instructed here, I've already put the two required files, `autoconfig.js` and `firefox.cfg` in their correct folders (`/usr/lib/firefox-developer-edition/defaults/pref` and `/usr/lib/firefox-developer-edition` in my machine).

The file `firefox.cfg` contains the following code:

 //
 (() => {
   var tabbar = document.getElementById("TabsToolbar");
 })();


However, every time I run Firefox, this message will appear:

 "Failed to read the configuration file. Please contact your system administrator."


If I empty out the `firefox.cfg` file, Firefox will run normally without showing the error message. It will also run normally if I just have something like this in the file:

 //
 (() => {
   var testVar = "";
 })();


I don't understand why the JavaScript code can't access the Firefox UI elements through `document` or `window.document`. If `autoconfig.js` isn't build for that, what should I use to change my browser's UI elements through JavaScript?

Thank you.

Oporandu jazaliOjapo 1 jasy

Ombohovaipyre cor-elOjapo 1 jasy

  • Moĩporãmbyre

What is the Firefox Installer?

I'm trying to migrate to the newest version of Firefox on an old installation of Fedora. I've downloaded and unpacked the installation files but can't identify the insta… (emoñe’ẽve)

I'm trying to migrate to the newest version of Firefox on an old installation of Fedora. I've downloaded and unpacked the installation files but can't identify the installer. All I probably need is the name, as I know how to make it executable and run it once I know what file it is.

Oporandu sideburnsOjapo 1 jasy

Ombohovaipyre sideburnsOjapo 1 jasy

  • Moĩporãmbyre

"this page is slowing down firefox"

How can I turn this message off? Some sites I visit give me that message, it shows up when I'm typing a reply to something which pushes the page lower and fouls up my ab… (emoñe’ẽve)

How can I turn this message off? Some sites I visit give me that message, it shows up when I'm typing a reply to something which pushes the page lower and fouls up my ability to keep typing, then if goes away, comes back, goes away ... I just want to kill the message entirely. I'm not worried about speed, there's nothing to fix, I just want the message gone.

Oporandu rayandrewsOjapo 1 jasy

Ombohovaipyre cor-elOjapo 1 jasy

  • Moĩporãmbyre

Firefox themes

Saved themes in Firefox color not visible in add-ons manager. Does not fix itself in safe mode. One of the saved themes is a default preset I liked, the other is a preset… (emoñe’ẽve)

Saved themes in Firefox color not visible in add-ons manager. Does not fix itself in safe mode. One of the saved themes is a default preset I liked, the other is a preset I made myself, using all options except advanced colors.

Oporandu Lord_VoidwrathOjapo 1 jasy

Ombohovaipyre Lord_VoidwrathOjapo 1 jasy

  • Moĩporãmbyre

youtube ad blocker not blocking ads

I have an add-on ad blocker for youtube and have never gotten ads. This afternoon that stopped. I get ads with every video I click and there is no 'skip ad' on the scr… (emoñe’ẽve)

I have an add-on ad blocker for youtube and have never gotten ads. This afternoon that stopped. I get ads with every video I click and there is no 'skip ad' on the screen. I added another top rated youtube add blocker, quit firefox and then opened it again. Before, if I clicked a video it started an ad and I could go back and then hit the video again, but now that doesn't work, but if I select to show the video in a new tab, there are no ads in that tab. What can I do to make the ads stop like they used to and never appear? Yes and my OS is Ubuntu 22.04

Oporandu pdsimdarsOjapo 1 jasy

Ombohovaipyre TyDraniuOjapo 1 jasy

  • Moĩporãmbyre

Copy is completely broken in the Linux .deb version of Firefox

As the title states. At least half the time when you try right-click and use the "Copy" function, the option is greyed out. If you try to Ctrl+Shift+C, it opens dev too… (emoñe’ẽve)

As the title states. At least half the time when you try right-click and use the "Copy" function, the option is greyed out. If you try to Ctrl+Shift+C, it opens dev tools! This happens on multiple systems that I have that are based on Debian/Ubuntu. So basically, copy functionality is broken for Firefox Linux users...

Oporandu cvpsmithOjapo 1 jasy

Ombohovaipyre cor-elOjapo 1 jasy

  • Moĩporãmbyre

How do I stop "momentum" scrolling?

Hi there, On Firefox, I'm experiencing "momentum" scrolling where, when I scroll using the trackpad, after I lift my fingers off, it keeps scrolling for a bit. This is … (emoñe’ẽve)

Hi there,

On Firefox, I'm experiencing "momentum" scrolling where, when I scroll using the trackpad, after I lift my fingers off, it keeps scrolling for a bit.

This is not the same thing as smooth scrolling. Disabling smooth scrolling does not disable this behaviour, and I use smooth scrolling on plenty of programs without it experiencing this "sliding" "momentum" on any of them except Firefox. I've also used Firefox before with trackpads without experiencing this.

How can I disable this?

Oporandu revsuineOjapo 1 jasy

Ombohovaipyre TyDraniuOjapo 1 jasy

  • Moĩporãmbyre

How to separate inactive tabs ? with either bar or boxes

Initial post: https://forums.debian.net/viewtopic.php?p=792869#p792869 cat history.log-* history.log | grep -i firefox -B2 Start-Date: 2024-02-11 19:48:58 Commandline… (emoñe’ẽve)

Initial post: https://forums.debian.net/viewtopic.php?p=792869#p792869

cat history.log-* history.log | grep -i firefox -B2

Start-Date: 2024-02-11 19:48:58 Commandline: /usr/bin/unattended-upgrade Upgrade: firefox-esr:amd64 (102.15.0esr-1~deb11u1, 115.7.0esr-1~deb11u1)

before: https://support.mozilla.org/en-US/kb/search-open-tabs-firefox https://addons.mozilla.org/fr/firefox/addon/simple-tab-groups/ https://www.ghacks.net/2021/03/09/manage-container-tabs-efficiently-from-a-side-panel-with-the-container-tabs-sidebar-extension-for-firefox/ now: https://addons.mozilla.org/fr/firefox/addon/tab-stash/ https://www.majorgeeks.com/files/details/sidebar_tabs.html

How do I put bar between tabs, or, each tab inside an individual box ? I have tried many codes from various forums, but since this update, FF seems to ignore ./chrome/userChrome.css completely.

Oporandu Benoit-Pierre DEMAINEOjapo 2 jasy

Ombohovaipyre jscher2000 - Support VolunteerOjapo 2 jasy

  • Moĩporãmbyre

Firefox always sets address to https

I assume that it's the same problem as this: https://support.mozilla.org/en-US/questions/1388431 but there is no solution. https only mode is not active browser.fixup.a… (emoñe’ẽve)

I assume that it's the same problem as this: https://support.mozilla.org/en-US/questions/1388431 but there is no solution.

https only mode is not active

browser.fixup.alternate.protocol is set to http from https browser.urlbar.autoFill is set to false

Nothing helped.

I get that this default makes sense but since so many local tools don't use http there should be at least 1 working option to disable this behavior at least for certain sites.

Oporandu danielw90.dw+firefoxOjapo 2 jasy

Ombohovaipyre TerryOjapo 2 jasy

  • Moĩporãmbyre

Default browser on linux fails on file:/// URLs.

I just wrote this blog post and someone suggested I contact you. I have my default browser set to Firefox on Linux (Debian Bookworm). When I open an http:// or https:// … (emoñe’ẽve)

I just wrote this blog post and someone suggested I contact you.

I have my default browser set to Firefox on Linux (Debian Bookworm). When I open an http:// or https:// URL, it opens in Firefox, but when I open a file:/// URL, it opens in Chromium. It seems that file:/// URL makes it resort to the MIME type.

Is there anything Firefox can do here or is this a Debian or freedesktop.org issue?

Thanks!

Tim

Oporandu oylenshpeegulOjapo 2 jasy

Ombohovaipyre oylenshpeegulOjapo 2 jasy

  • Moĩporãmbyre

Profile lock prevents launch on workstations with shared remote home

I am using Firefox in a Linux environment with multiple workstations, where I may be logged into more than one workstation at once. The workstations have an auto-mounted … (emoñe’ẽve)

I am using Firefox in a Linux environment with multiple workstations, where I may be logged into more than one workstation at once. The workstations have an auto-mounted home file system such that my home directory (including my Firefox profile directory) are shared.

Because of this, when I try to launch Firefox on a second workstation, I get an error saying "Firefox is already running but is not responding". I have read the support articles about this issue, and other community support threads, but none of them address this use case.

I wish to use the same profile, so that I still have all my bookmarks and such, and have them continue to stay up-to-date. How can I do so in this environment?

Oporandu tmorris4Ojapo 2 jasy

Ombohovaipyre cor-elOjapo 2 jasy

  • Moĩporãmbyre

Two devices can’t be separated by Sync in Mozilla account

I am logged into my Mozilla account on four devices: Laptop Linux, Desktop Linux, Desktop Windows, Phone Android. However, when I try “Send tab to device” or list the dev… (emoñe’ẽve)

I am logged into my Mozilla account on four devices: Laptop Linux, Desktop Linux, Desktop Windows, Phone Android. However, when I try “Send tab to device” or list the devices in the account settings, the two Linux devices are not shown separately, so I can’t send a tab from Laptop Linux to Desktop Linux or vice versa. In fact, when I edit the Device name on either of the Linux device, that name will also be shown on the other device.

How is this possible? How can I disentangle the two devices?

Oporandu Simon AlbrechtOjapo 2 jasy

Ombohovaipyre jonzn4SUSEOjapo 2 jasy

  • Moĩporãmbyre

Load New Tab's Content At Vitis

Just like the Android version of Firefox does! It opens the new tab(s), but load each tab at visit! Desktop Firefox also does this at [History / Restore Previous Session… (emoñe’ẽve)

Just like the Android version of Firefox does! It opens the new tab(s), but load each tab at visit!

Desktop Firefox also does this at [History / Restore Previous Session]. All the previously opened tabs are opened again, but each of them only loads at visit.

This is I would like to have as default behaviour with newly opened tab(s) in Firefox. > Tab opens. > It hasn't loaded yet! > At visit it loads the content.

PS: I tried, but didn't work: > about:config _ browser.sessionstore.restore*demand (switch) > Addon _ LoadTabOnSelect 3 (But it worked weirdly.)

Oporandu Horváth AttilaOjapo 2 jasy

Ombohovaipyre zeroknightOjapo 2 jasy

  • Moĩporãmbyre

How can I disable searching when typing a question mark in the awesomebar?

I use a lot of keyword search engines. This means I can type something like `kagi foobar` to search Kagi for `foobar`. However the awesome bar has a "feature" where if yo… (emoñe’ẽve)

I use a lot of keyword search engines. This means I can type something like `kagi foobar` to search Kagi for `foobar`. However the awesome bar has a "feature" where if you type a question mark (?) anywhere it instead uses the default search engine. This means that `kagi How do I cook a turkey?` searches my default search engine for "kagi How do I cook a turkey?" rather than searching Kagi (based on the `kagi` keyword). Is there a way to disable this behaviour?

I have searched about:config and "Search Shortcuts" in preferences doesn't have a `?`. I never use `?` as a shortcut to search (I just type the keyword for the engine I want) so completely removing it would be perfect.

Oporandu Kevin CoxOjapo 4 jasy

Ombohovaipyre zeroknightOjapo 2 jasy

  • Moĩporãmbyre

FF pausing videos if more than one is playing on separate tabs

I don't remember with which version of Firefox for Linux this issue started; but I cannot play multiple videos at once. If I open two tabs with video sources one of the v… (emoñe’ẽve)

I don't remember with which version of Firefox for Linux this issue started; but I cannot play multiple videos at once. If I open two tabs with video sources one of the videos will automatically pause if I start watching the second one.

I have tried disabling my add-ons but the issue persists and I don't think there should be any reason for any of them interfering with videos.

Currently running Firefox 120.0 (64-bit - Arch Linux)

Oporandu 12fdoashf123Ojapo 4 jasy

Ombohovaipyre zeroknightOjapo 4 jasy