Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How to avoid bookmarklet causing popup warning

  • Gan freagra
  • 1 leis an bhfadhb seo
  • 18 views
more options

I like firefox's popup blocker, but since recently it's not been able to handle my bookmarklet that pops up a window. It causes a popup blocked message *as if the popup had come from the site I was visiting* whereas actually it's come from clicking the button in the toolbar.

e.g. I have a bookmarklet that bookmarks the current page with a Nextcloud service. It uses a popup to do this.

Firefox's popup options are (a) allow all popups - no thanks! (b) allow popups for the site I'm visiting - again, not what I want, or (c) allow this specific popup this time.

It would be great if there were options like:

- allow popups taking me to domain/url x (e.g. I trust my nextcloud site) - allow popups clicked from the bookmarks toolbar - allow popups from a particular bookmarklet

Do any work arounds exist? I'm sure this has only recently been a problem as I've always used the popup blocker.

I like firefox's popup blocker, but since recently it's not been able to handle my bookmarklet that pops up a window. It causes a popup blocked message *as if the popup had come from the site I was visiting* whereas actually it's come from clicking the button in the toolbar. e.g. I have a bookmarklet that bookmarks the current page with a Nextcloud service. It uses a popup to do this. Firefox's popup options are (a) allow all popups - no thanks! (b) allow popups for the site I'm visiting - again, not what I want, or (c) allow this specific popup this time. It would be great if there were options like: - allow popups taking me to domain/url x (e.g. I trust my nextcloud site) - allow popups clicked from the bookmarks toolbar - allow popups from a particular bookmarklet Do any work arounds exist? I'm sure this has only recently been a problem as I've always used the popup blocker.