Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

UI elements on 27" iMac are far too small

  • 4 réponses
  • 0 a ce problème
  • 15 vues
  • Dernière réponse par Bob-SF

more options

I've used Firefox for years on my iMac with its 5K display. The UI was fine. Today I had to delete and then re-install Firefox because the program had started crashing repeatedly. I lost a lot of bookmarks & tabs. Upon opening the new install, I saw that Firefox now shows a miniaturized UI that is very difficult to read. I refer to the UI elements (tabs, bookmarks bar, URL/search field), not the web pages themselves. As part of the installation, I went through all the settings, and I didn't see any controls for the sizes of UI elements. So I searched the internet and found many reports of similar problems over many years. I tried a few suggested changes to about:config settings. Nothing has worked. I am exasperated. What am I missing? Can anyone help?

I've used Firefox for years on my iMac with its 5K display. The UI was fine. Today I had to delete and then re-install Firefox because the program had started crashing repeatedly. I lost a lot of bookmarks & tabs. Upon opening the new install, I saw that Firefox now shows a miniaturized UI that is very difficult to read. I refer to the UI elements (tabs, bookmarks bar, URL/search field), not the web pages themselves. As part of the installation, I went through all the settings, and I didn't see any controls for the sizes of UI elements. So I searched the internet and found many reports of similar problems over many years. I tried a few suggested changes to about:config settings. Nothing has worked. I am exasperated. What am I missing? Can anyone help?
Captures d’écran jointes

Solution choisie

It was working to me. It can interact with OS settings. Try to increase the value to 2 or 3.

Lire cette réponse dans son contexte 👍 1

Toutes les réponses (4)

more options

Go to about:config and set layout.css.devPixelsPerPx = 1.5.

more options

That setting just makes everything even smaller, both UI and web page display. Have you tried this before with success? Does this config setting interact with some other setting?

more options

Solution choisie

It was working to me. It can interact with OS settings. Try to increase the value to 2 or 3.

Modifié le par TyDraniu

more options

Thanks, TyDraniu. Changing layout.css.devPixelsPerPx to 2.0 did nothing, but I just tried 3.0, and it worked! The UI elements immediately became a readable size. This is a huge relief, as my eyes were hurting from the tiny interface. Much appreciated.