Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

opening saved webpages

  • 7 réponses
  • 1 a ce problème
  • 27 vues
  • Dernière réponse par cor-el

more options

I'm having problems opening saved (archived) Facebook pages. The problem is the page opens without formatting or layout, just text and images.

I've had this problem before when I was using Firefox 68. The solution was to roll back a security patch by doing the following as proposed by jscher2000:

You can roll back the patch as follows if you want to see what difference it makes:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste uniq and pause while the list is filtered

(3) Double-click the privacy.file_unique_origin preference to switch the value from true to false

That had worked until recently. I checked "privacy.file_unique_origin" and its still has a value of 'false' but the webpages are not opening properly, even ones I saved over the last few years.

What can I do?

Solution choisie

The privacy.file_unique_origin pref is no longer supported in Firefox 95+. For now there is still security.fileuri.strict_origin_policy that you can try instead, but this pref will be removed as well in the future, so that it is no longer possible to bypass strict origin.

Safest is to use a separate profile for testing locally with this feature disabled.

Lire cette réponse dans son contexte 👍 0

Toutes les réponses (7)

more options

How were the pages saved? Links? HTML? . . . .

Have you tried to refresh the page?

Cela vous a-t-il été utile ?

more options

Solution choisie

The privacy.file_unique_origin pref is no longer supported in Firefox 95+. For now there is still security.fileuri.strict_origin_policy that you can try instead, but this pref will be removed as well in the future, so that it is no longer possible to bypass strict origin.

Safest is to use a separate profile for testing locally with this feature disabled.

Modifié le par cor-el

Cela vous a-t-il été utile ?

more options

Hi Claude, until a new and SAFE workaround is discovered, I suggest opening your saved Facebook pages in another browser. Hopefully we'll remember to update this thread but if you don't get any new replies in the next two weeks, feel free to add a new reply so it moves back to the top of the list.

Cela vous a-t-il été utile ?

more options

The solution proposed by cor-el worked! Hopefully for a while.

When workarounds are not available, how can I save Facebook pages without running in this problem?

Is someone working to fix this issue?

Cela vous a-t-il été utile ?

more options

That workaround creates a security hole allowing access to your hard drive. You should only use it while actively working with the saved files and then turn it back off.

Test this add-on for saving FB pages and see whether it works. It doesn't required scrabbling around on your disk to reconstruct the page: https://addons.mozilla.org/firefox/addon/single-file/

Cela vous a-t-il été utile ?

more options

Good point. I'll try the add-on and get back with the results. Thank you

Cela vous a-t-il été utile ?

more options

Safest for opening files locally is to use a separate profile with this feature disabled.

Cela vous a-t-il été utile ?

Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.