Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

DuckDuckGo giving "The page isn’t redirecting properly" (301 redirect chain in devtools) when the search query contains the word "localhost".

  • 9 réponses
  • 1 a ce problème
  • 12 vues
  • Dernière réponse par cor-el

more options

I also tested this on chromium and everything was working fine there.

I also tested this on chromium and everything was working fine there.

Toutes les réponses (9)

more options

Aaron said

I also tested this on chromium and everything was working fine there.

The version is 95.0.2 on ArchLinux.

The search query only has to contain the word localhost for it to work.

How to replicate: Entering this domain already causes the issue for me: https://duckduckgo.com/?t=ffab&q=testing+localhost

Modifié le par Aaron

Cela vous a-t-il été utile ?

more options

Steps to replicate.

Modifié le par jonzn4SUSE

Cela vous a-t-il été utile ?

more options

Where are you entering your query for localhost?

If you are searching in Firefox's address bar:

localhost (by itself, without any additional terms) is pre-reserved as a reference to a local server address, so it doesn't go directly to your default search engine. To turn off the exception:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.fixup.domainwhitelist.localhost and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

Does that help?

If you later need to load an address on localhost after making this change, use the protocol before it (for example, https://localhost).

Cela vous a-t-il été utile ?

more options

You can possibly set browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar = false on the about:config page to prevent the search bar on the Firefox Home new tab page going to the location bar.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

DISCLAIMER: modifying prefs directly via the about:config page is not officially supported and there is no guarantee that this will keep working in future releases or otherwise "breaks" Firefox.

Cela vous a-t-il été utile ?

more options

cor-el said

You can possibly set browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar = false on the about:config page to prevent the search bar on the Firefox Home new tab page going to the location bar. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. DISCLAIMER: modifying prefs directly via the about:config page is not officially supported and there is no guarantee that this will keep working in future releases or otherwise "breaks" Firefox.

My issue arises when the search query contains the word localhost.

Reproduce: https://duckduckgo.com/?t=ffab&q=testing+localhost.

Modifié le par Aaron

Cela vous a-t-il été utile ?

more options

jscher2000 said

Where are you entering your query for localhost? If you are searching in Firefox's address bar: localhost (by itself, without any additional terms) is pre-reserved as a reference to a local server address, so it doesn't go directly to your default search engine. To turn off the exception: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. (2) In the search box in the page, type or paste browser.fixup.domainwhitelist.localhost and pause while the list is filtered (3) Double-click the preference to switch the value from true to false Does that help? If you later need to load an address on localhost after making this change, use the protocol before it (for example, https://localhost).


My issue arises when the search query contains the word localhost.

Reproduce: https://duckduckgo.com/?t=ffab&q=testing+localhost.

Modifié le par Aaron

Cela vous a-t-il été utile ?

more options

Here is what I get. see screenshot Show what you get.

Cela vous a-t-il été utile ?

more options

What address appears in the address bar when you get the error? Is it a DDG address or some other address?

Cela vous a-t-il été utile ?

more options

Does this also happen if you initiate a search via the location/address bar by using the '@' search modifier ?

Cela vous a-t-il été utile ?

Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.