Prohledat stránky podpory

Vyhněte se podvodům. Za účelem poskytnutí podpory vás nikdy nežádáme, abyste zavolali nebo poslali SMS na nějaké telefonní číslo nebo abyste sdělili své osobní údaje. Jakékoliv podezřelé chování nám prosím nahlaste pomocí odkazu „Nahlásit zneužití“.

Learn More

Adding default settings throuh mozilla.cfg not working on firefox-26

  • 1 odpověď
  • 15 má tento problém
  • 5624 zobrazení
  • Poslední odpověď od cor-el

more options

I would like to set proxy settings to all the firefox process for non-root users, Earlier i used to do this by adding below lines in /usr/lib64/firefox/defaults/preferences/channel-perf.js

pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg");

and creating mozilla.cfg file in /usr/lib64/firefox directory as followd

lockPref("network.proxy.type", 1); lockPref("network.proxy.http", "127.0.0.1") lockPref("network.proxy.http_port", 3128) lockPref("network.proxy.share_proxy_settings", true)


How do i achieve the same in Firefox-26

I tried the following

In the /usr/lib64/firefox/browser/defaults/preferences directory, i created file channel-pref.js as follows pref("general.config.obscure_value", 0) pref("general.config.filename", "mozilla.cfg");


create mozilla.cfg file in /usr/lib64/firefox directory , then using moz-byteshift.pl i modified the mozilla.cfg moz-byteshift.pl -s 13 <mozilla.cfg.txt >mozilla.cfg

but it still doesn't work ,

Any information on how to make this work

Všechny odpovědi (1)

more options

It is best to leave the channel-prefs.js file alone and create a specific local-settings.js file to specify using mozilla.cfg in the defaults\pref folder where you also find the channel-prefs.js file.

pref("general.config.filename", "mozilla.cfg");

See:

These functions can be used in the mozilla.cfg file:

defaultPref();  // set new default value
pref();         // set pref, but allow changes in current session
lockPref();     // lock pref, disallow changes

Note that only the first pref line you posted is ending with a semi colon.
Also make sure that the first line of mozilla.cfg is a comment line as this line is always skipped.

//
lockPref("network.proxy.type", 1);
lockPref("network.proxy.http", "127.0.0.1");
lockPref("network.proxy.http_port", 3128);
lockPref("network.proxy.share_proxy_settings", true);